summaryrefslogtreecommitdiff
path: root/sci-calculators/wcalc
diff options
context:
space:
mode:
Diffstat (limited to 'sci-calculators/wcalc')
-rw-r--r--sci-calculators/wcalc/Manifest3
-rw-r--r--sci-calculators/wcalc/files/0001-fix-bashism-in-configure-script.patch28
-rw-r--r--sci-calculators/wcalc/wcalc-2.5.ebuild16
3 files changed, 43 insertions, 4 deletions
diff --git a/sci-calculators/wcalc/Manifest b/sci-calculators/wcalc/Manifest
index 7f53bc5b2f90..682b9d9f1286 100644
--- a/sci-calculators/wcalc/Manifest
+++ b/sci-calculators/wcalc/Manifest
@@ -1,4 +1,5 @@
+AUX 0001-fix-bashism-in-configure-script.patch 843 BLAKE2B c2182e49884db916dff35129303b5b67d55648caab93b6a0c9621e0519a9fc22bcfdbb060fde3b004f514d9c1598082e45a17f67f59d86db942f06a907f80753 SHA512 0c770995c94bb4a74ac98e180b70fe56026c047cc214607497d4a007b1581a43ae0710bd4ab4f5a8063b4c1fd768d593e7351587d1f01cd0504ecae42a1e4183
AUX wcalc-2.5-AR.patch 247 BLAKE2B 915558fce783f7046e2942bdef285f1a3f5537faa4d215477c7a6d4dcac5dc11c059cb24d88eb252b8f1f8649ce5d394af29ade3f569b427addb7797cc201d03 SHA512 789610d5fd7ec215f76f082a337312a8c5cee8a76613a2c682c996040325f5e459a7a596c5937fc4f1a43c57bef8161b5ee39052493e7705f58ac7900ab9591d
DIST wcalc-2.5.tar.bz2 413637 BLAKE2B 6093d73249548c90ba544b7445846bf6021cfc567fd6a7a269412b48ce8e4208ec19193dce878a5799f78f84e64fad59622cccae303d433ed58aa7d0ee0ffce1 SHA512 3eedcf8c93bd33ca0a4bb35867e3157adbde2999d9fc1826ad55281fd927546614f6b1a28900b4cae87a0d15888cd62a04fa2adca316d7cf309af7a2fefea704
-EBUILD wcalc-2.5.ebuild 768 BLAKE2B 77d0d86b6a2d0538e861c440b357547496076fe5db0d886e8b997725ac35ef847c1092ce7b1a66150705199b8363561ae1202e67e901f86461959caddf5f68b5 SHA512 ad20024f9aaebb96c07cb66b16d758a4f078f17d85d3d43cbef638b634deef3be8ac30748f6905ee7c731e68748d64a1083a0c0dbdbb580dfbbe8c355d7e4db2
+EBUILD wcalc-2.5.ebuild 1036 BLAKE2B fe8fe2e4f8d37608bf7585c741993482ca728869a66624f44b3bcb8f160c39a16902fb6a703b63e4884cb72f948ff62cbed077cce8a102d42fa7e108f4a3c05a SHA512 d513d5177993886b8c4fbfc637761a53cbdf894ee59989526dd958852022828eb3f988c51520a60f46a777833eaaaee15753563c7f537eb070c449fe4c68a415
MISC metadata.xml 812 BLAKE2B fb50f03932be0021aa58823095c7d5ab271decdcebdae8eba59cc9ad52c97b4dbffbce46412954455f1eddf1ed0ef2e1891855296124bea6bbd8dfc663e6271a SHA512 30d7b6a999e2041c933a36cf7327e7c19ee20542e21e0a8be263cebda89132461e6b304317fc4c2ffaefdd71b7ee26eeade69a82b8649fbd284f7be74a343e1d
diff --git a/sci-calculators/wcalc/files/0001-fix-bashism-in-configure-script.patch b/sci-calculators/wcalc/files/0001-fix-bashism-in-configure-script.patch
new file mode 100644
index 000000000000..97cd3772309b
--- /dev/null
+++ b/sci-calculators/wcalc/files/0001-fix-bashism-in-configure-script.patch
@@ -0,0 +1,28 @@
+From b533584038a4ab8709fb8c88d7c4441f22b5de78 Mon Sep 17 00:00:00 2001
+From: Eli Schwartz <eschwartz93@gmail.com>
+Date: Wed, 13 Mar 2024 18:15:00 -0400
+Subject: [PATCH] fix bashism in configure script
+
+double equals is horrid and banned. Do not ever use it, but definitely
+don't use it in POSIX sh, where it doesn't exist *even* as an alias for
+single equals.
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 1db142d..af541af 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -48,7 +48,7 @@ AC_PROG_RANLIB
+ AC_PROG_YACC
+ AM_PROG_AR
+ AM_PROG_LEX
+-AS_IF([test "x$LEX" == x],
++AS_IF([test "x$LEX" = x],
+ [AC_MSG_ERROR([A Lex/Flex program is required in order to compile wcalc.])],
+ [AS_IF([test "x$LEX" != xflex],
+ [LEX="$SHELL $missing_dir/missing flex"
+--
+2.43.2
+
diff --git a/sci-calculators/wcalc/wcalc-2.5.ebuild b/sci-calculators/wcalc/wcalc-2.5.ebuild
index e21f19c9610f..6fd0f9e9cae0 100644
--- a/sci-calculators/wcalc/wcalc-2.5.ebuild
+++ b/sci-calculators/wcalc/wcalc-2.5.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools desktop
+inherit autotools desktop flag-o-matic
DESCRIPTION="A flexible command-line scientific calculator"
HOMEPAGE="http://w-calc.sourceforge.net/"
@@ -20,7 +20,10 @@ RDEPEND="
readline? ( sys-libs/readline:0= )"
DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}"/${P}-AR.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-AR.patch
+ "${FILESDIR}"/0001-fix-bashism-in-configure-script.patch
+)
src_prepare() {
default
@@ -28,6 +31,13 @@ src_prepare() {
}
src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/862384
+ #
+ # Upstream is sourceforge. Last release in 2015, last activity 2021. Not
+ # submitting a bug report for now. -- Eli
+ filter-lto
+
econf $(use_with readline)
}