summaryrefslogtreecommitdiff
path: root/sci-calculators/wcalc/wcalc-2.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-calculators/wcalc/wcalc-2.5.ebuild')
-rw-r--r--sci-calculators/wcalc/wcalc-2.5.ebuild16
1 files changed, 13 insertions, 3 deletions
diff --git a/sci-calculators/wcalc/wcalc-2.5.ebuild b/sci-calculators/wcalc/wcalc-2.5.ebuild
index e21f19c9610f..6fd0f9e9cae0 100644
--- a/sci-calculators/wcalc/wcalc-2.5.ebuild
+++ b/sci-calculators/wcalc/wcalc-2.5.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools desktop
+inherit autotools desktop flag-o-matic
DESCRIPTION="A flexible command-line scientific calculator"
HOMEPAGE="http://w-calc.sourceforge.net/"
@@ -20,7 +20,10 @@ RDEPEND="
readline? ( sys-libs/readline:0= )"
DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}"/${P}-AR.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-AR.patch
+ "${FILESDIR}"/0001-fix-bashism-in-configure-script.patch
+)
src_prepare() {
default
@@ -28,6 +31,13 @@ src_prepare() {
}
src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/862384
+ #
+ # Upstream is sourceforge. Last release in 2015, last activity 2021. Not
+ # submitting a bug report for now. -- Eli
+ filter-lto
+
econf $(use_with readline)
}