summaryrefslogtreecommitdiff
path: root/sci-calculators/units/units-2.18.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-calculators/units/units-2.18.ebuild')
-rw-r--r--sci-calculators/units/units-2.18.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/sci-calculators/units/units-2.18.ebuild b/sci-calculators/units/units-2.18.ebuild
index 119605f9309f..8f8ba8b7c387 100644
--- a/sci-calculators/units/units-2.18.ebuild
+++ b/sci-calculators/units/units-2.18.ebuild
@@ -12,12 +12,12 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
LICENSE="FDL-1.3 GPL-3"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm hppa ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
-IUSE="+units--cur"
-REQUIRED_USE="units--cur? ( ${PYTHON_REQUIRED_USE} )"
+IUSE="+units-cur"
+REQUIRED_USE="units-cur? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="
sys-libs/readline:=
- units--cur? (
+ units-cur? (
${PYTHON_DEPS}
$(python_gen_cond_dep '
dev-python/future[${PYTHON_MULTI_USEDEP}]
@@ -33,12 +33,12 @@ PATCHES=(
)
pkg_setup() {
- use units--cur && python-single-r1_pkg_setup
+ use units-cur && python-single-r1_pkg_setup
}
src_configure() {
econf \
- --sharedstatedir="${EROOT}/var/lib" \
+ --sharedstatedir="${EPREFIX}"/var/lib \
ac_cv_path_PYTHON=no
}
@@ -54,7 +54,7 @@ src_install() {
# we're intentionally delaying this since 'make install' would
# get confused if we shove 'units_cur' there, and there is no real
# need to add more complexity for it
- if use units--cur; then
+ if use units-cur; then
sed \
-e "/^outfile/s|'.*'|'/usr/share/units/currency.units'|g" \
-e 's|^#!|&/usr/bin/python|g' \