summaryrefslogtreecommitdiff
path: root/sci-calculators/pcalc/pcalc-3-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-calculators/pcalc/pcalc-3-r1.ebuild')
-rw-r--r--sci-calculators/pcalc/pcalc-3-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sci-calculators/pcalc/pcalc-3-r1.ebuild b/sci-calculators/pcalc/pcalc-3-r1.ebuild
new file mode 100644
index 000000000000..4edafb5b9706
--- /dev/null
+++ b/sci-calculators/pcalc/pcalc-3-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs
+
+DESCRIPTION="the programmers calculator"
+HOMEPAGE="https://github.com/vapier/pcalc"
+SRC_URI="mirror://sourceforge/pcalc/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="sys-devel/flex"
+RDEPEND=""
+
+src_prepare() {
+ default
+ sed -i -e "s:/usr:${EPREFIX}/usr:g" Makefile || die
+}
+
+src_configure() {
+ tc-export CC
+}