summaryrefslogtreecommitdiff
path: root/sci-calculators/keurocalc/keurocalc-1.2.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-calculators/keurocalc/keurocalc-1.2.3.ebuild')
-rw-r--r--sci-calculators/keurocalc/keurocalc-1.2.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sci-calculators/keurocalc/keurocalc-1.2.3.ebuild b/sci-calculators/keurocalc/keurocalc-1.2.3.ebuild
new file mode 100644
index 000000000000..4faa5ccbe7ce
--- /dev/null
+++ b/sci-calculators/keurocalc/keurocalc-1.2.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KDE_LINGUAS="bg bs ca ca@valencia cs da de el en_GB es et fi fr ga gl hu it
+ja ko nb nds nl pl pt pt_BR ru sk sl sr sr@Latn sv tr ug uk zh_TW"
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="A universal currency converter and calculator"
+HOMEPAGE="http://opensource.bureau-cornavin.com/keurocalc/index.html"
+SRC_URI="http://opensource.bureau-cornavin.com/keurocalc/sources/${P}.tgz"
+
+LICENSE="GPL-2+ FDL-1.2"
+SLOT="4"
+KEYWORDS="amd64 x86"
+IUSE="debug"
+
+DOCS=( AUTHORS TODO )
+
+src_prepare() {
+ # bug 500560
+ sed -e "s/PO_FILES //" -i po/*/CMakeLists.txt || die
+
+ # bug 518070
+ sed -e "/cmake_minimum_required/a cmake_policy(SET CMP0002 OLD)" \
+ -i CMakeLists.txt || die
+
+ kde4-base_src_prepare
+}