summaryrefslogtreecommitdiff
path: root/sci-calculators/datamash/datamash-1.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-calculators/datamash/datamash-1.2.ebuild')
-rw-r--r--sci-calculators/datamash/datamash-1.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sci-calculators/datamash/datamash-1.2.ebuild b/sci-calculators/datamash/datamash-1.2.ebuild
new file mode 100644
index 000000000000..2046d05d80fa
--- /dev/null
+++ b/sci-calculators/datamash/datamash-1.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="command-line program for basic numeric, textual and statistical operations"
+HOMEPAGE="https://www.gnu.org/software/datamash/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls openssl"
+
+CDEPEND="
+ nls? ( sys-devel/gettext )
+ openssl? ( dev-libs/openssl )
+"
+RDEPEND="
+ nls? ( virtual/libintl )
+"
+DEPEND="
+ ${CDEPEND}
+ ${RDEPEND}
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.2-libcrypto.patch
+)
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(usex openssl --with-openssl={yes,no})
+}