summaryrefslogtreecommitdiff
path: root/sci-biology/raxml/raxml-8.2.13.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/raxml/raxml-8.2.13.ebuild')
-rw-r--r--sci-biology/raxml/raxml-8.2.13.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sci-biology/raxml/raxml-8.2.13.ebuild b/sci-biology/raxml/raxml-8.2.13.ebuild
new file mode 100644
index 000000000000..859016195389
--- /dev/null
+++ b/sci-biology/raxml/raxml-8.2.13.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Sequential, Parallel & Distributed Inference of Large Phylogenetic Trees"
+HOMEPAGE="https://github.com/stamatak/standard-RAxML"
+SRC_URI="https://github.com/stamatak/standard-RAxML/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/standard-RAxML-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cpu_flags_x86_sse3 +threads"
+
+# mpi is not supported in version 7.2.2. mpi is enabled by adding -DPARALLEL to CFLAGS
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
+
+src_configure() {
+ use cpu_flags_x86_sse3 &&
+ append-cppflags -D__SIM_SSE3 &&
+ append-cflags -msse3
+ use threads &&
+ append-cppflags -D_USE_PTHREADS &&
+ append-cflags -pthread
+
+ tc-export CC
+}
+
+src_compile() {
+ emake -f Makefile.gcc
+}
+
+src_install() {
+ dobin raxmlHPC
+}