summaryrefslogtreecommitdiff
path: root/sci-biology/raxml/files
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/raxml/files')
-rw-r--r--sci-biology/raxml/files/raxml-7.2.6-makefile.patch29
-rw-r--r--sci-biology/raxml/files/raxml-8.2.13-makefile.patch37
2 files changed, 37 insertions, 29 deletions
diff --git a/sci-biology/raxml/files/raxml-7.2.6-makefile.patch b/sci-biology/raxml/files/raxml-7.2.6-makefile.patch
deleted file mode 100644
index 6b82ed65b770..000000000000
--- a/sci-biology/raxml/files/raxml-7.2.6-makefile.patch
+++ /dev/null
@@ -1,29 +0,0 @@
- Makefile.gcc | 6 +++---
- 1 files changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/Makefile.gcc b/Makefile.gcc
-index 716b6c6..f0c1de2 100644
---- a/Makefile.gcc
-+++ b/Makefile.gcc
-@@ -1,10 +1,10 @@
- # Makefile August 2006 by Alexandros Stamatakis
- # Makefile cleanup October 2006, Courtesy of Peter Cordes <peter@cordes.ca>
-
--CC = gcc
-+CC ?= gcc
-
-
--CFLAGS = -D_GNU_SOURCE -fomit-frame-pointer -funroll-loops -O2 -msse
-+CPPFLAGS += -D_GNU_SOURCE
-
-
-
-@@ -19,7 +19,7 @@ all : raxmlHPC
- GLOBAL_DEPS = axml.h globalVariables.h
-
- raxmlHPC : $(objs)
-- $(CC) -o raxmlHPC $(objs) $(LIBRARIES)
-+ $(CC) $(LDFLAGS) -o raxmlHPC $(objs) $(LIBRARIES) $(LIBS)
-
- classify.o : classify.c $(GLOBAL_DEPS)
- evaluatePartialSpecialGeneric.o : evaluatePartialSpecialGeneric.c $(GLOBAL_DEPS)
diff --git a/sci-biology/raxml/files/raxml-8.2.13-makefile.patch b/sci-biology/raxml/files/raxml-8.2.13-makefile.patch
new file mode 100644
index 000000000000..d774b1fb824d
--- /dev/null
+++ b/sci-biology/raxml/files/raxml-8.2.13-makefile.patch
@@ -0,0 +1,37 @@
+--- a/Makefile.gcc
++++ b/Makefile.gcc
+@@ -1,7 +1,6 @@
+ # Makefile August 2006 by Alexandros Stamatakis
+ # Makefile cleanup October 2006, Courtesy of Peter Cordes <peter@cordes.ca>
+
+-CC = gcc
+
+ ARCH := $(shell uname -m)
+ ifeq ($(ARCH), x86_64)
+@@ -10,7 +9,7 @@
+ ARCH_CFLAGS=
+ endif
+
+-CFLAGS = -D_GNU_SOURCE -fomit-frame-pointer -funroll-loops -O2 $(ARCH_CFLAGS) #-Wall -Wunused-parameter -Wredundant-decls -Wreturn-type -Wswitch-default -Wunused-value -Wimplicit -Wimplicit-function-declaration -Wimplicit-int -Wimport -Wunused -Wunused-function -Wunused-label -Wno-int-to-pointer-cast -Wbad-function-cast -Wmissing-declarations -Wmissing-prototypes -Wnested-externs -Wold-style-definition -Wstrict-prototypes -Wpointer-sign -Wextra -Wredundant-decls -Wunused -Wunused-function -Wunused-parameter -Wunused-value -Wunused-variable -Wformat -Wformat-nonliteral -Wparentheses -Wsequence-point -Wuninitialized -Wundef -Wbad-function-cast
++CFLAGS += -D_GNU_SOURCE #-Wall -Wunused-parameter -Wredundant-decls -Wreturn-type -Wswitch-default -Wunused-value -Wimplicit -Wimplicit-function-declaration -Wimplicit-int -Wimport -Wunused -Wunused-function -Wunused-label -Wno-int-to-pointer-cast -Wbad-function-cast -Wmissing-declarations -Wmissing-prototypes -Wnested-externs -Wold-style-definition -Wstrict-prototypes -Wpointer-sign -Wextra -Wredundant-decls -Wunused -Wunused-function -Wunused-parameter -Wunused-value -Wunused-variable -Wformat -Wformat-nonliteral -Wparentheses -Wsequence-point -Wuninitialized -Wundef -Wbad-function-cast
+
+ LIBRARIES = -lm
+
+@@ -23,7 +22,7 @@
+ GLOBAL_DEPS = axml.h globalVariables.h rmq.h rmqs.h #mem_alloc.h
+
+ raxmlHPC : $(objs)
+- $(CC) -o raxmlHPC $(objs) $(LIBRARIES) $(LDFLAGS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o raxmlHPC $(objs) $(LIBRARIES)
+
+ rmqs.o : rmqs.c $(GLOBAL_DEPS)
+ classify.o : classify.c $(GLOBAL_DEPS)
+@@ -51,8 +50,6 @@
+
+
+
+-eigen.o : eigen.c $(GLOBAL_DEPS)
+- $(CC) -c -o eigen.o eigen.c
+ clean :
+ $(RM) *.o raxmlHPC
+