summaryrefslogtreecommitdiff
path: root/sci-biology/libgtextutils/libgtextutils-0.6.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/libgtextutils/libgtextutils-0.6.1.ebuild')
-rw-r--r--sci-biology/libgtextutils/libgtextutils-0.6.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-biology/libgtextutils/libgtextutils-0.6.1.ebuild b/sci-biology/libgtextutils/libgtextutils-0.6.1.ebuild
new file mode 100644
index 000000000000..8f0455e5322c
--- /dev/null
+++ b/sci-biology/libgtextutils/libgtextutils-0.6.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Gordon Text utils Library"
+HOMEPAGE="http://hannonlab.cshl.edu/fastx_toolkit/"
+SRC_URI="http://hannonlab.cshl.edu/fastx_toolkit/${P}.tar.bz2"
+
+LICENSE="AGPL-3"
+SLOT="0/0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-build-system.patch
+ "${FILESDIR}"/${P}-gcc6.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+
+ # package installs .pc files
+ find "${D}" -name '*.la' -delete || die
+}