summaryrefslogtreecommitdiff
path: root/sci-biology/finchtv/finchtv-1.3.1-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/finchtv/finchtv-1.3.1-r3.ebuild')
-rw-r--r--sci-biology/finchtv/finchtv-1.3.1-r3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-biology/finchtv/finchtv-1.3.1-r3.ebuild b/sci-biology/finchtv/finchtv-1.3.1-r3.ebuild
new file mode 100644
index 000000000000..09ab304a7a3d
--- /dev/null
+++ b/sci-biology/finchtv/finchtv-1.3.1-r3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils
+
+MY_PV="${PV//./_}"
+MY_P=${PN}_${MY_PV}
+
+DESCRIPTION="Graphical viewer for chromatogram files"
+HOMEPAGE="http://www.geospiza.com/finchtv/"
+SRC_URI="http://www.geospiza.com/finchtv/download/programs/linux/${MY_P}.tar.gz"
+
+LICENSE="finchtv"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+QA_PREBUILT="opt/bin/*"
+
+src_install() {
+ exeinto /opt/bin
+ doexe finchtv
+
+ dodoc ReleaseNotes.txt
+ docinto html
+ dodoc -r Help/*
+
+ insinto /usr/share/doc/${PN}
+ doins -r SampleData
+
+ newicon Help/media/FinchTV_Mac_App.png ${PN}.png
+}