summaryrefslogtreecommitdiff
path: root/sci-biology/fastx_toolkit/fastx_toolkit-0.0.14.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/fastx_toolkit/fastx_toolkit-0.0.14.ebuild')
-rw-r--r--sci-biology/fastx_toolkit/fastx_toolkit-0.0.14.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sci-biology/fastx_toolkit/fastx_toolkit-0.0.14.ebuild b/sci-biology/fastx_toolkit/fastx_toolkit-0.0.14.ebuild
new file mode 100644
index 000000000000..d9012a54e166
--- /dev/null
+++ b/sci-biology/fastx_toolkit/fastx_toolkit-0.0.14.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Tools for Short Read FASTA/FASTQ file processing"
+HOMEPAGE="http://hannonlab.cshl.edu/fastx_toolkit"
+SRC_URI="https://github.com/agordon/fastx_toolkit/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ sci-biology/libgtextutils
+ virtual/pkgconfig"
+RDEPEND="
+ dev-perl/PerlIO-gzip
+ dev-perl/GDGraph
+ sci-biology/libgtextutils:=
+ sci-visualization/gnuplot"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-build-system.patch
+ "${FILESDIR}"/${P}-gcc7.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}