summaryrefslogtreecommitdiff
path: root/sci-biology/bowtie
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/bowtie')
-rw-r--r--sci-biology/bowtie/Manifest7
-rw-r--r--sci-biology/bowtie/bowtie-2.2.9.ebuild61
-rw-r--r--sci-biology/bowtie/bowtie-2.4.4.ebuild55
-rw-r--r--sci-biology/bowtie/files/bowtie-2.2.9-fix-c++14.patch29
-rw-r--r--sci-biology/bowtie/metadata.xml19
5 files changed, 65 insertions, 106 deletions
diff --git a/sci-biology/bowtie/Manifest b/sci-biology/bowtie/Manifest
index f9a42acddbb3..c2958853f2a0 100644
--- a/sci-biology/bowtie/Manifest
+++ b/sci-biology/bowtie/Manifest
@@ -1,4 +1,3 @@
-AUX bowtie-2.2.9-fix-c++14.patch 687 BLAKE2B a75f473f429379789a97142d7820fb19fc1a64b764236c6fa1c068cefb03e37a58b41b0a515a62d42e85b3131f0dfe8f2bb856126528099277394674a0e53248 SHA512 3aa6e7a30fdf93ae564091ce9b87338ab9feccbd0c873f4130af71dc94fd3b27527b42a93f13471a2613bad44dbacd639d17515000f03856695a0021ce14dfc5
-DIST bowtie2-2.2.9-source.zip 5734235 BLAKE2B ec48e09fe05403d1085bb4e0c6ef1325b8912da0a8c942061c34f3381c6dd7ccdcc64c4bcdbb18c1da84ac57e1e34cc866fe79809c33c2769a8d75ecde7d0846 SHA512 ead8f7641f3231638d986f9e500bc4ec7afe1e542048465bfcc2e93e2b2d2e499f0dd8aa5c1e3e21df285c9d195b187682eb7e12be4a408f6c50fb97c0e0a205
-EBUILD bowtie-2.2.9.ebuild 1277 BLAKE2B b9cf9edc34af3f01eb1cde1510637bbcbaf7206d9a24135d859d14dcefe793abd0b78dd19dbcd1835840514e754061aee86a79d5992ca68d316c64c98bb4891c SHA512 40e22698d5df241b8b98c601f8ed22276d39f4c9818bb23afec0a39b625fd38a0fdb3f4b4d6f8c01b458e2b6b3464a7ee8a135bd446f3488354eeca9934daa85
-MISC metadata.xml 528 BLAKE2B 310fb406a0dbe56b194ae13cf521264e105f9d849b09e10d5d7e556c7d00a9cc7a0f9546a91e43f30344c9ec14a76e0d8a3f037fb4cb91bba68999d9f45b69e0 SHA512 1eb83cbd7d7e747bc94021051ba6ae0bf22411091287b754851a9f6824b263b6ca83c9a0d055c0b6ab24963ceea9b32d76bf1b343f48a3ee4bd322fec539b301
+DIST bowtie2-2.4.4-source.zip 10515984 BLAKE2B be4ceb9d3155d2a9a1f580e5032251b04b89ce0c8c9c89fc3551b34fe3bd71a683362488be7aad6daef24734c6f95c19223f20e67f198f745c4432381243039c SHA512 1b5dadd7e41b90bb9b05f50bfa171fe219cfd03aa8bb6f800de4baaffeb975eef6efc4fb8b49cb0d18833f74a1741cbe1556b87388f59188e04a55dcee6a02da
+EBUILD bowtie-2.4.4.ebuild 1202 BLAKE2B 4ba725c1a324fcff1444451c51b0f5f3d031dc6bb1c0e20eef82de155c19d2bff504531fc8ce2821f6955cc97b0ab162ff8c28c8b651629bf2127c90e972ab96 SHA512 c3fd41634d8b32b389a196b6443d8768541afceb67ca404ade678be166af4624733fa4c2ee5ce5683db415a9fb1e70a7edeeadeee3e9d3905c09f70e512b4ffe
+MISC metadata.xml 341 BLAKE2B 6128267ebf9a8b0b4b6abf9da19a57f9a1da5492a6c878a531e7c43dc139c614793c4919d1a4a99739dfee4a3e6861554b9155f46d7af60a2f998811890bb70a SHA512 02b50e247581f0454829e2aaca768cc8719ee181db276feb20c5b4ed3ab3ba820af8db491075906eeb7bb4e0941940e98c5ee81a8efae0b633881e8f14cbcd74
diff --git a/sci-biology/bowtie/bowtie-2.2.9.ebuild b/sci-biology/bowtie/bowtie-2.2.9.ebuild
deleted file mode 100644
index 0bacb8ca25d7..000000000000
--- a/sci-biology/bowtie/bowtie-2.2.9.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs
-
-DESCRIPTION="Popular short read aligner for Next-generation sequencing data"
-HOMEPAGE="http://bowtie-bio.sourceforge.net/bowtie2/"
-SRC_URI="mirror://sourceforge/project/${PN}-bio/${PN}2/${PV}/${PN}2-${PV}-source.zip"
-
-LICENSE="GPL-3"
-SLOT="2"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="examples cpu_flags_x86_sse2 +tbb"
-
-RDEPEND="dev-lang/perl
- tbb? ( dev-cpp/tbb )"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-S="${WORKDIR}/${PN}2-${PV}"
-
-DOCS=( AUTHORS NEWS TUTORIAL )
-HTML_DOCS=( doc/{manual.html,style.css} )
-PATCHES=( "${FILESDIR}/${PN}-2.2.9-fix-c++14.patch" )
-
-pkg_pretend() {
- if ! use cpu_flags_x86_sse2 ; then
- eerror "This package requires a CPU supporting the SSE2 instruction set."
- die "SSE2 support missing"
- fi
-}
-
-src_compile() {
- emake \
- CC="$(tc-getCC)" \
- CPP="$(tc-getCXX)" \
- CXX="$(tc-getCXX)" \
- CFLAGS="" \
- CXXFLAGS="" \
- EXTRA_FLAGS="${LDFLAGS}" \
- RELEASE_FLAGS="${CXXFLAGS} -msse2" \
- WITH_TBB="$(usex tbb 1 0)"
-}
-
-src_install() {
- dobin ${PN}2 ${PN}2-*
-
- exeinto /usr/libexec/${PN}2
- doexe scripts/*
-
- newman MANUAL ${PN}2.1
- einstalldocs
-
- if use examples; then
- insinto /usr/share/${PN}2
- doins -r example
- fi
-}
diff --git a/sci-biology/bowtie/bowtie-2.4.4.ebuild b/sci-biology/bowtie/bowtie-2.4.4.ebuild
new file mode 100644
index 000000000000..2ba75bc2bca7
--- /dev/null
+++ b/sci-biology/bowtie/bowtie-2.4.4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit python-single-r1 toolchain-funcs
+
+DESCRIPTION="Popular short read aligner for Next-generation sequencing data"
+HOMEPAGE="http://bowtie-bio.sourceforge.net/bowtie2/"
+SRC_URI="mirror://sourceforge/project/${PN}-bio/bowtie2/${PV}/bowtie2-${PV}-source.zip"
+S="${WORKDIR}/${PN}2-${PV}"
+
+LICENSE="GPL-3"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE="cpu_flags_x86_sse2 examples"
+REQUIRED_USE="cpu_flags_x86_sse2 ${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-lang/perl
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+BDEPEND="app-arch/unzip"
+
+src_compile() {
+ emake \
+ CXX="$(tc-getCXX)" \
+ CXXFLAGS="" \
+ CPPFLAGS="${CPPFLAGS}" \
+ EXTRA_FLAGS="${LDFLAGS}" \
+ RELEASE_FLAGS="${CXXFLAGS} -msse2"
+}
+
+src_install() {
+ dobin bowtie2 bowtie2-*
+
+ exeinto /usr/libexec/bowtie2
+ doexe scripts/*
+
+ HTML_DOCS=( doc/{manual.html,style.css} )
+ einstalldocs
+ dodoc TUTORIAL
+ newman MANUAL bowtie2.1
+
+ python_fix_shebang "${ED}"/usr/bin/bowtie2-{build,inspect}
+
+ if use examples; then
+ docinto examples
+ dodoc -r example/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/sci-biology/bowtie/files/bowtie-2.2.9-fix-c++14.patch b/sci-biology/bowtie/files/bowtie-2.2.9-fix-c++14.patch
deleted file mode 100644
index cd2a67b6a52b..000000000000
--- a/sci-biology/bowtie/files/bowtie-2.2.9-fix-c++14.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-Fix building with C++14, which errors out due to differing semantics between C++98
-and C++14 with regards to allowing destructors to throw exceptions.
-See also: https://bugs.gentoo.org/show_bug.cgi?id=593966
-
---- a/blockwise_sa.h
-+++ b/blockwise_sa.h
-@@ -87,7 +87,11 @@
- _logger(__logger)
- { }
-
-- virtual ~BlockwiseSA() { }
-+ virtual ~BlockwiseSA()
-+#if __cplusplus >= 201103L
-+ noexcept(false)
-+#endif
-+ { }
-
- /**
- * Get the next suffix; compute the next bucket if necessary.
-@@ -216,6 +220,9 @@
- { _randomSrc.init(__seed); reset(); }
-
- ~KarkkainenBlockwiseSA()
-+#if __cplusplus >= 201103L
-+ noexcept(false)
-+#endif
- {
- #ifdef WITH_TBB
- tbb_grp.wait();
diff --git a/sci-biology/bowtie/metadata.xml b/sci-biology/bowtie/metadata.xml
index 71e8d3bb8e0f..f570878c86e5 100644
--- a/sci-biology/bowtie/metadata.xml
+++ b/sci-biology/bowtie/metadata.xml
@@ -1,16 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>sci-biology@gentoo.org</email>
- <name>Gentoo Biology Project</name>
- </maintainer>
- <upstream>
- <remote-id type="sourceforge">bowtie-bio</remote-id>
- </upstream>
- <use>
- <flag name="tbb">Enables building bowtie with the Intel
- Threading Building Blocks from <pkg>dev-cpp/tbb</pkg>. This
- flag is recommended.</flag>
- </use>
+ <maintainer type="project">
+ <email>sci-biology@gentoo.org</email>
+ <name>Gentoo Biology Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">bowtie-bio</remote-id>
+ </upstream>
</pkgmetadata>