summaryrefslogtreecommitdiff
path: root/sci-biology/bfast
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/bfast')
-rw-r--r--sci-biology/bfast/Manifest5
-rw-r--r--sci-biology/bfast/bfast-0.7.0a.ebuild39
-rw-r--r--sci-biology/bfast/files/bfast-0.7.0a-C99-inline.patch74
-rw-r--r--sci-biology/bfast/files/bfast-0.7.0a-autotools.patch41
-rw-r--r--sci-biology/bfast/files/bfast-0.7.0a-test-sourcing.patch79
5 files changed, 211 insertions, 27 deletions
diff --git a/sci-biology/bfast/Manifest b/sci-biology/bfast/Manifest
index d9ec14eacea8..9c749a7da2e0 100644
--- a/sci-biology/bfast/Manifest
+++ b/sci-biology/bfast/Manifest
@@ -1,3 +1,6 @@
+AUX bfast-0.7.0a-C99-inline.patch 2316 BLAKE2B 744908af002c5d5af57358baffbaff75a6299b7d0467573e5416c78ab2d4c9fc35dddbdcf308ada17583ca0e732412d1293152240748e84ac5eea243a944e8a1 SHA512 13144864d6a758d6dc0cba59e2a4458242ce33ab77108aafc33967a5343d1f0e2d59f872822e13df8a2f77f1eba2f58c5cc14060a48900509726e48fe6061177
+AUX bfast-0.7.0a-autotools.patch 1268 BLAKE2B b5da950d0230322f0a95b7c1417aec5fc4774a7d40ce4576b10bbc66d21f8d4907e17f3020679f3074cfdbe10f7e69bc3d8b62371ad381a2fb7b17854f146e46 SHA512 d1b00230ef35e82fb633a063c32e48a50866d8c40889cb0e13fddb0866a5b5447ed0f41cc948811f7e50918544ed3d0758ace3e1060a97a33ff5a0c3ee12b29c
+AUX bfast-0.7.0a-test-sourcing.patch 1399 BLAKE2B 2cc246d437da36a28d6fd86fe8c4acb78ba06120672158c16305c108298f46f4cabf37193f793e9b32ecb8fddc022f076bc845d06564f23ed9f412f5d7c22378 SHA512 3257038564997ae1b2bdd814e893825951c9cc72934cc204d6a3cd1dd31c796d26b76b6801dca4722be3e10ac309e0d177ddf725a6b6a2c5fe01106bd35d5a5f
DIST bfast-0.7.0a.tar.gz 2456617 BLAKE2B a841e7651e731dbb3faf22eb03dce5d2008c84f9a6198204d3c41aea26626058e3a23375bc0e7e8fc142d4898e09ddbb168016c71a7b79527e602e06ec329151 SHA512 16e7ec5101c478f0dfc171016cbacb2b9240773e43b2d40eeb42d0e47afcee50a6dd5838e043a0326fc1ca9a87d3e55b42326a7f17b7c5654ef9825913860836
-EBUILD bfast-0.7.0a.ebuild 902 BLAKE2B c5e520867849c07323fd6002cc881160272259f4b002320453b1e529daeb9b89125da9b51f640bd708cad2f9fbc092dc5e5cb957803e5926a0eee2de18f87e7b SHA512 0807ad435ef822c9697b812b8bfec37fe2aaf701a6e60fac1dd15de821686d94101240cc70b829d46627dfbb0fe3e158ea0daeb873c54ff1f8b594a61be3ffbc
+EBUILD bfast-0.7.0a.ebuild 595 BLAKE2B 257ddca11ba647f033b22f98afa4d718f1260687a17cf8386dec115f9e0dfc764a30f94af2cdb4f3f63057e1286e104bb9e3a666dfd44a4f004aa9c84b8f5e92 SHA512 5ce28ea79f9dc037eb432a23f742e7c9efb18be1317324c2200fa0a66f7e938526daa386c146922ae45a1b0f8c96460bdd2700db77c172b18935cd06dc1353eb
MISC metadata.xml 346 BLAKE2B cf096d053302cd40548e541557cbe72f41e81328a93b41a6e19ae88122e9939d5e6414eb6f60ee6e96411f43a073151f7d98ab780858afa16c50c1a5e37f2c48 SHA512 b402eeeb37be04022693af8692b128bb257a69b8eeb75170506352fe05fa6e7154c908267bbab7af7d38d1eee26ad6d98e6be5f9c8647181aa491b3fb1680b62
diff --git a/sci-biology/bfast/bfast-0.7.0a.ebuild b/sci-biology/bfast/bfast-0.7.0a.ebuild
index 97282d2244a4..6a48785022f4 100644
--- a/sci-biology/bfast/bfast-0.7.0a.ebuild
+++ b/sci-biology/bfast/bfast-0.7.0a.ebuild
@@ -1,11 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-AUTOTOOLS_AUTORECONF=true
-
-inherit autotools-utils flag-o-matic
+inherit autotools
DESCRIPTION="Blat-like Fast Accurate Search Tool"
HOMEPAGE="https://sourceforge.net/projects/bfast/"
@@ -13,30 +11,19 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="test" # tests broken, upstream unresponsive
-DEPEND=""
RDEPEND="dev-perl/XML-Simple"
-src_prepare() {
- sed \
- -e 's/-m64//' \
- -e 's/CFLAGS="${default_CFLAGS} ${extended_CFLAGS}"/CFLAGS="${CFLAGS} ${default_CFLAGS} ${extended_CFLAGS}"/' \
- -e 's:-g -O2::g' \
- -i configure.ac || die
- sed \
- -e 's:. test.definitions.sh:. ./test.definitions.sh:g' \
- -i tests/*sh || die
-
- sed \
- -e '/docdir/d' \
- -i Makefile.am || die
-
- use test && AUTOTOOLS_IN_SOURCE_BUILD=1
+PATCHES=(
+ "${FILESDIR}"/${P}-autotools.patch
+ "${FILESDIR}"/${P}-test-sourcing.patch
+ "${FILESDIR}"/${P}-C99-inline.patch
+)
- append-flags -fgnu89-inline
-
- autotools-utils_src_prepare
+src_prepare() {
+ default
+ eautoreconf
}
diff --git a/sci-biology/bfast/files/bfast-0.7.0a-C99-inline.patch b/sci-biology/bfast/files/bfast-0.7.0a-C99-inline.patch
new file mode 100644
index 000000000000..86450c96048a
--- /dev/null
+++ b/sci-biology/bfast/files/bfast-0.7.0a-C99-inline.patch
@@ -0,0 +1,74 @@
+--- a/bfast/AlignNTSpace.c
++++ b/bfast/AlignNTSpace.c
+@@ -478,7 +478,7 @@
+ }
+ }
+
+-inline void AlignNTSpaceFillInCell(char *read,
++void AlignNTSpaceFillInCell(char *read,
+ int32_t readLength,
+ char *reference,
+ int32_t referenceLength,
+--- a/bfast/AlignNTSpace.h
++++ b/bfast/AlignNTSpace.h
+@@ -10,5 +10,5 @@
+ void AlignNTSpaceRecoverAlignmentFromMatrix(AlignedEntry*, AlignMatrix*, char*, int, char*, int, int32_t, int32_t, int, int32_t, char, int);
+ void AlignNTSpaceInitializeAtStart(AlignMatrix*, ScoringMatrix*, int32_t, int32_t);
+ void AlignNTSpaceInitializeToExtend(AlignMatrix*, ScoringMatrix*, int32_t, int32_t, int32_t, int32_t);
+-inline void AlignNTSpaceFillInCell(char*, int32_t, char*, int32_t, ScoringMatrix*, AlignMatrix*, int32_t, int32_t, int32_t, int32_t);
++void AlignNTSpaceFillInCell(char*, int32_t, char*, int32_t, ScoringMatrix*, AlignMatrix*, int32_t, int32_t, int32_t, int32_t);
+ #endif
+--- a/bfast/BLib.c
++++ b/bfast/BLib.c
+@@ -90,7 +90,7 @@
+ }
+
+ /* TODO */
+-inline char ToUpper(char a)
++char ToUpper(char a)
+ {
+ if(97 <= a && a < 122) return (char)(a - 32);
+ return a;
+--- a/bfast/BLib.h
++++ b/bfast/BLib.h
+@@ -16,7 +16,7 @@
+ int ParseFastaHeaderLine(char*);
+ char ToLower(char);
+ void ToLowerRead(char*, int);
+-inline char ToUpper(char);
++char ToUpper(char);
+ void ToUpperRead(char*, int);
+ void ReverseRead(char*, char*, int);
+ void ReverseReadFourBit(int8_t*, int8_t*, int);
+--- a/bfast/ScoringMatrix.c
++++ b/bfast/ScoringMatrix.c
+@@ -98,14 +98,14 @@
+ return 1;
+ }
+
+-inline int32_t ScoringMatrixGetNTScore(char a,
++int32_t ScoringMatrixGetNTScore(char a,
+ char b,
+ ScoringMatrix *sm)
+ {
+ return (ToUpper(a) == ToUpper(b)) ? sm->ntMatch : sm->ntMismatch;
+ }
+
+-inline int32_t ScoringMatrixGetColorScore(char a,
++int32_t ScoringMatrixGetColorScore(char a,
+ char b,
+ ScoringMatrix *sm)
+ {
+--- a/bfast/ScoringMatrix.h
++++ b/bfast/ScoringMatrix.h
+@@ -3,8 +3,8 @@
+
+ #include "BLibDefinitions.h"
+
+-inline int32_t ScoringMatrixGetNTScore(char, char, ScoringMatrix*);
+-inline int32_t ScoringMatrixGetColorScore(char, char, ScoringMatrix*);
++int32_t ScoringMatrixGetNTScore(char, char, ScoringMatrix*);
++int32_t ScoringMatrixGetColorScore(char, char, ScoringMatrix*);
+
+ int ScoringMatrixRead(char*, ScoringMatrix*, int);
+ void ScoringMatrixInitialize(ScoringMatrix*);
diff --git a/sci-biology/bfast/files/bfast-0.7.0a-autotools.patch b/sci-biology/bfast/files/bfast-0.7.0a-autotools.patch
new file mode 100644
index 000000000000..993f6a554662
--- /dev/null
+++ b/sci-biology/bfast/files/bfast-0.7.0a-autotools.patch
@@ -0,0 +1,41 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -8,7 +8,7 @@
+ AC_INIT([bfast],[0.7.0a],[bfast-help@lists.sourceforge.net],[bfast])
+ AC_COPYRIGHT([See LICENSE for copyright information.])
+ AC_CONFIG_AUX_DIR(config)
+-AM_INIT_AUTOMAKE([dist-bzip2 subdir-objects])
++AM_INIT_AUTOMAKE([dist-bzip2 subdir-objects serial-tests])
+ AC_CONFIG_SRCDIR([config.h.in])
+ AC_CONFIG_HEADERS([config.h])
+
+@@ -21,10 +21,10 @@
+
+ AC_PROG_INSTALL
+ AC_GNU_SOURCE
++AC_SYS_LARGEFILE
+
+ # set CFLAGS and CXXFLAGS
+-default_CFLAGS="-Wall -g -O2 -pthread";
+-extended_CFLAGS="";# "-m64 -D_FILE_OFFSET_BITS=64";
++default_CFLAGS="-Wall -pthread"
+
+ # Define some variables
+ GITREV="Revision: undefined$";
+@@ -42,7 +42,7 @@
+ AC_DEFINE(HAVE_LIBBZ2, 1, [Define to 1 if you have the <bzlib.h> header file.])],
+ AC_MSG_ERROR("could not find the bzlib library. Please use --disable-bzlib if you wish to disable bzlib support."))])
+
+-CFLAGS="${default_CFLAGS} ${extended_CFLAGS}";
++CFLAGS="${CFLAGS} ${default_CFLAGS} ${extended_CFLAGS}";
+
+ # Enable large file support; disable with --disable-largefile
+ AC_SYS_LARGEFILE
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -16,5 +16,4 @@
+
+ SUBDIRS = bfast butil scripts tests
+
+-docdir = ${datadir}/doc/${PACKAGE}
+ dist_doc_DATA = LICENSE manual/bfast-book.pdf
diff --git a/sci-biology/bfast/files/bfast-0.7.0a-test-sourcing.patch b/sci-biology/bfast/files/bfast-0.7.0a-test-sourcing.patch
new file mode 100644
index 000000000000..f4dd64e75cac
--- /dev/null
+++ b/sci-biology/bfast/files/bfast-0.7.0a-test-sourcing.patch
@@ -0,0 +1,79 @@
+--- a/tests/test.cleanup.sh
++++ b/tests/test.cleanup.sh
+@@ -1,6 +1,6 @@
+ #!/bin/sh
+
+-. test.definitions.sh
++. ./test.definitions.sh
+
+ echo " Cleaning up files.";
+
+--- a/tests/test.diff.sh
++++ b/tests/test.diff.sh
+@@ -1,6 +1,6 @@
+ #!/bin/sh
+
+-. test.definitions.sh
++. ./test.definitions.sh
+
+ #error()
+ #{
+--- a/tests/test.fasta2brg.sh
++++ b/tests/test.fasta2brg.sh
+@@ -1,6 +1,6 @@
+ #!/bin/sh
+
+-. test.definitions.sh
++. ./test.definitions.sh
+ TMP_DIR="tmp/";
+
+ echo " Building a reference genome.";
+--- a/tests/test.index.sh
++++ b/tests/test.index.sh
+@@ -1,5 +1,5 @@
+ #!/bin/sh
+-. test.definitions.sh
++. ./test.definitions.sh
+
+ echo " Building an index.";
+
+--- a/tests/test.initialize.sh
++++ b/tests/test.initialize.sh
+@@ -1,6 +1,6 @@
+ #!/bin/sh
+
+-. test.definitions.sh
++. ./test.definitions.sh
+
+ echo " Initializing data for tests.";
+
+--- a/tests/test.localalign.sh
++++ b/tests/test.localalign.sh
+@@ -1,6 +1,6 @@
+ #!/bin/sh
+
+-. test.definitions.sh
++. ./test.definitions.sh
+
+ echo " Running local alignment.";
+
+--- a/tests/test.match.sh
++++ b/tests/test.match.sh
+@@ -1,6 +1,6 @@
+ #!/bin/sh
+
+-. test.definitions.sh
++. ./test.definitions.sh
+
+ echo " Finding matches.";
+
+--- a/tests/test.postprocess.sh
++++ b/tests/test.postprocess.sh
+@@ -1,6 +1,6 @@
+ #!/bin/sh
+
+-. test.definitions.sh
++. ./test.definitions.sh
+
+ echo " Running postprocessing.";
+