summaryrefslogtreecommitdiff
path: root/sci-astronomy
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/Manifest.gzbin7023 -> 7022 bytes
-rw-r--r--sci-astronomy/kstars/Manifest2
-rw-r--r--sci-astronomy/kstars/kstars-3.1.0.ebuild85
-rw-r--r--sci-astronomy/predict/Manifest2
-rw-r--r--sci-astronomy/predict/predict-2.2.3-r2.ebuild4
-rw-r--r--sci-astronomy/pyephem/Manifest4
-rw-r--r--sci-astronomy/pyephem/pyephem-3.7.5.3.ebuild4
-rw-r--r--sci-astronomy/pyephem/pyephem-3.7.6.0.ebuild4
8 files changed, 96 insertions, 9 deletions
diff --git a/sci-astronomy/Manifest.gz b/sci-astronomy/Manifest.gz
index 76c383d607cb..dd35a86bc4a2 100644
--- a/sci-astronomy/Manifest.gz
+++ b/sci-astronomy/Manifest.gz
Binary files differ
diff --git a/sci-astronomy/kstars/Manifest b/sci-astronomy/kstars/Manifest
index 71042cf1fb3a..87cc317a7a76 100644
--- a/sci-astronomy/kstars/Manifest
+++ b/sci-astronomy/kstars/Manifest
@@ -1,3 +1,5 @@
DIST kstars-3.0.0.tar.xz 63604404 BLAKE2B 23754eb1d29b9e7793fac71869045a4e172f8c9aa32dc55d529ef40bf03251d035a2edc68508d887c204389364c2dceba2c9984985bf2ddcc357fc835924f215 SHA512 e574c2529898d66bc79e1cf88ce778dddeedfdfed4ea23921219226121b60be042a94e6865e9076efff038a0a529587901f9a4ab2cd5b658440a8bf39c0c4d08
+DIST kstars-3.1.0.tar.xz 67769080 BLAKE2B c9afed7673a673fe595e20aad260d3bbe06a3541b6f8bea75c476db6b940977a186ebe18864353cafdb4eccc734dd9c3cfc9f3075e0b489d3089bc8d7a495bd0 SHA512 32b7685580eb71224d45d0a3fd213abeab7ddcbc90c58065e4d82724a1d29c527851cc7b90fb7fe36319a83200018d2c90d79549298436891891db44c187afb1
EBUILD kstars-3.0.0.ebuild 2199 BLAKE2B 6a15c7174ad19e05253c89ad9f7744b80ecbeacd3aa4c5f3f25a938a0b9ab56a3ba7c377b78f60c6650b9c7ae9879d64e1583a97bd6ad77d39a4f398fe837626 SHA512 126b54bb36b0407fe49a0da961e7b93aec43f211d17c1120b27ad3d962392b21ddaa17345b6f357982e8493c3e35877a352d563592fe210556007793cddab926
+EBUILD kstars-3.1.0.ebuild 2201 BLAKE2B a11649bba50a6860bc5182f059527737e0bc30af6917c4c84819bb1e29fa35fd37df68149da4d27add2e1172e275a201df6c26eaf6f8c14d477e4f1906770fe5 SHA512 495cbfb01652addd8d119cebca97aa900a1f96dcfd80d138911d9800e7abba1d07821b6a9399de5f15b41c57ad3a2d8ffe500f512f810501d6feeccea253656a
MISC metadata.xml 623 BLAKE2B 9c82c20c0824fb19b9e6a2fe9e144fa92aff5c15eb3cfb660f2d4ec985ea6f9218ebe3cd64862529dc2877cd5cf4209e54b6bfa6ccb9acd6eeac568a910b7c43 SHA512 030a49974d3cf1944ab6e0abe805e8d81763d3c173e5366344d11cc8415b0f55f8423de99a5e587e24bf078f0a0c2522770f2609c20b57d25bc9ba65e8bba8a6
diff --git a/sci-astronomy/kstars/kstars-3.1.0.ebuild b/sci-astronomy/kstars/kstars-3.1.0.ebuild
new file mode 100644
index 000000000000..6e6e693abac0
--- /dev/null
+++ b/sci-astronomy/kstars/kstars-3.1.0.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional"
+PYTHON_COMPAT=( python2_7 )
+inherit kde5 python-single-r1
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Desktop Planetarium"
+HOMEPAGE="https://www.kde.org/applications/education/kstars https://edu.kde.org/kstars/"
+IUSE="fits indi +password raw wcs"
+
+REQUIRED_USE="indi? ( fits ) ${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kauth)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep knotifyconfig)
+ $(add_frameworks_dep kplotting)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdatavis3d)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtsql)
+ $(add_qt_dep qtsvg)
+ $(add_qt_dep qtwebsockets)
+ $(add_qt_dep qtwidgets)
+ sys-libs/zlib
+ fits? ( sci-libs/cfitsio )
+ indi? ( >=sci-libs/indilib-1.7.5 )
+ password? ( dev-libs/qtkeychain:= )
+ raw? ( media-libs/libraw:= )
+ wcs? ( sci-astronomy/wcslib )
+"
+# TODO: Add back when re-enabled by upstream
+# opengl? (
+# $(add_qt_dep qtopengl)
+# virtual/opengl
+# )
+DEPEND="${COMMON_DEPEND}
+ $(add_qt_dep qtconcurrent)
+ dev-cpp/eigen:3
+"
+RDEPEND="${COMMON_DEPEND}
+ ${PYTHON_DEPS}
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DFETCH_TRANSLATIONS=OFF
+ $(cmake-utils_use_find_package fits CFitsio)
+ $(cmake-utils_use_find_package indi INDI)
+ $(cmake-utils_use_find_package password Qt5Keychain)
+ $(cmake-utils_use_find_package raw LibRaw)
+ $(cmake-utils_use_find_package wcs WCSLIB)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst () {
+ kde5_pkg_postinst
+
+ if [[ -z "${REPLACING_VERSIONS}" ]] && ! has_version "x11-misc/xplanet" ; then
+ elog "${PN} has optional runtime support for x11-misc/xplanet"
+ fi
+ # same for AstrometryNet, which is not packaged.
+}
diff --git a/sci-astronomy/predict/Manifest b/sci-astronomy/predict/Manifest
index 7c8c75763d68..fc9de48c89ca 100644
--- a/sci-astronomy/predict/Manifest
+++ b/sci-astronomy/predict/Manifest
@@ -2,5 +2,5 @@ AUX predict-2.2.3-earthtrack.patch 1175 BLAKE2B 17e1327695b12321abce6cb01e821141
AUX predict-update 4039 BLAKE2B 856aea796dcd612d17cdcc8d9aa7015e59faaa42a66caf42bd01c3e51c4193119208eb2c9015d215a014e2c08511c6ebbd13b78d4a4a0f86b7b133e4363d0ed2 SHA512 8bcc89babe25f44ca985776b994265a12be8e3d6390e4301594f7a8d1402d7d42aa66f6ae1ab6f51c2d8d910d9f012920382928c0238fce4e1707cb8843a739a
DIST predict_2.2.3-3.1.diff.gz 78624 BLAKE2B c80ffcf2b624a36e919d0f659c4cb46dbb4d00c83dd7c0e900d052a7258be92a4435a8de7ff319d16169373eab1061bed61a2311c5344eb5fc2f43183c0b8b46 SHA512 9fe2e3ffd931be7ab85f10db4cd35a2091a459c3fd0c48e9ecf8a4482c20400c267b38d31f72d28270d50b7305bc49418fefe35ff013ac9be1627d853205bd5f
DIST predict_2.2.3.orig.tar.gz 1444530 BLAKE2B 0bcca42aa0b7294d5276d5f9db2e321b1d47afdcb5194eeeb90d6912bd6f38c02a21036638febc45a72e304b9ae4737840f6ee3f4550eccf557e830272ef3956 SHA512 260f7f4dbc72cca4b0b5f7bc9dcf612b8a7e3ef12ab6f34afa3c06b1ac24427435af1c4bae9d39e7cbcdff6cccad72e3235dd191605464642f014207651d8c11
-EBUILD predict-2.2.3-r2.ebuild 5685 BLAKE2B 15e7f9a2f8adc629f5063d2eae4273609c6807338bc01562ed8a9cb207578a8e8b92d0d269d92d0463ac7edac59c22adf4a4621254ff669fea849e49f09019ef SHA512 ef04cba114fb677519cf60bce037085535e0fbbfca0b9f22b10274534112cee862d7a86f2cd5220f21eeb5a4c4c70b23c00e163e8f15b0ea4b2806531283ec2d
+EBUILD predict-2.2.3-r2.ebuild 5683 BLAKE2B 8bcff5670e63eff9873df322793a6dd2ac47d9b4ffd50c4670ba296eda5124b68adc538e9bb8abeda3fd65306228edafaa390fa3885a35c363bff174481495d0 SHA512 e065d462ab30032f694861906726007f50fc1ed40a602c493aacbac1c35b5f7b0920a572cc99352a0db31831403743b4b430b4a4cbfc71d05d520f12605fbf39
MISC metadata.xml 836 BLAKE2B 2e0a9b729afaa130e43c2f0375c7bef313cf061b454a1d8f8a1acb3662b9ed364f0af9ff81b0f96400c77ec21042af1e7d745385f0317355f3dd1ac4894fe033 SHA512 7e67a924a0b385cb051848bd1dd73d6a93ae60d13a10db785e96ead08df289137f06c67f17d519055b85aa228c1eca79db6da97494a532759c7c06c95e9c51d8
diff --git a/sci-astronomy/predict/predict-2.2.3-r2.ebuild b/sci-astronomy/predict/predict-2.2.3-r2.ebuild
index bca4d52f5976..df1044cfeb9e 100644
--- a/sci-astronomy/predict/predict-2.2.3-r2.ebuild
+++ b/sci-astronomy/predict/predict-2.2.3-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -9,7 +9,7 @@ DEB_P=${PN}_${PV}
DEB_PR=3.1
DESCRIPTION="Satellite tracking and orbital prediction"
-HOMEPAGE="http://www.qsl.net/kd2bd/predict.html"
+HOMEPAGE="https://www.qsl.net/kd2bd/predict.html"
SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${DEB_P}.orig.tar.gz
mirror://debian/pool/main/${PN:0:1}/${PN}/${DEB_P}-${DEB_PR}.diff.gz"
diff --git a/sci-astronomy/pyephem/Manifest b/sci-astronomy/pyephem/Manifest
index 04bb75ce5a7a..9bcf5a8c1561 100644
--- a/sci-astronomy/pyephem/Manifest
+++ b/sci-astronomy/pyephem/Manifest
@@ -1,5 +1,5 @@
DIST pyephem-3.7.5.3.tar.gz 735112 BLAKE2B 0edac4210c6ab745e64641d21f053fbd67a6e3841d1eb6b3b06bd5d4fcff0b6a1e1dc1634d8608e990eb6e588d030cc6a67115ebfd7bbefeb8f5ce219ae3ca1b SHA512 a61b6a19c35c10ee9d4eba72cb0e6b9446076a3943be58dfd5e084bc9ab09dc70f2ee335ba5f0ef9d9d4d34a461bf4b9ddd57dae50d2e8a8f565d411e47f2908
DIST pyephem-3.7.6.0.tar.gz 739561 BLAKE2B a8129632514940e6d786dcc50d2dd0bd1fff2b76b9d59f88820c93cce3400f9b15c4f7418bc778ee5ad60a8909a970aaea5df62c5192fcb71f822b97abc0dc4f SHA512 c3013ef943c0e1e2c30bba6f72912efb100b4c8c45904b7d6d7ba73d8b741564793a6e538117eb88abb824c93c874e2c955de734418ebd2370888718a149c9a8
-EBUILD pyephem-3.7.5.3.ebuild 1145 BLAKE2B c37903f80239616a3273d4413e75ddd1c148478da70bd54852d8b78ba5c26f4aced62d092086869130c4003ee58e4d78263894d6ea0b3f4472c8d10066772e4f SHA512 1bb3dd5dd13736c2ae8660fc6874a5580b11df4c8ec7fbcda07eca4e38768af5b13a585d86efa111eed85c38369241f5a6ee0ce8e8b8116a7b893e2b43894085
-EBUILD pyephem-3.7.6.0.ebuild 1159 BLAKE2B 8cbae016802f6842ac9243d3291072f1201aaa598150027e956e12fa3b249acb139d53f69c44634651a0015929c38615e37def0fd074e3bb5bdc68325b05ac85 SHA512 cd115b7bed11ee65d384ba4bdd0d028b3482fd7920ab0e233bcd2476ad101a26f4b093cbd340a747ea894c69e530e18dff388f2c97b91da91078f996a4285615
+EBUILD pyephem-3.7.5.3.ebuild 1143 BLAKE2B 6c3bf4a081ca1dd585e1fa2339614e9403325cf48a8801c8a0bab8f0724b5ca245bfd9f9978f5954471001d89642a9c6f98eec715cfb134b048f0bc4dbe1567f SHA512 e08617299ba398b3546b2904f06c2883c3f33895ef11af33a297618b7979c39535893c6a9b1f7a3381bed0ac1f11d9d7974d0899daedccebbeb136bc6d90809e
+EBUILD pyephem-3.7.6.0.ebuild 1157 BLAKE2B c5755a69a5dd32d4af330199ae88bc34670e8177e4ed20cebbfab363f63a01db299e3ebd178dd2d888d474b6feca1d1746d86b7f3078cddbdf0c1af57ba1f91c SHA512 11afe3b25d1786bf179f325ccf4bfbe91cc67f23b5e1195ce778a04b3da99d7c9378e6396b67576cb380870e92049247e1c925513ac0cd02aba0e7f9c3b9368a
MISC metadata.xml 947 BLAKE2B 0e586f2e978bb31b9ca757d2192a41e5a6e3414c7c29ceabddfb0ace9c9eb31ade32424701a9370665d69dd7cbeba567cdc9288cada621eb1d66b5a8a680c36d SHA512 f41c27b07f211b09dd72e316d02c46206dea0ff368e2ad1a8d116df49a2ce2a74137b2647572e295bcde34792d4ee15fb2d3f9e1a883c6cb306f6ef2a43d5c53
diff --git a/sci-astronomy/pyephem/pyephem-3.7.5.3.ebuild b/sci-astronomy/pyephem/pyephem-3.7.5.3.ebuild
index 10c8bdb996b0..4bba49a96d6c 100644
--- a/sci-astronomy/pyephem/pyephem-3.7.5.3.ebuild
+++ b/sci-astronomy/pyephem/pyephem-3.7.5.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -8,7 +8,7 @@ PYTHON_COMPAT=( python{2_7,3_4} )
inherit distutils-r1
DESCRIPTION="Astronomical routines for the python programming language"
-HOMEPAGE="http://rhodesmill.org/pyephem/"
+HOMEPAGE="https://rhodesmill.org/pyephem/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="LGPL-3"
diff --git a/sci-astronomy/pyephem/pyephem-3.7.6.0.ebuild b/sci-astronomy/pyephem/pyephem-3.7.6.0.ebuild
index 1a2ddf41ddf7..62b5f19683a0 100644
--- a/sci-astronomy/pyephem/pyephem-3.7.6.0.ebuild
+++ b/sci-astronomy/pyephem/pyephem-3.7.6.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -8,7 +8,7 @@ PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
inherit distutils-r1
DESCRIPTION="Astronomical routines for the python programming language"
-HOMEPAGE="http://rhodesmill.org/pyephem/"
+HOMEPAGE="https://rhodesmill.org/pyephem/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="LGPL-3"