summaryrefslogtreecommitdiff
path: root/sci-astronomy/siril/files
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/siril/files')
-rw-r--r--sci-astronomy/siril/files/siril-1.0-execinfo-r1.patch22
-rw-r--r--sci-astronomy/siril/files/siril-1.2-execinfo.patch46
-rw-r--r--sci-astronomy/siril/files/siril-1.2-htmesh.patch57
-rw-r--r--sci-astronomy/siril/files/siril-1.2-prototypes.patch41
4 files changed, 144 insertions, 22 deletions
diff --git a/sci-astronomy/siril/files/siril-1.0-execinfo-r1.patch b/sci-astronomy/siril/files/siril-1.0-execinfo-r1.patch
deleted file mode 100644
index c9c7cd81c19f..000000000000
--- a/sci-astronomy/siril/files/siril-1.0-execinfo-r1.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-commit c009c4c1800086e7f4c4e80939e9ddc8964c8e12
-Author: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de>
-Date: Thu Aug 4 00:27:08 2022 +0200
-
- Include execinfo.h only if available
-
-Bug: https://bugs.gentoo.org/873016
-Upstream: https://gitlab.com/free-astro/siril/-/merge_requests/284
-
-diff --git a/src/core/signals.c b/src/core/signals.c
-index 74100b3a..0eefd460 100644
---- a/src/core/signals.c
-+++ b/src/core/signals.c
-@@ -25,7 +25,7 @@
- #ifdef _WIN32
- #include <windows.h>
- #include <dbghelp.h>
--#else
-+#elif HAVE_EXECINFO_H
- #include <execinfo.h>
- #endif
-
diff --git a/sci-astronomy/siril/files/siril-1.2-execinfo.patch b/sci-astronomy/siril/files/siril-1.2-execinfo.patch
new file mode 100644
index 000000000000..82f29b290f63
--- /dev/null
+++ b/sci-astronomy/siril/files/siril-1.2-execinfo.patch
@@ -0,0 +1,46 @@
+From 6f959a02d27fb507cda1898a3aa785766e77d404 Mon Sep 17 00:00:00 2001
+From: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de>
+Date: Mon, 27 Feb 2023 17:34:43 +0100
+Subject: [PATCH] fix HAVE_EXECINFO_H logic
+Bug: https://bugs.gentoo.org/898108
+Upstream: https://gitlab.com/free-astro/siril/-/merge_requests/442
+
+---
+ src/core/signals.c | 14 +++++++-------
+ 1 file changed, 7 insertions(+), 7 deletions(-)
+
+diff --git a/src/core/signals.c b/src/core/signals.c
+index 42b369d6..d4745909 100644
+--- a/src/core/signals.c
++++ b/src/core/signals.c
+@@ -55,13 +55,7 @@ static void signal_handled(int s) {
+ g_printf(ANSI_COLOR_RED"%s"ANSI_COLOR_RESET"\n", visit);
+ }
+
+-#if (!defined _WIN32 && defined HAVE_EXECINFO_H)
+- void *stack[STACK_DEPTH];
+-
+- size_t size = backtrace(stack, sizeof(stack) / sizeof(void*));
+-
+- backtrace_symbols_fd(stack, size, fileno((FILE*) stdout));
+-#else
++#ifdef _WIN32
+ unsigned int i;
+ void *stack[STACK_DEPTH];
+ unsigned short size;
+@@ -84,6 +78,12 @@ static void signal_handled(int s) {
+ }
+
+ free(symbol);
++#elif HAVE_EXECINFO_H
++ void *stack[STACK_DEPTH];
++
++ size_t size = backtrace(stack, sizeof(stack) / sizeof(void*));
++
++ backtrace_symbols_fd(stack, size, fileno((FILE*) stdout));
+ #endif
+ }
+ undo_flush();
+--
+2.39.2
+
diff --git a/sci-astronomy/siril/files/siril-1.2-htmesh.patch b/sci-astronomy/siril/files/siril-1.2-htmesh.patch
new file mode 100644
index 000000000000..83f389267c40
--- /dev/null
+++ b/sci-astronomy/siril/files/siril-1.2-htmesh.patch
@@ -0,0 +1,57 @@
+From 915d01b7e94ff0a597685976838ab707917428db Mon Sep 17 00:00:00 2001
+From: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de>
+Date: Fri, 24 Feb 2023 19:00:52 +0100
+Subject: [PATCH] Don't install bundled htmesh static library system wide.
+Upstream: https://gitlab.com/free-astro/siril/-/merge_requests/438
+
+---
+ subprojects/htmesh/CMakeLists.txt | 7 ++++---
+ 1 file changed, 4 insertions(+), 3 deletions(-)
+
+diff --git a/subprojects/htmesh/CMakeLists.txt b/subprojects/htmesh/CMakeLists.txt
+index 5c197a9e..189acd3e 100644
+--- a/subprojects/htmesh/CMakeLists.txt
++++ b/subprojects/htmesh/CMakeLists.txt
+@@ -49,9 +49,10 @@ set_target_properties(htmesh PROPERTIES
+ VERSION 1.0.0
+ SOVERSION 1)
+
+-if (NOT ANDROID)
+- install(TARGETS htmesh ${KDE_INSTALL_TARGETS_DEFAULT_ARGS} )
+-endif ()
++# It is not necessary to install the static library as we just link against it.
++#if (NOT ANDROID)
++# install(TARGETS htmesh ${KDE_INSTALL_TARGETS_DEFAULT_ARGS} )
++#endif ()
+
+ # If you wish to compile the HTMesh perl wrapper, uncomment this, rebuild and copy the library into /usr/lib/, because we will use it as a shared object. See README in the perl wrapper directory (kstars/kstars/data/tools/HTMesh-*) for more details.
+ #set_property(TARGET htmesh PROPERTY POSITION_INDEPENDENT_CODE YES)
+--
+2.39.2
+
+From 42a12b852f4146aa104350587c456a35501a9707 Mon Sep 17 00:00:00 2001
+From: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de>
+Date: Fri, 24 Feb 2023 18:40:26 +0100
+Subject: [PATCH] Fix typo in htmesh build configuration
+Upstream: https://gitlab.com/free-astro/siril/-/merge_requests/437
+
+---
+ meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/meson.build b/meson.build
+index 886f3697..1ed39a98 100644
+--- a/meson.build
++++ b/meson.build
+@@ -270,7 +270,7 @@ endif
+ htmesh_dep = sub_proj.dependency('htmesh')
+ htmesh_inc = sub_proj.include_directories('htmesh')
+ else
+- siril_cpp_flag += '-DHAVE_LIBRTPROCESS'
++ siril_cpp_flag += '-DHAVE_HTMESH'
+ endif
+
+ ## Optional dependencies
+--
+2.39.2
+
diff --git a/sci-astronomy/siril/files/siril-1.2-prototypes.patch b/sci-astronomy/siril/files/siril-1.2-prototypes.patch
new file mode 100644
index 000000000000..8b72fef41b49
--- /dev/null
+++ b/sci-astronomy/siril/files/siril-1.2-prototypes.patch
@@ -0,0 +1,41 @@
+From 6c06d62579234e1d0030bad985a9cfcf7249b5d7 Mon Sep 17 00:00:00 2001
+From: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de>
+Date: Mon, 27 Feb 2023 17:49:41 +0100
+Subject: [PATCH 1/2] fix prototypes for functions with parameters
+Bug: https://bugs.gentoo.org/898108
+Upstream: https://gitlab.com/free-astro/siril/-/merge_requests/443
+
+---
+ src/core/processing.h | 2 +-
+ src/gui/save_dialog.h | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/core/processing.h b/src/core/processing.h
+index 1eba970b..89f24bd3 100644
+--- a/src/core/processing.h
++++ b/src/core/processing.h
+@@ -162,7 +162,7 @@ void wait_for_script_thread();
+ gboolean end_generic(gpointer arg);
+ guint siril_add_idle(GSourceFunc idle_function, gpointer data);
+
+-struct generic_seq_args *create_default_seqargs();
++struct generic_seq_args *create_default_seqargs(sequence *seq);
+
+ int check_threading(threading_type *threads);
+ int limit_threading(threading_type *threads, int min_iterations_per_thread, size_t total_iterations);
+diff --git a/src/gui/save_dialog.h b/src/gui/save_dialog.h
+index c724abb1..586a2ca3 100644
+--- a/src/gui/save_dialog.h
++++ b/src/gui/save_dialog.h
+@@ -20,7 +20,7 @@ enum {
+ };
+
+ void on_header_save_as_button_clicked();
+-void on_header_snapshot_button_clicked();
++void on_header_snapshot_button_clicked(gboolean clipboard);
+ void on_header_save_button_clicked();
+
+ #endif /* SRC_GUI_SAVE_DIALOG_H_ */
+--
+2.39.2
+