summaryrefslogtreecommitdiff
path: root/sci-astronomy/healpix
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/healpix')
-rw-r--r--sci-astronomy/healpix/Manifest6
-rw-r--r--sci-astronomy/healpix/healpix-3.30.ebuild140
-rw-r--r--sci-astronomy/healpix/healpix-3.31.ebuild140
-rw-r--r--sci-astronomy/healpix/metadata.xml20
4 files changed, 306 insertions, 0 deletions
diff --git a/sci-astronomy/healpix/Manifest b/sci-astronomy/healpix/Manifest
new file mode 100644
index 000000000000..018165435e51
--- /dev/null
+++ b/sci-astronomy/healpix/Manifest
@@ -0,0 +1,6 @@
+DIST Healpix_3.30_2015Oct08.tar.gz 23465221 SHA256 efcc8ff9775f393bd3e7e9d36202126e34e5c762ee568495a728329fa6650bfb SHA512 a7be82687a2188f5dff99c6826355e3290ccc91cc440e67267c58fa13af9fa5d301eca9b37676ef6f0af262b2ff1c06e722d0dcd3aca00a4c9d2794bc666c0c7 WHIRLPOOL 56584726daa1efd8809440cb7608c82a6b2ee6f1f35ddff701e98d3ddc3c77c0a3c339003c0b08e150747db5c6b0eb18da9ef153f89e1f33bc897e4135692152
+DIST Healpix_3.31_2016Aug26.tar.gz 23834899 SHA256 ddf437442b6d5ae7d75c9afaafc4ec43921f903c976e25db3c5ed5185a181542 SHA512 fd80e9ed80d19e438134f63c3d13802f63c4cd1b9f3596807e67d4ba5ff814e652a130d038449269d6ead271085eb0ab74884b2d768d8531066727377c457f9c WHIRLPOOL 3ae297b5fc0235162870af6ab8161ad87bd0f33a2e20c807da0d3faa2a7c2b0ac7b194e5c535ec74fa1d36d9571c1eff8d54606360b47d61253fdadd24261d0f
+EBUILD healpix-3.30.ebuild 3133 SHA256 793944f646b889e072423e086dfff90699e5d41446dc049fee82eac432a90016 SHA512 cd0a0ef795cbd11f84f126411c7fd72798d035306f25e76d5659fa5c084e38337492148c953bd013e22998c2107e7e5f1bcd46a0b94a95ed4ff7dd186b4c59ef WHIRLPOOL 7289b82cc45f3577856d865c69f5ecf42d239d3b4eff0f109c6d3f094b32faad02174804e0f99ce112ddd30b590133ce9e4b4f3b3dfb794a20b7ce9990e7a1d1
+EBUILD healpix-3.31.ebuild 3133 SHA256 ea835eafc8e52c9d9f776adb35e346650281b52d55db372442779b2906602999 SHA512 51d64602f658c9ab2ab81ca4529415fe19c1cbd2e00d48ca352257a11c60d666464da7b7e6b09224152cad8af7b90d3d41f7ede5cb84911aaec2724797002714 WHIRLPOOL 2b6b37a1c5fb18c426c3b914986d3a5f5500eecaae31b7fe6323c50b79fce58bb73e8cf1e261707364d3aacb6ad27e5caf0f6391cad6d1553b4347cb35341066
+MISC ChangeLog 473 SHA256 1620bd2dc6414cde4464abdff7c9154a6a4caa305cb2d2e159609331a54489f6 SHA512 6605b490131636baeb862f5ac971e10dc116fa50274cb9fa4da36de7a9ac25258891fdd7ddd8ada8aa1f59a4e3d44f8f326859a42d47e226e93904967f248074 WHIRLPOOL d51fd9958cb87fb46dfe5f0d8773639f9888e9770667d2fba6ad3af71c96b5dbc805d53f9e5687c36c2843e66eac70079f7e17966ffe05ef277605c39ef9bb9d
+MISC metadata.xml 736 SHA256 6b4f51727f5233cc57315204cf5582f83e236f3b5fa30f372029a0139044853b SHA512 1c1b23603bf390ebf8258f75a0867f2a0eb640099c2fbba9db5377449945aff71df8eac9c4c83391e838f1785fca1ce64b7acacd112f7a3b1ddde61a8923f1d5 WHIRLPOOL 9e3f437fa6dff4108bac2a1ff654683b1ac907f9e666be73d1baa0bf8c0a110e83030ec8db27bf4668ac3d31e6d3584bd5ae0decf8079ba3003b44cf08cc4dc1
diff --git a/sci-astronomy/healpix/healpix-3.30.ebuild b/sci-astronomy/healpix/healpix-3.30.ebuild
new file mode 100644
index 000000000000..e446fc060467
--- /dev/null
+++ b/sci-astronomy/healpix/healpix-3.30.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools toolchain-funcs eutils java-pkg-opt-2 java-ant-2
+
+MYP="Healpix_${PV}"
+MYPF=${MYP}_2015Oct08
+
+DESCRIPTION="Hierarchical Equal Area isoLatitude Pixelization of a sphere"
+HOMEPAGE="http://healpix.sourceforge.net/"
+SRC_URI="mirror://sourceforge/healpix/${MYP}/${MYPF}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+# might add fortran in the future if requested
+IUSE="cxx doc idl java openmp static-libs test"
+
+RDEPEND="
+ >=sci-libs/cfitsio-3
+ idl? (
+ dev-lang/gdl
+ sci-astronomy/idlastro )
+ java? ( >=virtual/jre-1.6:* )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ java? ( >=virtual/jdk-1.6:* test? ( dev-java/ant-junit4:0 ) )"
+
+S="${WORKDIR}/${MYP}"
+
+pkg_pretend() {
+ if use cxx && use openmp && [[ $(tc-getCXX)$ == *g++* ]] && [[ ${MERGE_TYPE} != binary ]]; then
+ tc-has-openmp || \
+ die "You are using gcc but without OpenMP capabilities that you requested"
+ fi
+}
+
+pkg_setup() {
+ java-pkg-opt-2_pkg_setup
+}
+
+src_prepare() {
+ pushd src/C/autotools > /dev/null
+ eautoreconf
+ popd > /dev/null
+ # why was static-libtool-libs forced?
+ if use cxx; then
+ pushd src/cxx/autotools > /dev/null
+ sed -i -e '/-static-libtool-libs/d' Makefile.am || die
+ eautoreconf
+ popd > /dev/null
+ fi
+ # duplicate of idlastro (in rdeps)
+ rm -r src/idl/zzz_external/astron || die
+ mv src/idl/zzz_external/README src/idl/README.external || die
+ java-pkg-opt-2_src_prepare
+ default
+}
+
+src_configure() {
+ pushd src/C/autotools > /dev/null
+ econf $(use_enable static-libs static)
+ popd > /dev/null
+ if use cxx; then
+ pushd src/cxx/autotools > /dev/null
+ econf \
+ --disable-native-optimizations \
+ $(use_enable openmp) \
+ $(use_enable static-libs static)
+ popd > /dev/null
+ fi
+}
+
+src_compile() {
+ pushd src/C/autotools > /dev/null
+ emake
+ popd > /dev/null
+ if use cxx; then
+ pushd src/cxx/autotools > /dev/null
+ emake
+ popd > /dev/null
+ fi
+ if use java; then
+ pushd src/java > /dev/null
+ eant dist-notest
+ popd > /dev/null
+ fi
+}
+
+src_test() {
+ pushd src/C/autotools > /dev/null
+ emake check
+ popd > /dev/null
+ if use cxx; then
+ pushd src/cxx/autotools > /dev/null
+ emake check
+ popd > /dev/null
+ fi
+ if use java; then
+ pushd src/java > /dev/null
+ EANT_GENTOO_CLASSPATH="ant-junit4" ANT_TASKS="ant-junit4" eant test
+ popd > /dev/null
+ fi
+}
+
+src_install() {
+ dodoc READ_Copyrights_Licenses.txt
+ pushd src/C/autotools > /dev/null
+ emake install DESTDIR="${D}"
+ popd > /dev/null
+ if use cxx; then
+ pushd src/cxx/autotools > /dev/null
+ emake install DESTDIR="${D}"
+ docinto cxx
+ dodoc ../CHANGES
+ popd > /dev/null
+ fi
+ use static-libs || prune_libtool_files --all
+ if use idl; then
+ pushd src/idl > /dev/null
+ insinto /usr/share/gnudatalanguage/healpix
+ doins -r examples fits interfaces misc toolkit visu zzz_external
+ doins HEALPix_startup
+ docinto idl
+ dodoc README.*
+ popd > /dev/null
+ fi
+ if use java; then
+ pushd src/java > /dev/null
+ java-pkg_dojar dist/*.jar
+ docinto java
+ dodoc README CHANGES
+ popd > /dev/null
+ fi
+ use doc && dodoc -r doc/html
+}
diff --git a/sci-astronomy/healpix/healpix-3.31.ebuild b/sci-astronomy/healpix/healpix-3.31.ebuild
new file mode 100644
index 000000000000..489986685793
--- /dev/null
+++ b/sci-astronomy/healpix/healpix-3.31.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools toolchain-funcs eutils java-pkg-opt-2 java-ant-2
+
+MYP="Healpix_${PV}"
+MYPF=${MYP}_2016Aug26
+
+DESCRIPTION="Hierarchical Equal Area isoLatitude Pixelization of a sphere"
+HOMEPAGE="http://healpix.sourceforge.net/"
+SRC_URI="mirror://sourceforge/healpix/${MYP}/${MYPF}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+# might add fortran in the future if requested
+IUSE="cxx doc idl java openmp static-libs test"
+
+RDEPEND="
+ >=sci-libs/cfitsio-3
+ idl? (
+ dev-lang/gdl
+ sci-astronomy/idlastro )
+ java? ( >=virtual/jre-1.6:* )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ java? ( >=virtual/jdk-1.6:* test? ( dev-java/ant-junit4:0 ) )"
+
+S="${WORKDIR}/${MYP}"
+
+pkg_pretend() {
+ if use cxx && use openmp && [[ $(tc-getCXX)$ == *g++* ]] && [[ ${MERGE_TYPE} != binary ]]; then
+ tc-has-openmp || \
+ die "You are using gcc but without OpenMP capabilities that you requested"
+ fi
+}
+
+pkg_setup() {
+ java-pkg-opt-2_pkg_setup
+}
+
+src_prepare() {
+ pushd src/C/autotools > /dev/null
+ eautoreconf
+ popd > /dev/null
+ # why was static-libtool-libs forced?
+ if use cxx; then
+ pushd src/cxx/autotools > /dev/null
+ sed -i -e '/-static-libtool-libs/d' Makefile.am || die
+ eautoreconf
+ popd > /dev/null
+ fi
+ # duplicate of idlastro (in rdeps)
+ rm -r src/idl/zzz_external/astron || die
+ mv src/idl/zzz_external/README src/idl/README.external || die
+ java-pkg-opt-2_src_prepare
+ default
+}
+
+src_configure() {
+ pushd src/C/autotools > /dev/null
+ econf $(use_enable static-libs static)
+ popd > /dev/null
+ if use cxx; then
+ pushd src/cxx/autotools > /dev/null
+ econf \
+ --disable-native-optimizations \
+ $(use_enable openmp) \
+ $(use_enable static-libs static)
+ popd > /dev/null
+ fi
+}
+
+src_compile() {
+ pushd src/C/autotools > /dev/null
+ emake
+ popd > /dev/null
+ if use cxx; then
+ pushd src/cxx/autotools > /dev/null
+ emake
+ popd > /dev/null
+ fi
+ if use java; then
+ pushd src/java > /dev/null
+ eant dist-notest
+ popd > /dev/null
+ fi
+}
+
+src_test() {
+ pushd src/C/autotools > /dev/null
+ emake check
+ popd > /dev/null
+ if use cxx; then
+ pushd src/cxx/autotools > /dev/null
+ emake check
+ popd > /dev/null
+ fi
+ if use java; then
+ pushd src/java > /dev/null
+ EANT_GENTOO_CLASSPATH="ant-junit4" ANT_TASKS="ant-junit4" eant test
+ popd > /dev/null
+ fi
+}
+
+src_install() {
+ dodoc READ_Copyrights_Licenses.txt
+ pushd src/C/autotools > /dev/null
+ emake install DESTDIR="${D}"
+ popd > /dev/null
+ if use cxx; then
+ pushd src/cxx/autotools > /dev/null
+ emake install DESTDIR="${D}"
+ docinto cxx
+ dodoc ../CHANGES
+ popd > /dev/null
+ fi
+ use static-libs || prune_libtool_files --all
+ if use idl; then
+ pushd src/idl > /dev/null
+ insinto /usr/share/gnudatalanguage/healpix
+ doins -r examples fits interfaces misc toolkit visu zzz_external
+ doins HEALPix_startup
+ docinto idl
+ dodoc README.*
+ popd > /dev/null
+ fi
+ if use java; then
+ pushd src/java > /dev/null
+ java-pkg_dojar dist/*.jar
+ docinto java
+ dodoc README CHANGES
+ popd > /dev/null
+ fi
+ use doc && dodoc -r doc/html
+}
diff --git a/sci-astronomy/healpix/metadata.xml b/sci-astronomy/healpix/metadata.xml
new file mode 100644
index 000000000000..d83a73a67095
--- /dev/null
+++ b/sci-astronomy/healpix/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-astronomy@gentoo.org</email>
+ <name>Gentoo Astronomy Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ HEALPix is an acronym for Hierarchical Equal Area isoLatitude
+ Pixelization of a sphere. As suggested in the name, this pixelization produces a
+ subdivision of a spherical surface in which each pixel covers the same
+ surface area as every other pixel.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">healpix</remote-id>
+ </upstream>
+ <use>
+ <flag name="idl">Install healpix IDL/GDL routines</flag>
+ </use>
+</pkgmetadata>