summaryrefslogtreecommitdiff
path: root/sci-astronomy/celestia/files
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/celestia/files')
-rw-r--r--sci-astronomy/celestia/files/celestia-1.6.0-cfg.patch11
-rw-r--r--sci-astronomy/celestia/files/celestia-1.6.1-gcc46.patch14
-rw-r--r--sci-astronomy/celestia/files/celestia-1.6.1-gcc47.patch22
-rw-r--r--sci-astronomy/celestia/files/celestia-1.6.1-libpng15.patch14
-rw-r--r--sci-astronomy/celestia/files/celestia-1.6.1-libpng16.patch25
-rw-r--r--sci-astronomy/celestia/files/celestia-1.6.1-linking.patch65
6 files changed, 0 insertions, 151 deletions
diff --git a/sci-astronomy/celestia/files/celestia-1.6.0-cfg.patch b/sci-astronomy/celestia/files/celestia-1.6.0-cfg.patch
deleted file mode 100644
index 2319c255b2b5..000000000000
--- a/sci-astronomy/celestia/files/celestia-1.6.0-cfg.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/celestia.cfg
-+++ b/celestia.cfg
-@@ -195,7 +195,7 @@
- # or
- # ExtrasDirectories [ "D:\\celestia-extras" ]
- #------------------------------------------------------------------------
-- ExtrasDirectories [ "extras-standard" "extras" ]
-+ ExtrasDirectories [ "extras-standard" "extras" "~/.celestia" ]
-
-
- #------------------------------------------------------------------------
diff --git a/sci-astronomy/celestia/files/celestia-1.6.1-gcc46.patch b/sci-astronomy/celestia/files/celestia-1.6.1-gcc46.patch
deleted file mode 100644
index 757cd6c5d407..000000000000
--- a/sci-astronomy/celestia/files/celestia-1.6.1-gcc46.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-http://bugs.gentoo.org/show_bug.cgi?id=366073
-http://celestia.svn.sourceforge.net/viewvc/celestia?view=revision&revision=5178
-
-Patch written by Nils Larsson <ni1s@nerdshack.com>
---- a/src/celengine/frametree.h
-+++ b/src/celengine/frametree.h
-@@ -14,6 +14,7 @@
- #define _CELENGINE_FRAMETREE_H_
-
- #include <vector>
-+#include <cstddef>
-
- class Star;
- class Body;
diff --git a/sci-astronomy/celestia/files/celestia-1.6.1-gcc47.patch b/sci-astronomy/celestia/files/celestia-1.6.1-gcc47.patch
deleted file mode 100644
index 385f39a20511..000000000000
--- a/sci-astronomy/celestia/files/celestia-1.6.1-gcc47.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff -up celestia-1.6.1/src/celengine/frametree.h.gcc47 celestia-1.6.1/src/celengine/frametree.h
---- celestia-1.6.1/src/celengine/frametree.h.gcc47 2012-03-22 12:56:56.096087430 -0400
-+++ celestia-1.6.1/src/celengine/frametree.h 2012-03-22 12:57:04.333022427 -0400
-@@ -13,6 +13,7 @@
- #ifndef _CELENGINE_FRAMETREE_H_
- #define _CELENGINE_FRAMETREE_H_
-
-+#include <unistd.h>
- #include <vector>
-
- class Star;
-diff -up celestia-1.6.1/src/celengine/planetgrid.cpp.gcc47 celestia-1.6.1/src/celengine/planetgrid.cpp
---- celestia-1.6.1/src/celengine/planetgrid.cpp.gcc47 2012-03-22 12:53:01.496950513 -0400
-+++ celestia-1.6.1/src/celengine/planetgrid.cpp 2012-03-22 12:53:08.812891865 -0400
-@@ -12,6 +12,7 @@
-
- #include <cstdio>
- #include <cmath>
-+#include <celmath/mathlib.h>
- #include <celmath/intersect.h>
- #include "planetgrid.h"
- #include "body.h"
diff --git a/sci-astronomy/celestia/files/celestia-1.6.1-libpng15.patch b/sci-astronomy/celestia/files/celestia-1.6.1-libpng15.patch
deleted file mode 100644
index 0a772ffdf6ac..000000000000
--- a/sci-astronomy/celestia/files/celestia-1.6.1-libpng15.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-imagecapture.cpp:184:40: error: ‘Z_BEST_COMPRESSION’ was not declared in this scope
-
---- a/src/celestia/imagecapture.cpp
-+++ b/src/celestia/imagecapture.cpp
-@@ -31,6 +31,9 @@
- #include "png.h"
- #endif
-
-+// Z_BEST_COMPRESSION
-+#include <zlib.h>
-+
- // Define png_jmpbuf() in case we are using a pre-1.0.6 version of libpng
- #ifndef png_jmpbuf
- #define png_jmpbuf(png_ptr) png_ptr->jmpbuf
diff --git a/sci-astronomy/celestia/files/celestia-1.6.1-libpng16.patch b/sci-astronomy/celestia/files/celestia-1.6.1-libpng16.patch
deleted file mode 100644
index 0905be66b6b6..000000000000
--- a/sci-astronomy/celestia/files/celestia-1.6.1-libpng16.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-image.cpp:530:61: error: ‘memcpy’ was not declared in this scope
-
-https://bugs.gentoo.org/show_bug.cgi?id=464764
-
-Patch written by Lars Wendler <polynomial-c@gentoo.org>
---- a/src/celengine/image.cpp
-+++ b/src/celengine/image.cpp
-@@ -42,6 +42,7 @@ extern "C" {
- #include "jpeglib.h"
- #else
- #include <cstdio>
-+#include <string.h>
- #include <jpeglib.h>
- #endif
- }
---- a/src/celengine/texture.cpp
-+++ b/src/celengine/texture.cpp
-@@ -28,6 +28,7 @@
- #include <cstdlib>
- #include <cstdio>
- #include <cassert>
-+#include <string.h>
-
- #ifndef _WIN32
- #ifndef TARGET_OS_MAC
diff --git a/sci-astronomy/celestia/files/celestia-1.6.1-linking.patch b/sci-astronomy/celestia/files/celestia-1.6.1-linking.patch
deleted file mode 100644
index dd5f93e609a6..000000000000
--- a/sci-astronomy/celestia/files/celestia-1.6.1-linking.patch
+++ /dev/null
@@ -1,65 +0,0 @@
-Fix linking issues:
- * underlinking GLUT (bug #372123, #387609)
- * as-needed (bug #281258)
- * theora with glut (bug #399237)
-
---- a/src/celestia/Makefile.am
-+++ b/src/celestia/Makefile.am
-@@ -7,14 +7,15 @@
-
- if ENABLE_KDE
- SUBDIRS += kde
--celestiaKDELIBS = $(LIB_QT) $(LIB_KDECORE) $(LIB_KDEUI) $(LIB_KFILE) \
-- $(LIBSOCKET) -lDCOP kde/libkdegui.a
-+celestiaKDELIBS = kde/libkdegui.a
- celestia_LDFLAGS = $(all_libraries) $(KDE_RPATH)
-+LIBS += $(LIB_QT) $(LIB_KDECORE) $(LIB_KDEUI) $(LIB_KFILE) $(LIBSOCKET) -lDCOP
- endif
-
- if ENABLE_GTK
- SUBDIRS += gtk
--celestiaGTKLIBS = $(GTK_LIBS) gtk/libgtkgui.a
-+celestiaGTKLIBS = gtk/libgtkgui.a
-+LIBS += $(GTK_LIBS)
- endif
-
- COMMONSOURCES = \
-@@ -62,6 +63,7 @@
-
- if ENABLE_GLUT
- GLUTSOURCES = glutmain.cpp
-+GLUTLIBS = -lGL
- endif
-
- if ENABLE_THEORA
-@@ -80,15 +82,16 @@
- celestia_LDADD = \
- $(celestiaKDELIBS) \
- $(celestiaGTKLIBS) \
-- $(DL_LIBS) \
-- $(LUA_LIBS) \
-- $(THEORA_LIBS) \
- ../celengine/libcelengine.a \
- ../celtxf/libceltxf.a \
- ../cel3ds/libcel3ds.a \
- ../celmath/libcelmath.a \
- ../celutil/libcelutil.a \
-- $(SPICE_LIBS)
-+ $(LUA_LIBS) \
-+ $(THEORA_LIBS) \
-+ $(GLUTLIBS) \
-+ $(SPICE_LIBS) \
-+ $(DL_LIBS)
-
- noinst_HEADERS = $(wildcard *.h)
- noinst_DATA = ../../celestia
---- a/configure.in
-+++ b/configure.in
-@@ -252,6 +252,7 @@
- dnl Check for GLUT.
- AC_CHECK_LIB(glut, glutKeyboardUpFunc, ,
- [AC_MSG_ERROR([GLUT library version >= 3.7 not found])])
-+ check_theora="yes"
- fi
- AM_CONDITIONAL(ENABLE_GLUT, test "$ui_glut" = "yes")
-