summaryrefslogtreecommitdiff
path: root/net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild')
-rw-r--r--net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild87
1 files changed, 32 insertions, 55 deletions
diff --git a/net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild b/net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild
index df34e7baa75c..e0e179eeae04 100644
--- a/net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild
+++ b/net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -12,15 +12,13 @@ LICENSE="|| ( GPL-2 BSD )"
if [ "${PV}" = "9999" ]; then
inherit git-r3
EGIT_REPO_URI="https://w1.fi/hostap.git"
- KEYWORDS=""
else
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
SRC_URI="https://w1.fi/releases/${P}.tar.gz"
fi
SLOT="0"
-IUSE="ap bindist dbus eap-sim eapol_test fasteap gnutls +hs2-0 libressl p2p privsep ps3 qt5 readline selinux smartcard ssl suiteb tdls uncommon-eap-types wimax wps kernel_linux kernel_FreeBSD"
-REQUIRED_USE="smartcard? ( ssl )"
+IUSE="ap bindist dbus eap-sim eapol_test fasteap +hs2-0 libressl macsec p2p privsep ps3 qt5 readline selinux smartcard tdls uncommon-eap-types wimax wps kernel_linux kernel_FreeBSD"
CDEPEND="dbus? ( sys-apps/dbus )
kernel_linux? (
@@ -39,17 +37,8 @@ CDEPEND="dbus? ( sys-apps/dbus )
sys-libs/ncurses:0=
sys-libs/readline:0=
)
- ssl? (
- gnutls? (
- dev-libs/libgcrypt:0=
- net-libs/gnutls:=
- )
- !gnutls? (
- !libressl? ( >=dev-libs/openssl-1.0.2k:0=[bindist=] )
- libressl? ( dev-libs/libressl:0= )
- )
- )
- !ssl? ( dev-libs/libtommath )
+ !libressl? ( >=dev-libs/openssl-1.0.2k:0=[bindist=] )
+ libressl? ( dev-libs/libressl:0= )
"
DEPEND="${CDEPEND}
virtual/pkgconfig
@@ -88,16 +77,6 @@ Kconfig_style_config() {
fi
}
-pkg_setup() {
- if use ssl ; then
- if use gnutls && use libressl ; then
- elog "You have both 'gnutls' and 'libressl' USE flags enabled: defaulting to USE=\"gnutls\""
- fi
- else
- elog "You have 'ssl' USE flag disabled: defaulting to internal TLS implementation"
- fi
-}
-
src_prepare() {
default
@@ -154,6 +133,11 @@ src_configure() {
Kconfig_style_config IBSS_RSN
Kconfig_style_config IEEE80211W
Kconfig_style_config IEEE80211R
+ Kconfig_style_config HT_OVERRIDES
+ Kconfig_style_config VHT_OVERRIDES
+ Kconfig_style_config OCV
+ Kconfig_style_config TLSV11
+ Kconfig_style_config TLSV12
# Basic authentication methods
# NOTE: we don't set GPSK or SAKE as they conflict
@@ -225,34 +209,20 @@ src_configure() {
Kconfig_style_config WPA_CLI_EDIT
fi
- if use suiteb; then
+ Kconfig_style_config TLS openssl
+ Kconfig_style_config FST
+ if ! use bindist; then
+ Kconfig_style_config EAP_PWD
+ Kconfig_style_config FILS
+ Kconfig_style_config FILS_SK_PFS
+ # Enabling mesh networks.
+ Kconfig_style_config MESH
+ #WPA3
+ Kconfig_style_config OWE
+ Kconfig_style_config SAE
+ Kconfig_style_config DPP
Kconfig_style_config SUITEB
- fi
-
- # SSL authentication methods
- if use ssl ; then
- if use gnutls ; then
- Kconfig_style_config TLS gnutls
- Kconfig_style_config GNUTLS_EXTRA
- else
- #this fails for gnutls
- Kconfig_style_config SUITEB192
- Kconfig_style_config TLS openssl
- if ! use bindist; then
- #this fails for gnutls
- Kconfig_style_config EAP_PWD
- # SAE fails on gnutls and everything below here needs SAE
- # Enabling mesh networks.
- Kconfig_style_config MESH
- #WPA3
- Kconfig_style_config OWE
- Kconfig_style_config SAE
- #we also need to disable FILS, except that isn't enabled yet
- fi
-
- fi
- else
- Kconfig_style_config TLS internal
+ Kconfig_style_config SUITEB192
fi
if use smartcard ; then
@@ -273,6 +243,13 @@ src_configure() {
Kconfig_style_config DRIVER_WEXT
Kconfig_style_config DRIVER_WIRED
+ if use macsec ; then
+ #requires something, no idea what
+ #Kconfig_style_config DRIVER_MACSEC_QCA
+ Kconfig_style_config DRIVER_MACSEC_LINUX
+ Kconfig_style_config MACSEC
+ fi
+
if use ps3 ; then
Kconfig_style_config DRIVER_PS3
fi
@@ -404,7 +381,7 @@ src_install() {
insinto /etc/dbus-1/system.d
newins dbus-wpa_supplicant.conf wpa_supplicant.conf
insinto /usr/share/dbus-1/system-services
- doins fi.epitest.hostap.WPASupplicant.service fi.w1.wpa_supplicant1.service
+ doins fi.w1.wpa_supplicant1.service
popd > /dev/null || die
# This unit relies on dbus support, bug 538600.
@@ -429,9 +406,9 @@ pkg_postinst() {
ewarn "needs to be moved to ${EROOT%/}/etc/wpa_supplicant/wpa_supplicant.conf"
fi
- if use bindist || use gnutls; then
+ if use bindist; then
if ! use libressl; then
- ewarn "Using bindist or gnutls use flags presently breaks WPA3 (specifically SAE and OWE)."
+ ewarn "Using bindist use flag presently breaks WPA3 (specifically SAE, OWE, DPP, and FILS)."
ewarn "This is incredibly undesirable"
fi
fi