summaryrefslogtreecommitdiff
path: root/net-wireless/wavemon/files
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/wavemon/files')
-rw-r--r--net-wireless/wavemon/files/wavemon-0.6.7-dont-override-CFLAGS.patch11
-rw-r--r--net-wireless/wavemon/files/wavemon-0.7.6-ncurses-tinfo.patch19
-rw-r--r--net-wireless/wavemon/files/wavemon-0.8.0-build.patch33
3 files changed, 63 insertions, 0 deletions
diff --git a/net-wireless/wavemon/files/wavemon-0.6.7-dont-override-CFLAGS.patch b/net-wireless/wavemon/files/wavemon-0.6.7-dont-override-CFLAGS.patch
new file mode 100644
index 000000000000..df98db7cd590
--- /dev/null
+++ b/net-wireless/wavemon/files/wavemon-0.6.7-dont-override-CFLAGS.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -9,8 +9,6 @@
+ AC_DEFINE_UNQUOTED([BUILD_DATE], ["`/bin/date`"],
+ [date wavemon was last configured and built])
+
+-CFLAGS="-O2 -Wall"
+-
+ # wavemon is only supported on Linux, warn user about futile compilations
+ AC_CANONICAL_HOST
+ case "$host_os" in
diff --git a/net-wireless/wavemon/files/wavemon-0.7.6-ncurses-tinfo.patch b/net-wireless/wavemon/files/wavemon-0.7.6-ncurses-tinfo.patch
new file mode 100644
index 000000000000..e8d0af99587b
--- /dev/null
+++ b/net-wireless/wavemon/files/wavemon-0.7.6-ncurses-tinfo.patch
@@ -0,0 +1,19 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -21,6 +21,7 @@
+ AC_PROG_CC
+ AC_PROG_CPP
+ AC_PROG_INSTALL
++PKG_PROG_PKG_CONFIG
+
+ # Checks for header files.
+ AC_HEADER_STDC
+@@ -52,7 +53,7 @@
+
+ # Tests involving libraries
+ AC_CHECK_LIB([m], [pow], [], [AC_MSG_ERROR(math library not found)])
+-AC_CHECK_LIB([ncurses], [waddstr], [], [AC_MSG_ERROR(ncurses library not found)])
++PKG_CHECK_MODULES([ncurses], [ncurses], [LIBS="$LIBS $ncurses_LIBS"], AC_MSG_ERROR([ncurses is required but was not found]))
+ AC_CHECK_LIB([pthread], [pthread_create], [CFLAGS="$CFLAGS -pthread"],
+ [AC_MSG_ERROR(pthread library not found)])
+ AC_CHECK_LIB([cap], [cap_get_flag])
diff --git a/net-wireless/wavemon/files/wavemon-0.8.0-build.patch b/net-wireless/wavemon/files/wavemon-0.8.0-build.patch
new file mode 100644
index 000000000000..373b27e3e255
--- /dev/null
+++ b/net-wireless/wavemon/files/wavemon-0.8.0-build.patch
@@ -0,0 +1,33 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -15,8 +15,6 @@
+ AC_DEFINE_UNQUOTED([BUILD_DATE], ["`/bin/date`"],
+ [date wavemon was last configured and built])
+
+-CFLAGS="-O2 -Wall"
+-
+ # wavemon is only supported on Linux, warn user about futile compilations
+ AC_CANONICAL_HOST
+ case "$host_os" in
+diff -uarN a/Makefile.in b/Makefile.in
+--- a/Makefile.in 2017-07-14 21:35:18.154423280 +0300
++++ b/Makefile.in 2017-07-14 21:35:34.613402738 +0300
+@@ -9,7 +9,7 @@
+ install-suid-root: exec_perms = 4755
+
+ CC ?= @CC@
+-CFLAGS ?= @CFLAGS@ @LIBNL3_CFLAGS@
++CFLAGS = @CFLAGS@ @LIBNL3_CFLAGS@
+ CPPFLAGS ?= @CPPFLAGS@
+ LDFLAGS ?= @LDFLAGS@
+ DEFS ?= @DEFS@
+@@ -25,8 +25,7 @@
+ DOCS = README.md NEWS THANKS AUTHORS COPYING ChangeLog
+
+ %.o: %.c $(HEADERS)
+- @echo ' CC ' $<
+- @$(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) $(DEFS) -c -o $@ $<
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) $(DEFS) -c -o $@ $<
+
+ all: @PACKAGE_NAME@
+ @PACKAGE_NAME@: $(MAIN) $(OBJS)