summaryrefslogtreecommitdiff
path: root/net-wireless/ubertooth/ubertooth-2018.12.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/ubertooth/ubertooth-2018.12.1.ebuild')
-rw-r--r--net-wireless/ubertooth/ubertooth-2018.12.1.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/net-wireless/ubertooth/ubertooth-2018.12.1.ebuild b/net-wireless/ubertooth/ubertooth-2018.12.1.ebuild
index 845ee09d3793..32189828f352 100644
--- a/net-wireless/ubertooth/ubertooth-2018.12.1.ebuild
+++ b/net-wireless/ubertooth/ubertooth-2018.12.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI="7"
-inherit cmake-utils udev
+inherit cmake udev
HOMEPAGE="http://ubertooth.sourceforge.net/"
@@ -34,6 +34,8 @@ DESCRIPTION="open source wireless development platform suitable for Bluetooth ex
#readd firmware building, but do it right
#USE="-fortran -mudflap -nls -openmp -multilib" crossdev --without-headers --genv 'EXTRA_ECONF="--with-mode=thumb --with-cpu=cortex-m3 --with-float=soft"' -s4 -t arm-cortexm3-eabi
+PATCHES=( "${FILESDIR}"/"${P}"-gcc-10.patch )
+
src_configure() {
local mycmakeargs=(
-DUSE_BLUEZ=$(usex bluez)
@@ -47,11 +49,11 @@ src_configure() {
-DUDEV_RULES_PATH="$(get_udevdir)/rules.d"
)
fi
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
insinto /usr/share/${PN}
pushd "${WORKDIR}/${PN}-${MY_PV}" || die