summaryrefslogtreecommitdiff
path: root/net-wireless/soapyremote
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/soapyremote')
-rw-r--r--net-wireless/soapyremote/Manifest4
-rw-r--r--net-wireless/soapyremote/metadata.xml11
-rw-r--r--net-wireless/soapyremote/soapyremote-0.4.3.ebuild29
-rw-r--r--net-wireless/soapyremote/soapyremote-9999.ebuild31
4 files changed, 75 insertions, 0 deletions
diff --git a/net-wireless/soapyremote/Manifest b/net-wireless/soapyremote/Manifest
new file mode 100644
index 000000000000..712777796c99
--- /dev/null
+++ b/net-wireless/soapyremote/Manifest
@@ -0,0 +1,4 @@
+DIST soapyremote-0.4.3.tar.gz 60023 BLAKE2B bff0b681d850794c7a3cc23bc9cb6276e3c579a074101ed82e76a933e5d9cd84b96fc7be5560ee166bcf624f0ba968ff259309fb9bb17fa8ccf4ebe903db5a33 SHA512 58e91c2da52440acab0930d5a913715d173c309aed83489e1adb408fbae99c22e4e549412dc5a655f266cfbfaf0a67e45eb330aaf9df0fc9b699a7aaa7c12ff6
+EBUILD soapyremote-0.4.3.ebuild 669 BLAKE2B 078f4c65fbda3a1907571daa17b71315b9ba47352fe845fc8259341e4e8a51b2fc9b5d0a4403a9fde066f2575b3d17b9acd48ffc26752f99b25f52cac18ee0f3 SHA512 d495a081d16cdfebf3e67bc0e2f54432ceb83bfadde0cf15cb3a02389af49351a1144a83b815748b4759fbab339750d01310b77fab53c106ae32a5145c44e0ec
+EBUILD soapyremote-9999.ebuild 714 BLAKE2B 10f45adb3bd980d3e95ad80dc4ee1ba45b5625a133376a9e2ecd7854ab76c576a9beac71861cc7c36cdefcca0913f31c35974b2f02fd265a9caa0a937fc9b4b6 SHA512 58320ccfbe3a96fd5abf30ed01a3de79adad946d791072cc2f3f40b772226de780cf6491f5b681475e4bae6826aeff68fbc1739b5108bfb7cbd31afe7fb8ae80
+MISC metadata.xml 336 BLAKE2B cf77d5c87670b460f2965ad571a9566510d3df71a56aed5d8b1ebbdbee2ee0332a073ff30c2410f628053ee33fe55b7d391e1a6de7802344b3c5fc5e792ed318 SHA512 b8b0bd12ddb26ac45f533bf7d46e8f2bd4306cee47283e0f71d7bfd9701a47bdb85c5082cc070a5b6bf42f518cff91861360ab68505594e3b3d35042f42d0a72
diff --git a/net-wireless/soapyremote/metadata.xml b/net-wireless/soapyremote/metadata.xml
new file mode 100644
index 000000000000..ec3d8fb8c80d
--- /dev/null
+++ b/net-wireless/soapyremote/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>idl0r@gentoo.org</email>
+ <name>Christian Ruppert</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pothosware/SoapyRemote</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-wireless/soapyremote/soapyremote-0.4.3.ebuild b/net-wireless/soapyremote/soapyremote-0.4.3.ebuild
new file mode 100644
index 000000000000..0b994353296d
--- /dev/null
+++ b/net-wireless/soapyremote/soapyremote-0.4.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Soapy SDR remote module"
+HOMEPAGE="https://github.com/pothosware/SoapyRemote"
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/pothosware/SoapyRemote.git"
+ EGIT_CLONE_TYPE="shallow"
+ KEYWORDS=""
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/pothosware/SoapyRemote/archive/soapy-remote-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/SoapyRemote-soapy-remote-"${PV}"
+fi
+
+LICENSE="Boost-1.0"
+SLOT="0"
+
+IUSE=""
+REQUIRED_USE=""
+
+RDEPEND="net-wireless/soapysdr"
+DEPEND="${RDEPEND}"
diff --git a/net-wireless/soapyremote/soapyremote-9999.ebuild b/net-wireless/soapyremote/soapyremote-9999.ebuild
new file mode 100644
index 000000000000..e1818a79ebcb
--- /dev/null
+++ b/net-wireless/soapyremote/soapyremote-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit cmake-utils
+
+DESCRIPTION="Soapy SDR remote module"
+HOMEPAGE="https://github.com/pothosware/SoapyRemote"
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/pothosware/SoapyRemote.git"
+ EGIT_CLONE_TYPE="shallow"
+ KEYWORDS=""
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/pothosware/SoapyRemote/archive/soapy-remote-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/SoapyRemote-soapy-remote-"${PV}"
+fi
+
+LICENSE="Boost-1.0"
+SLOT="0"
+
+IUSE=""
+REQUIRED_USE=""
+
+RDEPEND="net-wireless/soapysdr"
+DEPEND="${RDEPEND}"