summaryrefslogtreecommitdiff
path: root/net-wireless/rtl_power_fftw/rtl_power_fftw-0.0_p20180528.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/rtl_power_fftw/rtl_power_fftw-0.0_p20180528.ebuild')
-rw-r--r--net-wireless/rtl_power_fftw/rtl_power_fftw-0.0_p20180528.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-wireless/rtl_power_fftw/rtl_power_fftw-0.0_p20180528.ebuild b/net-wireless/rtl_power_fftw/rtl_power_fftw-0.0_p20180528.ebuild
new file mode 100644
index 000000000000..1ab71952dffc
--- /dev/null
+++ b/net-wireless/rtl_power_fftw/rtl_power_fftw-0.0_p20180528.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="power spectrum for RTLSDR dongles"
+HOMEPAGE="https://github.com/AD-Vega/rtl-power-fftw"
+
+LICENSE="GPL-3"
+SLOT="0"
+if [ "${PV}" = "9999" ]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/AD-Vega/rtl-power-fftw.git"
+else
+ KEYWORDS="~amd64 ~x86"
+ COMMIT="d567a454a6c96a67c61242178363e29d4cc84d64"
+ SRC_URI="https://github.com/AD-Vega/rtl-power-fftw/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN//_/-}-${COMMIT}"
+fi
+
+IUSE=""
+
+RDEPEND="dev-cpp/tclap
+ sci-libs/fftw:=
+ net-wireless/rtl-sdr:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"