summaryrefslogtreecommitdiff
path: root/net-wireless/blueman/blueman-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/blueman/blueman-9999.ebuild')
-rw-r--r--net-wireless/blueman/blueman-9999.ebuild20
1 files changed, 9 insertions, 11 deletions
diff --git a/net-wireless/blueman/blueman-9999.ebuild b/net-wireless/blueman/blueman-9999.ebuild
index 65fe1c7ffb7d..bec135aa318c 100644
--- a/net-wireless/blueman/blueman-9999.ebuild
+++ b/net-wireless/blueman/blueman-9999.ebuild
@@ -1,11 +1,12 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+DISTUTILS_EXT=1
DISTUTILS_SINGLE_IMPL=1
DISTUTILS_USE_PEP517=no
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit autotools distutils-r1 gnome2-utils linux-info systemd xdg-utils
@@ -20,7 +21,7 @@ else
https://github.com/blueman-project/blueman/releases/download/${PV/_/.}/${P/_/.}.tar.xz
"
S=${WORKDIR}/${P/_/.}
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
fi
# icons are GPL-2
@@ -67,11 +68,14 @@ RDEPEND="
>=net-misc/networkmanager-0.8[introspection]
)
)
- policykit? ( sys-auth/polkit )
+ policykit? (
+ sys-auth/polkit
+ )
pulseaudio? (
|| (
- media-video/pipewire[bluetooth]
media-sound/pulseaudio-daemon[bluetooth]
+ media-video/pipewire[bluetooth]
+ <media-sound/pulseaudio-15.99.1[bluetooth]
)
)
"
@@ -123,12 +127,6 @@ python_compile() {
default
}
-python_test() {
- # import tests are not very valuable and fail if /dev/rfkill
- # does not exist
- "${EPYTHON}" -m unittest -v test/test_gobject.py || die
-}
-
python_install() {
default