summaryrefslogtreecommitdiff
path: root/net-vpn/vpnc-scripts
diff options
context:
space:
mode:
Diffstat (limited to 'net-vpn/vpnc-scripts')
-rw-r--r--net-vpn/vpnc-scripts/Manifest4
-rw-r--r--net-vpn/vpnc-scripts/metadata.xml8
-rw-r--r--net-vpn/vpnc-scripts/vpnc-scripts-20210402.ebuild23
-rw-r--r--net-vpn/vpnc-scripts/vpnc-scripts-99999999.ebuild23
4 files changed, 58 insertions, 0 deletions
diff --git a/net-vpn/vpnc-scripts/Manifest b/net-vpn/vpnc-scripts/Manifest
new file mode 100644
index 000000000000..5b0aeb256a5e
--- /dev/null
+++ b/net-vpn/vpnc-scripts/Manifest
@@ -0,0 +1,4 @@
+DIST vpnc-scripts-20210402.tar.gz 39925 BLAKE2B 2bc8a274773e51ba48e402588fdf5b51d20360f610afe5608f91dfe2466644b68d891a60c27e4c6938b4ed5da1f193ddb7a8ac955c8f02e6bf91437dc5c47620 SHA512 5f9fc5ab1a5a2607f807700536c4a8e71c551052e72979c1cdd02b15906615be33a297b873b0806f269e51645f10f1c02a7acfed2501148bfa2797250582920d
+EBUILD vpnc-scripts-20210402.ebuild 594 BLAKE2B fe8d8a629332563b792285af44ef9b4199200cba23471ee3deeb5dc748ca55f009cebf35d024a22b5b0b1a4b7ddaf9be3ea4b68bb1cafcbbfab0954957d54dbb SHA512 4dea57427a334d1c6a349c3461a6ee50e5202475e218435ba5d6fb4d6ca15cbdd2e8317fcde4a2aca8a4a766e4729c43caf552aa1d0e262b609fe688e8710630
+EBUILD vpnc-scripts-99999999.ebuild 594 BLAKE2B fe8d8a629332563b792285af44ef9b4199200cba23471ee3deeb5dc748ca55f009cebf35d024a22b5b0b1a4b7ddaf9be3ea4b68bb1cafcbbfab0954957d54dbb SHA512 4dea57427a334d1c6a349c3461a6ee50e5202475e218435ba5d6fb4d6ca15cbdd2e8317fcde4a2aca8a4a766e4729c43caf552aa1d0e262b609fe688e8710630
+MISC metadata.xml 246 BLAKE2B f94a229d0ffd7220f14c23ca2b0b6b84128338b5af27cd18ddb0c9e2f95f51c943fdfbc368c03b4a87d7bb381c668158fdc169fd067cc0cd8cd35852acc29d62 SHA512 b6df287a6e1f18bf267a05d8eb6dea788ae7ec74de31d9cea76fea038e4090c6a83d62221505d280d55e9b314d059c409e442951d78eb3a58928307ff118147b
diff --git a/net-vpn/vpnc-scripts/metadata.xml b/net-vpn/vpnc-scripts/metadata.xml
new file mode 100644
index 000000000000..de09ffd8b089
--- /dev/null
+++ b/net-vpn/vpnc-scripts/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>floppym@gentoo.org</email>
+ <name>Mike Gilbert</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-vpn/vpnc-scripts/vpnc-scripts-20210402.ebuild b/net-vpn/vpnc-scripts/vpnc-scripts-20210402.ebuild
new file mode 100644
index 000000000000..83fa0467d1d8
--- /dev/null
+++ b/net-vpn/vpnc-scripts/vpnc-scripts-20210402.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == 99999999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/openconnect/vpnc-scripts.git"
+else
+ SRC_URI="ftp://ftp.infradead.org/pub/vpnc-scripts/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Connect scripts for use with vpnc and openconnect (and similar clients)"
+HOMEPAGE="https://gitlab.com/openconnect/vpnc-scripts"
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+src_install() {
+ exeinto /etc/vpnc-scripts
+ doexe vpnc-script{,-{ptrtd,sshd}}
+}
diff --git a/net-vpn/vpnc-scripts/vpnc-scripts-99999999.ebuild b/net-vpn/vpnc-scripts/vpnc-scripts-99999999.ebuild
new file mode 100644
index 000000000000..83fa0467d1d8
--- /dev/null
+++ b/net-vpn/vpnc-scripts/vpnc-scripts-99999999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == 99999999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/openconnect/vpnc-scripts.git"
+else
+ SRC_URI="ftp://ftp.infradead.org/pub/vpnc-scripts/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Connect scripts for use with vpnc and openconnect (and similar clients)"
+HOMEPAGE="https://gitlab.com/openconnect/vpnc-scripts"
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+src_install() {
+ exeinto /etc/vpnc-scripts
+ doexe vpnc-script{,-{ptrtd,sshd}}
+}