summaryrefslogtreecommitdiff
path: root/net-vpn/tor/tor-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-vpn/tor/tor-9999.ebuild')
-rw-r--r--net-vpn/tor/tor-9999.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/net-vpn/tor/tor-9999.ebuild b/net-vpn/tor/tor-9999.ebuild
index 009e202668a5..7d9d0b0a91ee 100644
--- a/net-vpn/tor/tor-9999.ebuild
+++ b/net-vpn/tor/tor-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -153,6 +153,17 @@ src_test() {
:sandbox/openat_filename
)
+ if use arm ; then
+ skip_tests+=(
+ # bug #920905
+ # https://gitlab.torproject.org/tpo/core/tor/-/issues/40912
+ :sandbox/opendir_dirname
+ :sandbox/openat_filename
+ :sandbox/chmod_filename
+ :sandbox/rename_filename
+ )
+ fi
+
# The makefile runs these by parallel by chunking them with a script
# but that means we lose verbosity and can't skip individual tests easily
# either.