summaryrefslogtreecommitdiff
path: root/net-vpn/tor/tor-0.4.4.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-vpn/tor/tor-0.4.4.8.ebuild')
-rw-r--r--net-vpn/tor/tor-0.4.4.8.ebuild18
1 files changed, 16 insertions, 2 deletions
diff --git a/net-vpn/tor/tor-0.4.4.8.ebuild b/net-vpn/tor/tor-0.4.4.8.ebuild
index 6a411102af45..bdb635b77531 100644
--- a/net-vpn/tor/tor-0.4.4.8.ebuild
+++ b/net-vpn/tor/tor-0.4.4.8.ebuild
@@ -3,7 +3,8 @@
EAPI="7"
-inherit flag-o-matic readme.gentoo-r1 systemd verify-sig
+PYTHON_COMPAT=( python3_{7,8,9} )
+inherit flag-o-matic python-any-r1 readme.gentoo-r1 systemd verify-sig
MY_PV="$(ver_rs 4 -)"
MY_PF="${PN}-${MY_PV}"
@@ -16,7 +17,9 @@ S="${WORKDIR}/${MY_PF}"
LICENSE="BSD GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86 ~ppc-macos"
+if [[ ${PV} != *_alpha* && ${PV} != *_beta* && ${PV} != *_rc* ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86 ~ppc-macos"
+fi
IUSE="caps doc lzma +man scrypt seccomp selinux +server systemd tor-hardening test zstd"
VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/torproject.org.asc
@@ -38,6 +41,13 @@ RDEPEND="
${DEPEND}
selinux? ( sec-policy/selinux-tor )"
+# bug #764260
+DEPEND+="
+ test? (
+ ${DEPEND}
+ ${PYTHON_DEPS}
+ )"
+
PATCHES=(
"${FILESDIR}"/${PN}-0.2.7.4-torrc.sample.patch
"${FILESDIR}"/${PN}-0.3.3.2-alpha-tor.service.in.patch
@@ -47,6 +57,10 @@ DOCS=()
RESTRICT="!test? ( test )"
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
src_configure() {
use doc && DOCS+=( README ChangeLog ReleaseNotes doc/HACKING )
export ac_cv_lib_cap_cap_init=$(usex caps)