summaryrefslogtreecommitdiff
path: root/net-vpn/protonvpn-cli/protonvpn-cli-2.2.11-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-vpn/protonvpn-cli/protonvpn-cli-2.2.11-r1.ebuild')
-rw-r--r--net-vpn/protonvpn-cli/protonvpn-cli-2.2.11-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-vpn/protonvpn-cli/protonvpn-cli-2.2.11-r1.ebuild b/net-vpn/protonvpn-cli/protonvpn-cli-2.2.11-r1.ebuild
new file mode 100644
index 000000000000..9ae7f688ec16
--- /dev/null
+++ b/net-vpn/protonvpn-cli/protonvpn-cli-2.2.11-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A VPN command-line tool from protonvpn - python rewrite"
+HOMEPAGE="https://protonvpn.com https://github.com/ProtonVPN/protonvpn-cli-ng"
+SRC_URI="https://github.com/ProtonVPN/linux-cli-community/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND="dev-python/docopt[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/pythondialog:0[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+ net-vpn/openvpn"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/linux-cli-community-${PV}"
+
+DOCS=( CHANGELOG.md README.md USAGE.md )