summaryrefslogtreecommitdiff
path: root/net-vpn/openvpn/openvpn-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-vpn/openvpn/openvpn-9999.ebuild')
-rw-r--r--net-vpn/openvpn/openvpn-9999.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/net-vpn/openvpn/openvpn-9999.ebuild b/net-vpn/openvpn/openvpn-9999.ebuild
index 8ad3d42ffc35..8cf7c4dc8093 100644
--- a/net-vpn/openvpn/openvpn-9999.ebuild
+++ b/net-vpn/openvpn/openvpn-9999.ebuild
@@ -64,10 +64,10 @@ src_configure() {
SYSTEMD_UNIT_DIR=$(systemd_get_systemunitdir) \
TMPFILES_DIR="/usr/lib/tmpfiles.d" \
econf \
- --with-plugindir="${ROOT}/usr/$(get_libdir)/$PN" \
- $(usex mbedtls 'with-crypto-library' 'mbedtls' '' '') \
+ --with-plugindir="${EPREFIX}/usr/$(get_libdir)/$PN" \
$(use_enable inotify async-push) \
$(use_enable ssl crypto) \
+ $(use_with ssl crypto-library $(usex mbedtls mbedtls openssl)) \
$(use_enable lz4) \
$(use_enable lzo) \
$(use_enable pkcs11) \