summaryrefslogtreecommitdiff
path: root/net-vpn/openvpn/openvpn-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-vpn/openvpn/openvpn-9999.ebuild')
-rw-r--r--net-vpn/openvpn/openvpn-9999.ebuild27
1 files changed, 12 insertions, 15 deletions
diff --git a/net-vpn/openvpn/openvpn-9999.ebuild b/net-vpn/openvpn/openvpn-9999.ebuild
index b8189f16f79b..6dc536051832 100644
--- a/net-vpn/openvpn/openvpn-9999.ebuild
+++ b/net-vpn/openvpn/openvpn-9999.ebuild
@@ -1,27 +1,25 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit autotools flag-o-matic systemd linux-info tmpfiles
+inherit autotools systemd linux-info tmpfiles
DESCRIPTION="Robust and highly flexible tunneling application compatible with many OSes"
HOMEPAGE="https://openvpn.net/"
if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="https://github.com/OpenVPN/${PN}.git"
- EGIT_SUBMODULES=(-cmocka)
-
inherit git-r3
else
- SRC_URI="https://build.openvpn.net/downloads/releases/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+ SRC_URI="https://build.openvpn.net/downloads/releases/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="down-root examples inotify iproute2 +lz4 +lzo mbedtls +openssl"
+IUSE="dco down-root examples inotify iproute2 +lz4 +lzo mbedtls +openssl"
IUSE+=" pam pkcs11 +plugins selinux systemd test"
RESTRICT="!test? ( test )"
@@ -30,6 +28,7 @@ REQUIRED_USE="
pkcs11? ( !mbedtls )
!plugins? ( !pam !down-root )
inotify? ( plugins )
+ dco? ( !iproute2 )
"
CDEPEND="
@@ -39,10 +38,12 @@ CDEPEND="
lz4? ( app-arch/lz4 )
lzo? ( >=dev-libs/lzo-1.07 )
mbedtls? ( net-libs/mbedtls:= )
- openssl? ( >=dev-libs/openssl-0.9.8:0= )
+ openssl? ( >=dev-libs/openssl-1.0.2:0= )
pam? ( sys-libs/pam )
pkcs11? ( >=dev-libs/pkcs11-helper-1.11 )
systemd? ( sys-apps/systemd )
+ dco? ( >=net-vpn/ovpn-dco-0.2 >=dev-libs/libnl-3.2.29:= )
+ sys-libs/libcap-ng:=
"
BDEPEND="virtual/pkgconfig"
@@ -60,11 +61,6 @@ if [[ ${PV} = "9999" ]]; then
BDEPEND+=" dev-python/docutils"
fi
-PATCHES=(
- "${FILESDIR}"/openvpn-2.5.0-auth-pam-missing-header.patch
- "${FILESDIR}"/openvpn-2.5.2-detect-python-rst2man.patch
-)
-
pkg_setup() {
local CONFIG_CHECK="~TUN"
linux-info_pkg_setup
@@ -95,6 +91,7 @@ src_configure() {
$(use_enable pam plugin-auth-pam)
$(use_enable down-root plugin-down-root)
$(use_enable systemd)
+ $(use_enable dco)
)
SYSTEMD_UNIT_DIR=$(systemd_get_systemunitdir) \
@@ -121,7 +118,7 @@ src_install() {
find "${ED}/usr" -name '*.la' -delete || die
# install documentation
- dodoc AUTHORS ChangeLog PORTS README README.IPv6
+ dodoc AUTHORS ChangeLog PORTS README
# Install some helper scripts
keepdir /etc/openvpn