summaryrefslogtreecommitdiff
path: root/net-vpn/openfortivpn/openfortivpn-1.19.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-vpn/openfortivpn/openfortivpn-1.19.0.ebuild')
-rw-r--r--net-vpn/openfortivpn/openfortivpn-1.19.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-vpn/openfortivpn/openfortivpn-1.19.0.ebuild b/net-vpn/openfortivpn/openfortivpn-1.19.0.ebuild
new file mode 100644
index 000000000000..f9a5078e5045
--- /dev/null
+++ b/net-vpn/openfortivpn/openfortivpn-1.19.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools linux-info
+
+DESCRIPTION="Fortinet compatible VPN client"
+HOMEPAGE="https://github.com/adrienverge/openfortivpn"
+SRC_URI="https://github.com/adrienverge/openfortivpn/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3-with-openssl-exception openssl"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-libs/openssl:0=
+ net-dialup/ppp
+"
+RDEPEND="${DEPEND}"
+
+CONFIG_CHECK="~PPP ~PPP_ASYNC"
+
+PATCHES=(
+ "${FILESDIR}/systemd_substitute_bin_and_sysconfig_dirs.patch"
+)
+
+src_prepare() {
+ default
+
+ sed -i 's/-Werror//g' Makefile.am || die "Failed to remove -Werror from Makefile.am"
+
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ keepdir /etc/openfortivpn
+}