summaryrefslogtreecommitdiff
path: root/net-vpn/eduvpn-client/eduvpn-client-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-vpn/eduvpn-client/eduvpn-client-9999.ebuild')
-rw-r--r--net-vpn/eduvpn-client/eduvpn-client-9999.ebuild15
1 files changed, 11 insertions, 4 deletions
diff --git a/net-vpn/eduvpn-client/eduvpn-client-9999.ebuild b/net-vpn/eduvpn-client/eduvpn-client-9999.ebuild
index 6e6179988a41..9b8f13bf2170 100644
--- a/net-vpn/eduvpn-client/eduvpn-client-9999.ebuild
+++ b/net-vpn/eduvpn-client/eduvpn-client-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -17,13 +17,19 @@ if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/eduvpn/python-${PN}.git"
S="${WORKDIR}/${P}"
else
- VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/eduvpn.asc
+ # Development Versions use a different release signing key
+ if [[ $(ver_cut 2) == 99 || $(ver_cut 3) == 99 ]] ; then
+ VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/eduvpn-dev.asc
+ else
+ VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/eduvpn.asc
+ fi
inherit verify-sig
MY_P="python-${P}"
SRC_URI="
https://github.com/eduvpn/python-eduvpn-client/releases/download/${PV}/${MY_P}.tar.xz
verify-sig? ( https://github.com/eduvpn/python-eduvpn-client/releases/download/${PV}/${MY_P}.tar.xz.asc )
"
+ KEYWORDS="~amd64 ~x86"
S="${WORKDIR}/${MY_P}"
fi
@@ -40,11 +46,12 @@ RESTRICT="test"
RDEPEND="
dev-python/requests[${PYTHON_USEDEP}]
dev-python/pygobject:3[${PYTHON_USEDEP}]
- >=net-vpn/eduvpn-common-1.2.0[${PYTHON_USEDEP}]
+ net-misc/networkmanager
+ >=net-vpn/eduvpn-common-1.99.0[${PYTHON_USEDEP}]
"
if [[ ${PV} != *9999* ]] ; then
- BDEPEND="verify-sig? ( sec-keys/openpgp-keys-eduvpn )"
+ BDEPEND="verify-sig? ( >=sec-keys/openpgp-keys-eduvpn-20240307 )"
fi
PATCHES=(