summaryrefslogtreecommitdiff
path: root/net-vpn/aiccu/files
diff options
context:
space:
mode:
Diffstat (limited to 'net-vpn/aiccu/files')
-rw-r--r--net-vpn/aiccu/files/aiccu-2007.01.15-Makefile.patch79
-rw-r--r--net-vpn/aiccu/files/aiccu-2007.01.15-gnutls-3.4.patch22
-rw-r--r--net-vpn/aiccu/files/aiccu-2007.01.15-r2-init.gentoo.patch33
-rw-r--r--net-vpn/aiccu/files/aiccu-2007.01.15-setupscript.patch17
-rw-r--r--net-vpn/aiccu/files/aiccu-2007.01.15-systemd.patch52
-rw-r--r--net-vpn/aiccu/files/aiccu-2007.01.15-uclibc.patch29
6 files changed, 0 insertions, 232 deletions
diff --git a/net-vpn/aiccu/files/aiccu-2007.01.15-Makefile.patch b/net-vpn/aiccu/files/aiccu-2007.01.15-Makefile.patch
deleted file mode 100644
index c0eabbefd906..000000000000
--- a/net-vpn/aiccu/files/aiccu-2007.01.15-Makefile.patch
+++ /dev/null
@@ -1,79 +0,0 @@
---- unix-console/Makefile.old 2010-06-28 21:56:32.287782600 +0200
-+++ unix-console/Makefile 2010-06-28 22:15:56.232637681 +0200
-@@ -25,14 +25,11 @@ CWARNS += -W -Wall -Wshadow -Wpointer-ar
- # CWARNS += -Wpacked
-
- #CFLAGS += $(CWARNS) -D_GNU_SOURCE -D_DEBUG -g3 -O0
--CFLAGS += $(CWARNS) -D_GNU_SOURCE
-+CFLAGS ?= $(CWARNS) -O3
-+CFLAGS += -D_GNU_SOURCE
- CC = @gcc
- RM = rm
--
--# Add -O3 when nothing is specified yet
--ifeq ($(shell echo $(CFLAGS) | grep -c "\-O"),0)
--CFLAGS += -O3
--endif
-+STRIP = strip
-
- # This is a console client
- CFLAGS += -D AICCU_CONSOLE
-@@ -42,7 +39,7 @@ CFLAGS += -D AICCU_CONSOLE
- # Currently defaultly builds only on Linux, but other platforms might easily also support it
- ifeq ($(shell uname | grep -c "Linux"),1)
- CFLAGS += -D AICCU_GNUTLS
--LDFLAGS += -lgnutls
-+LIBS += -lgnutls
- endif
-
- # Linux
-@@ -50,7 +47,7 @@ ifeq ($(shell uname | grep -c "Linux"),1
- CFLAGS += -D_LINUX -D HAS_IFHEAD -D AICCU_TYPE="\"linux\""
- SRCS += ../common/aiccu_linux.c
- OBJS += ../common/aiccu_linux.o
--LDFLAGS += -lpthread -lresolv
-+LIBS += -lpthread -lresolv
- endif
-
- # FreeBSD
-@@ -118,7 +115,7 @@ ifeq ($(shell uname | grep -c "Darwin"),
- CFLAGS += -D_DARWIN -D NEED_IFHEAD -D AICCU_TYPE="\"darwin\""
- SRCS += ../common/aiccu_darwin.c
- OBJS += ../common/aiccu_darwin.o
--LDFLAGS += -lresolv
-+LIBS += -lresolv
- endif
-
- # SunOS / Solaris
-@@ -126,7 +123,7 @@ ifeq ($(shell uname | grep -c "SunOS"),1
- CFLAGS += -D_SUNOS -D AICCU_TYPE="\"sunos\""
- SRCS += ../common/aiccu_sunos.c
- OBJS += ../common/aiccu_sunos.o
--LDFLAGS += -lsocket -lnsl -lresolv
-+LIBS += -lsocket -lnsl -lresolv
- endif
-
- # AIX
-@@ -137,17 +134,19 @@ CFLAGS += -D AICCU_CONSOLE
- CFLAGS += -D_AIX -D AICCU_TYPE="\"aix\""
- SRCS += ../common/aiccu_aix.c
- OBJS += ../common/aiccu_aix.o
--LDFLAGS += -lpthread
-+LIBS += -lpthread
- endif
-
-
- all: aiccu
-
- aiccu: $(OBJS) ${SRCS} ${INCS}
-- $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(OBJS)
-+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(OBJS) $(LIBS)
- ifeq ($(shell echo $(CFLAGS) | grep -c "DEBUG"),0)
- ifeq ($(shell echo "$(RPM_OPT_FLAGS)" | wc -c),1)
-- strip $@
-+ifdef STRIP
-+ $(STRIP) $@
-+endif
- endif
- endif
-
diff --git a/net-vpn/aiccu/files/aiccu-2007.01.15-gnutls-3.4.patch b/net-vpn/aiccu/files/aiccu-2007.01.15-gnutls-3.4.patch
deleted file mode 100644
index ee637a761029..000000000000
--- a/net-vpn/aiccu/files/aiccu-2007.01.15-gnutls-3.4.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-from http://git.alpinelinux.org/cgit/aports/tree/main/aiccu
-
---- aiccu/common/common.c 2015-04-17 23:08:32.543680010 +0200
-+++ aiccu/common/common.c.new 2015-04-17 23:14:02.152457972 +0200
-@@ -272,7 +272,6 @@
- {
- #ifdef AICCU_GNUTLS
- /* Allow connections to servers that have OpenPGP keys as well */
-- const int cert_type_priority[3] = { GNUTLS_CRT_X509, GNUTLS_CRT_OPENPGP, 0 };
- int ret;
- #endif /* AICCU_GNUTLS*/
-
-@@ -300,8 +299,7 @@
- gnutls_set_default_priority(sock->session);
- /* XXX: Return value is not documented in GNUTLS documentation! */
-
-- gnutls_certificate_type_set_priority(sock->session, cert_type_priority);
-- /* XXX: Return value is not documented in GNUTLS documentation! */
-+ gnutls_priority_set_direct(sock->session, "NORMAL:+CTYPE-OPENPGP", NULL);
-
- /* Configure the x509 credentials for the current session */
- gnutls_credentials_set(sock->session, GNUTLS_CRD_CERTIFICATE, g_aiccu->tls_cred);
diff --git a/net-vpn/aiccu/files/aiccu-2007.01.15-r2-init.gentoo.patch b/net-vpn/aiccu/files/aiccu-2007.01.15-r2-init.gentoo.patch
deleted file mode 100644
index 35ca2b8a6719..000000000000
--- a/net-vpn/aiccu/files/aiccu-2007.01.15-r2-init.gentoo.patch
+++ /dev/null
@@ -1,33 +0,0 @@
---- aiccu/doc/aiccu.init.gentoo
-+++ aiccu/doc/aiccu.init.gentoo
-@@ -2,7 +2,7 @@
-
- depend() {
- need net
-- after ntp-client
-+ after ntp-client ntpd
- }
-
- checkconfig() {
-@@ -23,14 +23,19 @@
- start() {
- checkconfig || return 1
- ebegin "Starting aiccu"
-- start-stop-daemon --start --oknodo --quiet --exec /usr/sbin/aiccu -- start
-+ start-stop-daemon --start --quiet --exec /usr/sbin/aiccu -- start
- eend $?
- }
-
-
- stop() {
- ebegin "Stopping aiccu"
-- start-stop-daemon --stop --oknodo --quiet --exec /usr/sbin/aiccu -- stop
-+ start-stop-daemon --stop --pidfile /var/run/aiccu.pid --quiet --exec /usr/sbin/aiccu -- stop
- eend $?
- }
-
-+restart() {
-+ stop
-+ sleep 3
-+ start
-+}
diff --git a/net-vpn/aiccu/files/aiccu-2007.01.15-setupscript.patch b/net-vpn/aiccu/files/aiccu-2007.01.15-setupscript.patch
deleted file mode 100644
index 8981530435f3..000000000000
--- a/net-vpn/aiccu/files/aiccu-2007.01.15-setupscript.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- aiccu/unix-console/main.c
-+++ aiccu/unix-console/main.c
-@@ -471,6 +471,14 @@
- */
- if (aiccu_setup(hTunnel, true))
- {
-+
-+ /* Running setup script */
-+ if (g_aiccu->setupscript)
-+ {
-+ aiccu_exec("%s", g_aiccu->setupscript);
-+ }
-+
-+
- /* We need to stay running when doing Heartbeat or AYIYA */
- if ( strcasecmp(hTunnel->sType, "6in4-heartbeat") == 0 ||
- strcasecmp(hTunnel->sType, "ayiya") == 0)
diff --git a/net-vpn/aiccu/files/aiccu-2007.01.15-systemd.patch b/net-vpn/aiccu/files/aiccu-2007.01.15-systemd.patch
deleted file mode 100644
index e8616d04b3fc..000000000000
--- a/net-vpn/aiccu/files/aiccu-2007.01.15-systemd.patch
+++ /dev/null
@@ -1,52 +0,0 @@
---- /dev/null
-+++ aiccu-2007.01.15/doc/aiccu.service
-@@ -0,0 +1,13 @@
-+[Unit]
-+Description=Automatic IPv6 Connectivity Client Utility
-+After=time-sync.target network.target
-+ConditionPathExists=/etc/aiccu.conf
-+
-+
-+[Service]
-+Type=notify
-+ExecStart=/usr/sbin/aiccu start
-+ExecStop=/usr/sbin/aiccu stop
-+
-+[Install]
-+WantedBy=multi-user.target
---- aiccu-2007.01.15/unix-console/Makefile
-+++ aiccu-2007.01.15/unix-console/Makefile
-@@ -48,6 +48,10 @@ ifeq ($(shell uname | grep -c "Linux"),1)
- SRCS += ../common/aiccu_linux.c
- OBJS += ../common/aiccu_linux.o
- LIBS += -lpthread -lresolv
-+ifeq (1,$(HAVE_SYSTEMD))
-+LIBS += $(shell pkg-config --libs libsystemd 2>/dev/null || pkg-config --libs libsystemd-daemon)
-+CFLAGS += -DHAVE_SYSTEMD
-+endif
- endif
-
- # FreeBSD
---- aiccu-2007.01.15/unix-console/main.c
-+++ aiccu-2007.01.15/unix-console/main.c
-@@ -12,6 +12,9 @@
-
- #include "../common/aiccu.h"
- #include "../common/tun.h"
-+#ifdef HAVE_SYSTEMD
-+#include <systemd/sd-daemon.h>
-+#endif
-
- #ifndef _WIN32
- /* Enable/Disable heartbeating */
-@@ -478,6 +481,10 @@ int main(int argc, char *argv[])
- aiccu_exec("%s", g_aiccu->setupscript);
- }
-
-+#ifdef HAVE_SYSTEMD
-+ /* Tell systemd we are operational. */
-+ sd_notify(0, "READY=1");
-+#endif
-
- /* We need to stay running when doing Heartbeat or AYIYA */
- if ( strcasecmp(hTunnel->sType, "6in4-heartbeat") == 0 ||
diff --git a/net-vpn/aiccu/files/aiccu-2007.01.15-uclibc.patch b/net-vpn/aiccu/files/aiccu-2007.01.15-uclibc.patch
deleted file mode 100644
index 56341dea72f4..000000000000
--- a/net-vpn/aiccu/files/aiccu-2007.01.15-uclibc.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- aiccu/common/resolver.c
-+++ aiccu/common/resolver.c
-@@ -26,7 +26,7 @@
-
- int getrrs(const char *label, int rrtype, void gotrec(unsigned int num, int type, const char *record))
- {
--#ifdef _LINUX
-+#if defined(_LINUX) && ! defined(__UCLIBC__)
- struct __res_state res;
- #endif
- unsigned char answer[8192];
-@@ -38,7 +38,7 @@
- uint16_t type = 0, class = 0;
- uint32_t ttl = 0;
-
--#ifdef _LINUX
-+#if defined(_LINUX) && ! defined(__UCLIBC__)
- memset(&res, 0, sizeof(res));
- res.options = RES_DEBUG;
- res_ninit(&res);
-@@ -47,7 +47,7 @@
- #endif
-
- memset(answer, 0, sizeof(answer));
--#ifdef _LINUX
-+#if defined(_LINUX) && ! defined(__UCLIBC__)
- ret = res_nquery(&res, label, C_IN, rrtype, answer, sizeof(answer));
- #else
- ret = res_query(label, C_IN, rrtype, answer, sizeof(answer));