summaryrefslogtreecommitdiff
path: root/net-vpn/aiccu/aiccu-2007.01.15-r5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-vpn/aiccu/aiccu-2007.01.15-r5.ebuild')
-rw-r--r--net-vpn/aiccu/aiccu-2007.01.15-r5.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/net-vpn/aiccu/aiccu-2007.01.15-r5.ebuild b/net-vpn/aiccu/aiccu-2007.01.15-r5.ebuild
deleted file mode 100644
index 2887d7a02020..000000000000
--- a/net-vpn/aiccu/aiccu-2007.01.15-r5.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils linux-info systemd toolchain-funcs
-
-DESCRIPTION="AICCU Client to configure an IPv6 tunnel to SixXS"
-HOMEPAGE="https://www.sixxs.net/tools/aiccu"
-SRC_URI="https://www.sixxs.net/archive/sixxs/aiccu/unix/aiccu_${PV//\./}.tar.gz"
-
-LICENSE="SixXS"
-SLOT="0"
-KEYWORDS="amd64 arm hppa ppc sparc x86"
-IUSE="systemd"
-
-RDEPEND="
- net-libs/gnutls
- sys-apps/iproute2
- systemd? ( sys-apps/systemd )
-"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
-"
-
-S=${WORKDIR}/${PN}
-
-CONFIG_CHECK="~TUN"
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-r2-init.gentoo.patch \
- "${FILESDIR}"/${P}-Makefile.patch \
- "${FILESDIR}"/${P}-setupscript.patch \
- "${FILESDIR}"/${P}-uclibc.patch \
- "${FILESDIR}"/${P}-systemd.patch \
- "${FILESDIR}"/${P}-gnutls-3.4.patch
-}
-
-src_compile() {
- # Don't use main Makefile since it requires additional
- # dependencies which are useless for us.
- emake CC=$(tc-getCC) STRIP= -C unix-console \
- HAVE_SYSTEMD=$(usex systemd 1 0)
-}
-
-src_install() {
- dosbin unix-console/${PN}
-
- insopts -m 600
- insinto /etc
- doins doc/${PN}.conf
- newinitd doc/${PN}.init.gentoo ${PN}
-
- use systemd && systemd_dounit doc/${PN}.service
-
- dodoc doc/{HOWTO,README,changelog}
-}