summaryrefslogtreecommitdiff
path: root/net-voip/yate/files
diff options
context:
space:
mode:
Diffstat (limited to 'net-voip/yate/files')
-rw-r--r--net-voip/yate/files/yate-5.4.0-dont-mess-with-cflags.patch15
-rw-r--r--net-voip/yate/files/yate-5.5.0-dont-mess-with-cflags.patch14
-rw-r--r--net-voip/yate/files/yate.confd10
-rw-r--r--net-voip/yate/files/yate.initd33
4 files changed, 72 insertions, 0 deletions
diff --git a/net-voip/yate/files/yate-5.4.0-dont-mess-with-cflags.patch b/net-voip/yate/files/yate-5.4.0-dont-mess-with-cflags.patch
new file mode 100644
index 000000000000..961d73fa1ccc
--- /dev/null
+++ b/net-voip/yate/files/yate-5.4.0-dont-mess-with-cflags.patch
@@ -0,0 +1,15 @@
+https://build.opensuse.org/package/view_file/network:telephony/yate/dont-mess-with-cflags.patch?expand=1
+
+Index: yate/configure.in
+===================================================================
+--- yate.orig/configure.in
++++ yate/configure.in
+@@ -1447,7 +1447,6 @@ fi
+
+
+ INSTALL_D="install -D"
+-CFLAGS=`echo "$CFLAGS" | sed 's/\(^\| *\)-g[[0-9]]*//' | sed 's/[[[:space:]]]\{2,\}/ /g'`
+ MODULE_CFLAGS="-fno-exceptions -fPIC $HAVE_GCC_FORMAT_CHECK $HAVE_BLOCK_RETURN"
+ MODULE_CPPFLAGS="-fno-check-new $RTTI_OPT $MODULE_CFLAGS"
+ MODULE_LDRELAX="-export-dynamic -shared"
+
diff --git a/net-voip/yate/files/yate-5.5.0-dont-mess-with-cflags.patch b/net-voip/yate/files/yate-5.5.0-dont-mess-with-cflags.patch
new file mode 100644
index 000000000000..1a2a98c24e9e
--- /dev/null
+++ b/net-voip/yate/files/yate-5.5.0-dont-mess-with-cflags.patch
@@ -0,0 +1,14 @@
+https://build.opensuse.org/package/view_file/network:telephony/yate/dont-mess-with-cflags.patch?expand=1
+
+Index: yate/configure.ac
+===================================================================
+--- yate.orig/configure.ac
++++ yate/configure.ac
+@@ -1652,7 +1652,6 @@ fi
+
+
+ INSTALL_D="install -D"
+-CFLAGS=`echo "$CFLAGS" | sed 's/\(^\| \+\)-g[[0-9]]*//' | sed 's/[[[:space:]]]\{2,\}/ /g'`
+ MODULE_CFLAGS="-fno-exceptions -fPIC $HAVE_GCC_FORMAT_CHECK $HAVE_BLOCK_RETURN"
+ MODULE_CPPFLAGS="$HAVE_NO_OVERLOAD_VIRT_WARN $RTTI_OPT $MODULE_CFLAGS"
+ MODULE_LDRELAX="-rdynamic -shared"
diff --git a/net-voip/yate/files/yate.confd b/net-voip/yate/files/yate.confd
new file mode 100644
index 000000000000..926cc563919f
--- /dev/null
+++ b/net-voip/yate/files/yate.confd
@@ -0,0 +1,10 @@
+# /etc/conf.d/yate: config file for /etc/init.d/yate
+
+# Any random options you want to pass to yate
+YATE_OPTS=""
+
+# Pid file to use (needs to be absolute path)
+#YATE_PIDFILE="/var/run/yate.pid"
+
+# Path to yate binary (needs to be absolute path)
+#YATE_BINARY="/usr/bin/yate"
diff --git a/net-voip/yate/files/yate.initd b/net-voip/yate/files/yate.initd
new file mode 100644
index 000000000000..75428424fd33
--- /dev/null
+++ b/net-voip/yate/files/yate.initd
@@ -0,0 +1,33 @@
+#!/sbin/openrc-run
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+extra_started_commands="reload"
+
+YATE_PIDFILE=${YATE_PIDFILE:-/var/run/${SVCNAME}.pid}
+YATE_BINARY=${YATE_BINARY:-/usr/bin/yate}
+
+depend() {
+ need net
+ use mysql postgresql zaptel
+}
+
+start() {
+ ebegin "Starting ${SVCNAME}"
+ start-stop-daemon --start --exec "${YATE_BINARY}" \
+ -- -d -p "${YATE_PIDFILE}" ${YATE_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ${SVCNAME}"
+ start-stop-daemon --stop --pidfile="${YATE_PIDFILE}"
+ eend $?
+}
+
+reload() {
+ ebegin "Reloading ${SVCNAME}"
+ start-stop-daemon --signal HUP --exec "${YATE_BINARY}" \
+ --pidfile "${YATE_PIDFILE}"
+ eend $?
+}