summaryrefslogtreecommitdiff
path: root/net-proxy/trojan/trojan-1.13.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-proxy/trojan/trojan-1.13.0.ebuild')
-rw-r--r--net-proxy/trojan/trojan-1.13.0.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/net-proxy/trojan/trojan-1.13.0.ebuild b/net-proxy/trojan/trojan-1.13.0.ebuild
index 64ae38797920..aa4fa9f95beb 100644
--- a/net-proxy/trojan/trojan-1.13.0.ebuild
+++ b/net-proxy/trojan/trojan-1.13.0.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{3_5,3_6,3_7} )
+PYTHON_COMPAT=( python{3_6,3_7} )
-inherit cmake-utils python-any-r1 systemd
+inherit cmake python-any-r1 systemd
DESCRIPTION="An unidentifiable mechanism that helps you bypass GFW"
HOMEPAGE="https://github.com/trojan-gfw/trojan"
@@ -33,16 +33,15 @@ src_configure() {
-DENABLE_MYSQL=$(usex mysql)
-DSYSTEMD_SERVICE=ON
-DSYSTEMD_SERVICE_PATH=$(systemd_get_systemunitdir)
- -DCMAKE_INSTALL_DOCDIR=share/doc/${PF}
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
newinitd "${FILESDIR}/trojan.initd" trojan
}
src_test() {
- cmake-utils_src_test -j1
+ cmake_src_test -j1
}