summaryrefslogtreecommitdiff
path: root/net-proxy/squid/files/squid-cppunit-1.14.patch
diff options
context:
space:
mode:
Diffstat (limited to 'net-proxy/squid/files/squid-cppunit-1.14.patch')
-rw-r--r--net-proxy/squid/files/squid-cppunit-1.14.patch417
1 files changed, 0 insertions, 417 deletions
diff --git a/net-proxy/squid/files/squid-cppunit-1.14.patch b/net-proxy/squid/files/squid-cppunit-1.14.patch
deleted file mode 100644
index f31268fc61d5..000000000000
--- a/net-proxy/squid/files/squid-cppunit-1.14.patch
+++ /dev/null
@@ -1,417 +0,0 @@
-# backport rev 14707 from trunk
---- Makefile.am 2016-01-30 09:09:25 +0000
-+++ Makefile.am 2016-06-13 07:46:59 +0000
-@@ -48,7 +48,7 @@
- check: have-cppunit check-recursive
-
- have-cppunit:
-- @if test "$(SQUID_CPPUNIT_INC)$(SQUID_CPPUNIT_LA)$(SQUID_CPPUNIT_LIBS)" = "" ; then \
-+ @if test "$(LIBCPPUNIT_CFLAGS)$(LIBCPPUNIT_LIBS)" = "" ; then \
- echo "FATAL: 'make check' requires cppunit and cppunit development packages. They do not appear to be installed." ; \
- exit 1 ; \
- fi
-
---- compat/Makefile.am 2016-02-09 08:57:33 +0000
-+++ compat/Makefile.am 2016-06-13 07:46:59 +0000
-@@ -94,7 +94,7 @@
- testPreCompiler_SOURCES= \
- testPreCompiler.h \
- testPreCompiler.cc
--testPreCompiler_LDADD= $(SQUID_CPPUNIT_LA) $(SQUID_CPPUNIT_LIBS)
-+testPreCompiler_LDADD= $(LIBCPPUNIT_LIBS)
- testPreCompiler_LDFLAGS=
-
- # os/ subdir prevents us using src/TestHeaders.am
-
---- configure.ac 2016-06-11 05:28:18 +0000
-+++ configure.ac 2016-06-13 07:46:59 +0000
-@@ -115,10 +115,11 @@
- AC_PATH_PROG(CHMOD, chmod, $FALSE)
- AC_PATH_PROG(TR, tr, $FALSE)
- AC_PATH_PROG(RM, rm, $FALSE)
--AC_PATH_PROG(CPPUNITCONFIG, cppunit-config, false)
- dnl Libtool 2.2.6 requires: rm -f
- RM="$RM -f"
-
-+PKG_PROG_PKG_CONFIG
-+
- AC_PATH_PROG(PERL, perl, none)
- if test "x$ac_cv_path_PERL" = "xnone"; then
- AC_MSG_FAILURE([Perl is required to compile Squid. Please install Perl and then re-run configure ])
-@@ -984,9 +985,6 @@
- ]
- )
-
--dnl Necessary if the first PKG_CHECK_MODULES call is conditional
--PKG_PROG_PKG_CONFIG
--
- dnl Perform configuration consistency checks for eCAP
- if test "x$squid_opt_use_ecap" != "xno";
- then
-@@ -2725,45 +2723,29 @@
- [Enable support for the X-Accelerator-Vary HTTP header])
- AC_MSG_NOTICE([X-Accelerator-Vary support enabled: $enable_x_accelerator_vary])
-
--
--if $CPPUNITCONFIG --help >/dev/null; then
-- squid_cv_cppunit_version="`$CPPUNITCONFIG --version`"
-- AC_MSG_NOTICE([using system installed cppunit version $squid_cv_cppunit_version])
-- unset squid_cv_cppunit_version
-- SQUID_CPPUNIT_LIBS="`$CPPUNITCONFIG --libs`"
-- SQUID_CPPUNIT_LA=''
-- SQUID_CPPUNIT_INC="`$CPPUNITCONFIG --cflags`"
--else
-- AC_MSG_WARN([cppunit does not appear to be installed. squid does not require this, but code testing with 'make check' will fail.])
-- SQUID_CPPUNIT_LA=''
-- SQUID_CPPUNIT_LIBS=''
-- SQUID_CPPUNIT_INC=''
--fi
--
--AC_ARG_WITH(cppunit-basedir,
-- AS_HELP_STRING([--with-cppunit-basedir=PATH],
-- [Path where the cppunit headers are libraries can be found ]), [
--if test -f "$withval/include/cppunit/TestCase.h"; then
-- AC_MSG_NOTICE([Using cppunit includes from $withval])
-- SQUID_CPPUNIT_INC="-I${withval}/include"
--else
-- AC_MSG_ERROR(Cannot find cppunit at $withval)
--fi
--if test -f "$withval/lib/libcppunit.la"; then
-- AC_MSG_NOTICE([Using cppunit lib from $withval])
-- SQUID_CPPUNIT_LA="${withval}/lib/libcppunit.la"
-- SQUID_CPPUNIT_LIBS='$(SQUID_CPPUNIT_LA)'
--else
-- AC_MSG_ERROR(Cannot find cppunit at $withval)
--fi
--])
--SQUID_STATE_SAVE(squid_cppunit_state)
--CXXFLAGS="$CXXFLAGS $SQUID_CPPUNIT_INC"
--AC_CHECK_HEADERS(cppunit/extensions/HelperMacros.h)
--SQUID_STATE_ROLLBACK(squid_cppunit_state)
--AC_SUBST(SQUID_CPPUNIT_LIBS)
--AC_SUBST(SQUID_CPPUNIT_LA)
--AC_SUBST(SQUID_CPPUNIT_INC)
-+AC_ARG_WITH([cppunit], AS_HELP_STRING([--without-cppunit],[Do not use cppunit test framework]),[
-+ AS_CASE($with_cppunit, [yes|no],[],
-+ [
-+ AS_IF([test ! -d "$withval"],AC_MSG_ERROR([--with-cppunit PATH does not point to a directory]))
-+ LIBCPPUNIT_CFLAGS="-I$with_cppunit/include"
-+ LIBCPPUNIT_LIBS="-L$with_cppunit/lib -lcppunit"
-+ ])
-+])
-+AS_IF([test "x$with_cppunit" != "xno"],[
-+ PKG_CHECK_MODULES([LIBCPPUNIT],[cppunit],[
-+ squid_cv_cppunit_version="`pkg-config cppunit --version`"
-+ AC_MSG_NOTICE([using system installed cppunit version $squid_cv_cppunit_version])
-+ AS_UNSET(squid_cv_cppunit_version)
-+
-+ SQUID_STATE_SAVE(squid_cppunit_state)
-+ AS_VAR_APPEND(CXXFLAGS,[$LIBCPPUNIT_CFLAGS])
-+ AS_VAR_APPEND(LIBS,[$LIBCPPUNIT_LIBS])
-+ AC_CHECK_HEADERS(cppunit/extensions/HelperMacros.h)
-+ SQUID_STATE_ROLLBACK(squid_cppunit_state)
-+ ],[
-+ AC_MSG_WARN([cppunit does not appear to be installed. Squid does not require this, but code testing with 'make check' will fail.])
-+ ])
-+])
-
- # Force some compilers to use ANSI features
- #
-
---- src/Common.am 2017-06-01 16:49:00.000000000 +0300
-+++ src/Common.am 2017-06-15 16:10:20.000000000 +0300
-@@ -26,7 +26,7 @@
- -I$(top_srcdir)/lib \
- -I$(top_srcdir)/src \
- -I$(top_builddir)/include \
-- $(SQUID_CPPUNIT_INC)
-+ $(LIBCPPUNIT_CFLAGS)
-
- ## Kerberos headers require their include path.
- ## Because we use libcompat for comm_err.h header protections ...
---- src/Makefile.am 2017-06-01 16:49:00.000000000 +0300
-+++ src/Makefile.am 2017-06-15 16:38:40.000000000 +0300
-@@ -1112,9 +1112,9 @@
- # $(TESTSOURCES)
- #tests_testX_LDFLAGS = $(LIBADD_DL)
- #tests_testX_LDADD=\
--# $(SQUID_CPPUNIT_LIBS) \
--# $(SQUID_CPPUNIT_LA) \
--# $(COMPAT_LIB) \
-+# $(LIBCPPUNIT_LIBS) \
-+# $(COMPAT_LIB) \
-+# $(XTRA_LIBS)
- #tests_testX_DEPENDENCIES= $(SQUID_CPPUNIT_LA)
-
-
-@@ -1221,8 +1221,7 @@
- $(top_builddir)/lib/libmisccontainers.la \
- $(top_builddir)/lib/libmiscencoding.la \
- $(top_builddir)/lib/libmiscutil.la \
-- $(SQUID_CPPUNIT_LIBS) \
-- $(SQUID_CPPUNIT_LA) \
-+ $(LIBCPPUNIT_LIBS) \
- $(NETTLELIB) \
- $(SSLLIB) \
- $(COMPAT_LIB) \
-@@ -1363,7 +1362,7 @@
- $(DISK_OS_LIBS) \
- $(NETTLELIB) \
- $(REGEXLIB) \
-- $(SQUID_CPPUNIT_LIBS) \
-+ $(LIBCPPUNIT_LIBS) \
- $(SSLLIB) \
- $(COMPAT_LIB) \
- $(XTRA_LIBS)
-@@ -1383,14 +1382,14 @@
- tests/stub_MemBuf.cc \
- $(TESTSOURCES)
- tests_testBoilerplate_LDADD= \
-- $(SQUID_CPPUNIT_LIBS) \
- $(SSLLIB) \
- base/libbase.la \
-+ $(LIBCPPUNIT_LIBS) \
- $(COMPAT_LIB) \
- $(XTRA_LIBS)
- tests_testBoilerplate_LDFLAGS = $(LIBADD_DL)
- tests_testBoilerplate_DEPENDENCIES = \
-- $(SQUID_CPPUNIT_LA)
-+ $(LIBCPPUNIT_LIBS)
-
- ## Tests of base/libbase.la objects
- tests_testCharacterSet_SOURCES = \
-@@ -1405,9 +1404,8 @@
- tests_testCharacterSet_LDFLAGS = $(LIBADD_DL)
- tests_testCharacterSet_LDADD= \
- base/libbase.la \
-+ $(LIBCPPUNIT_LIBS) \
- $(COMPAT_LIB) \
-- $(SQUID_CPPUNIT_LA) \
-- $(SQUID_CPPUNIT_LIBS) \
- $(XTRA_LIBS)
-
- ## Tests of the CacheManager module.
-@@ -1646,8 +1644,7 @@
- $(top_builddir)/lib/libmiscutil.la \
- $(NETTLELIB) \
- $(REGEXLIB) \
-- $(SQUID_CPPUNIT_LIBS) \
-- $(SQUID_CPPUNIT_LA) \
-+ $(LIBCPPUNIT_LIBS) \
- $(SSLLIB) \
- $(KRB5LIBS) \
- $(COMPAT_LIB) \
-@@ -1829,8 +1826,8 @@
- $(top_builddir)/lib/libmiscutil.la \
- $(NETTLELIB) \
- $(REGEXLIB) \
-- $(SQUID_CPPUNIT_LIBS) \
- $(SSLLIB) \
-+ $(LIBCPPUNIT_LIBS) \
- $(COMPAT_LIB) \
- $(XTRA_LIBS)
-
-@@ -2076,9 +2073,8 @@
- $(SNMP_LIBS) \
- $(NETTLELIB) \
- $(REGEXLIB) \
-- $(SQUID_CPPUNIT_LIBS) \
-- $(SQUID_CPPUNIT_LA) \
- $(SSLLIB) \
-+ $(LIBCPPUNIT_LIBS) \
- $(KRB5LIBS) \
- $(COMPAT_LIB) \
- $(XTRA_LIBS)
-@@ -2323,10 +2319,9 @@
- $(SNMP_LIBS) \
- $(NETTLELIB) \
- $(REGEXLIB) \
-- $(SQUID_CPPUNIT_LIBS) \
-- $(SQUID_CPPUNIT_LA) \
- $(SSLLIB) \
- $(KRB5LIBS) \
-+ $(LIBCPPUNIT_LIBS) \
- $(COMPAT_LIB) \
- $(XTRA_LIBS)
- tests_testEventLoop_LDFLAGS = $(LIBADD_DL)
-@@ -2564,10 +2559,9 @@
- $(top_builddir)/lib/libmiscutil.la \
- $(NETTLELIB) \
- $(REGEXLIB) \
-- $(SQUID_CPPUNIT_LIBS) \
-- $(SQUID_CPPUNIT_LA) \
- $(SSLLIB) \
- $(KRB5LIBS) \
-+ $(LIBCPPUNIT_LIBS) \
- $(COMPAT_LIB) \
- $(XTRA_LIBS)
- tests_test_http_range_LDFLAGS = $(LIBADD_DL)
-@@ -2613,7 +2607,7 @@
- base/libbase.la \
- ip/libip.la \
- $(top_builddir)/lib/libmiscutil.la \
-- $(SQUID_CPPUNIT_LIBS) \
-+ $(LIBCPPUNIT_LIBS) \
- $(COMPAT_LIB) \
- $(XTRA_LIBS)
- tests_testHttpParser_LDFLAGS = $(LIBADD_DL)
-@@ -2639,9 +2633,8 @@
- parser/libsquid-parser.la \
- base/libbase.la \
- $(top_builddir)/lib/libmiscutil.la \
-+ $(LIBCPPUNIT_LIBS) \
- $(COMPAT_LIB) \
-- $(SQUID_CPPUNIT_LA) \
-- $(SQUID_CPPUNIT_LIBS) \
- $(XTRA_LIBS)
-
- ## Tests of the HttpRequest module.
-@@ -2875,10 +2868,9 @@
- $(DISK_OS_LIBS) \
- $(NETTLELIB) \
- $(REGEXLIB) \
-- $(SQUID_CPPUNIT_LIBS) \
-- $(SQUID_CPPUNIT_LA) \
- $(SSLLIB) \
- $(KRB5LIBS) \
-+ $(LIBCPPUNIT_LIBS) \
- $(COMPAT_LIB) \
- $(XTRA_LIBS)
- tests_testHttpRequest_LDFLAGS = $(LIBADD_DL)
-@@ -2902,9 +2894,8 @@
- icmp/libicmp-core.la \
- ip/libip.la \
- base/libbase.la \
-+ $(LIBCPPUNIT_LIBS) \
- $(COMPAT_LIB) \
-- $(SQUID_CPPUNIT_LA) \
-- $(SQUID_CPPUNIT_LIBS) \
- $(XTRA_LIBS)
-
- ## Tests for ip/* objects
-@@ -2918,9 +2909,8 @@
- tests_testIpAddress_LDADD= \
- ip/libip.la \
- base/libbase.la \
-+ $(LIBCPPUNIT_LIBS) \
- $(COMPAT_LIB) \
-- $(SQUID_CPPUNIT_LA) \
-- $(SQUID_CPPUNIT_LIBS) \
- $(XTRA_LIBS)
- tests_testIpAddress_LDFLAGS= $(LIBADD_DL)
-
-@@ -3087,10 +3077,10 @@
- $(top_builddir)/lib/libmiscutil.la \
- $(NETTLELIB) \
- $(REGEXLIB) \
-- $(SQUID_CPPUNIT_LIBS) \
- $(SSLLIB) \
- CommCalls.o \
- DnsLookupDetails.o \
-+ $(LIBCPPUNIT_LIBS) \
- $(COMPAT_LIB) \
- $(XTRA_LIBS)
- tests_testStore_LDFLAGS = $(LIBADD_DL)
-@@ -3130,8 +3120,8 @@
- ip/libip.la \
- $(top_builddir)/lib/libmiscutil.la \
- $(REGEXLIB) \
-- $(SQUID_CPPUNIT_LIBS) \
- $(SSLLIB) \
-+ $(LIBCPPUNIT_LIBS) \
- $(COMPAT_LIB) \
- $(XTRA_LIBS)
- tests_testString_LDFLAGS = $(LIBADD_DL)
-@@ -3326,8 +3316,8 @@
- $(top_builddir)/lib/libmiscutil.la \
- $(NETTLELIB) \
- $(REGEXLIB) \
-- $(SQUID_CPPUNIT_LIBS) \
- $(SSLLIB) \
-+ $(LIBCPPUNIT_LIBS) \
- $(COMPAT_LIB) \
- $(XTRA_LIBS)
- tests_testUfs_LDFLAGS = $(LIBADD_DL)
-@@ -3506,8 +3496,8 @@
- $(top_builddir)/lib/libmiscutil.la \
- $(NETTLELIB) \
- $(REGEXLIB) \
-- $(SQUID_CPPUNIT_LIBS) \
- $(SSLLIB) \
-+ $(LIBCPPUNIT_LIBS) \
- $(COMPAT_LIB) \
- $(XTRA_LIBS)
- tests_testRock_LDFLAGS = $(AM_CPPFLAGS) $(LIBADD_DL)
-@@ -3751,10 +3741,9 @@
- $(top_builddir)/lib/libmiscutil.la \
- $(NETTLELIB) \
- $(COMPAT_LIB) \
-- $(SQUID_CPPUNIT_LIBS) \
-- $(SQUID_CPPUNIT_LA) \
- $(SSLLIB) \
- $(KRB5LIBS) \
-+ $(LIBCPPUNIT_LIBS) \
- $(COMPAT_LIB) \
- $(XTRA_LIBS)
- tests_testURL_LDFLAGS = $(LIBADD_DL)
-@@ -3794,7 +3783,7 @@
- mgr/libmgr.la \
- $(top_builddir)/lib/libmiscutil.la \
- $(REGEXLIB) \
-- $(SQUID_CPPUNIT_LIBS) \
-+ $(LIBCPPUNIT_LIBS) \
- $(COMPAT_LIB) \
- $(XTRA_LIBS)
- tests_testSBuf_DEPENDENCIES= $(SQUID_CPPUNIT_LA)
-@@ -3838,7 +3827,7 @@
- ip/libip.la \
- mgr/libmgr.la \
- $(top_builddir)/lib/libmiscutil.la \
-- $(SQUID_CPPUNIT_LIBS) \
-+ $(LIBCPPUNIT_LIBS) \
- $(COMPAT_LIB) \
- $(XTRA_LIBS)
- tests_testSBufList_DEPENDENCIES= $(SQUID_CPPUNIT_LA)
-@@ -3876,8 +3865,8 @@
- ip/libip.la \
- $(top_builddir)/lib/libmiscutil.la \
- $(REGEXLIB) \
-- $(SQUID_CPPUNIT_LIBS) \
- $(SSLLIB) \
-+ $(LIBCPPUNIT_LIBS) \
- $(COMPAT_LIB) \
- $(XTRA_LIBS)
- tests_testConfigParser_LDFLAGS = $(LIBADD_DL)
-@@ -3922,9 +3911,9 @@
- base/libbase.la \
- $(top_builddir)/lib/libmiscutil.la \
- $(top_builddir)/lib/libmisccontainers.la \
-- $(SQUID_CPPUNIT_LIBS) \
-- $(SQUID_CPPUNIT_LA) \
-- $(COMPAT_LIB)
-+ $(LIBCPPUNIT_LIBS) \
-+ $(COMPAT_LIB) \
-+ $(XTRA_LIBS)
- tests_testStatHist_DEPENDENCIES = $(SQUID_CPPUNIT_LA)
-
- TESTS += testHeaders
---- lib/Makefile.am 2017-06-01 16:49:00.000000000 +0300
-+++ lib/Makefile.am 2017-06-16 07:19:54.000000000 +0300
-@@ -91,7 +91,7 @@
- tests/testRFC1035.cc
-
- tests_testRFC1035_LDADD= \
-- $(SQUID_CPPUNIT_LA) $(SQUID_CPPUNIT_LIBS) \
-+ $(LIBCPPUNIT_LIBS) \
- $(top_builddir)/lib/libmiscencoding.la \
- $(top_builddir)/lib/libmiscutil.la \
- $(COMPAT_LIB)
-@@ -103,7 +103,7 @@
- tests/testRFC1738.cc
-
- tests_testRFC1738_LDADD= \
-- $(SQUID_CPPUNIT_LA) $(SQUID_CPPUNIT_LIBS) \
-+ $(LIBCPPUNIT_LIBS) \
- $(top_builddir)/lib/libmiscencoding.la \
- $(top_builddir)/lib/libmiscutil.la \
- $(COMPAT_LIB)