summaryrefslogtreecommitdiff
path: root/net-print
diff options
context:
space:
mode:
Diffstat (limited to 'net-print')
-rw-r--r--net-print/Manifest.gzbin6747 -> 6914 bytes
-rw-r--r--net-print/cnijfilter2/Manifest4
-rw-r--r--net-print/cnijfilter2/cnijfilter2-5.20.ebuild61
-rw-r--r--net-print/cnijfilter2/files/cnijfilter2-5.20-gentoo.patch50
-rw-r--r--net-print/cnijfilter2/metadata.xml11
-rw-r--r--net-print/cups-filters/Manifest2
-rw-r--r--net-print/cups-filters/cups-filters-1.17.9.ebuild2
-rw-r--r--net-print/foomatic-db-ppds/Manifest10
-rw-r--r--net-print/foomatic-db-ppds/foomatic-db-ppds-4.0.20140105.ebuild29
-rw-r--r--net-print/foomatic-db-ppds/foomatic-db-ppds-4.0.20161101.ebuild29
-rw-r--r--net-print/foomatic-db-ppds/foomatic-db-ppds-4.0.20170331.ebuild4
-rw-r--r--net-print/foomatic-db-ppds/foomatic-db-ppds-4.0.20180126.ebuild (renamed from net-print/foomatic-db-ppds/foomatic-db-ppds-4.0.20160504.ebuild)9
-rw-r--r--net-print/foomatic-db/Manifest8
-rw-r--r--net-print/foomatic-db/foomatic-db-4.0.20140105.ebuild41
-rw-r--r--net-print/foomatic-db/foomatic-db-4.0.20161101.ebuild40
-rw-r--r--net-print/foomatic-db/foomatic-db-4.0.20180126.ebuild (renamed from net-print/foomatic-db/foomatic-db-4.0.20160504.ebuild)5
16 files changed, 143 insertions, 162 deletions
diff --git a/net-print/Manifest.gz b/net-print/Manifest.gz
index d022bb4d7685..2ef6821003e8 100644
--- a/net-print/Manifest.gz
+++ b/net-print/Manifest.gz
Binary files differ
diff --git a/net-print/cnijfilter2/Manifest b/net-print/cnijfilter2/Manifest
new file mode 100644
index 000000000000..eea873b2e45e
--- /dev/null
+++ b/net-print/cnijfilter2/Manifest
@@ -0,0 +1,4 @@
+AUX cnijfilter2-5.20-gentoo.patch 1775 BLAKE2B db93bfa9d09c2478ea7e6fa79cd38ef21b4743330853b31d22e2f9ba6923045a8b40170efdcfd72ea91384046d3b96c7ab74bf9699ef48e01644a336b0603fc5 SHA512 d79e611dacb2362ead277a593fe1082fce960c67f24af830e5b093ac4bcb641f9db6de84afa9be9b5495967a6826ddd5313fd76da507372945c5162e98736826
+DIST cnijfilter2-source-5.20-1.tar.gz 466507 BLAKE2B 1ca96153350a157f56dfed691a04dcbe1e3ab5462b59c0cd919316a7c54a36bbeb34cf4205132f0aa3e5a23f89eb260c35c1a3ee14ea85bc36b9e3b67cd7e3f7 SHA512 60be49d34adf9a4d2cd8337cccb36eb8c078e9712bf8043c3552f1d83c3da307badfe34fc3683c99e3234da30f4ba82e0c4a0b48ea5f78f0d66db1408bd7d495
+EBUILD cnijfilter2-5.20.ebuild 1403 BLAKE2B 1daedead655b9573ea422a8374bf04449baed0d9f845fb64852f0a3515694d6a24cb799f83d98074553808b6e3cadeb273a4b54c1a743d079658c5f093f1cadf SHA512 e316d08d3e04b5bdc2b3281c4e2d983b8bb4d4a46b7b32b088fa65c370f613ec3a4a6d48252f620125974212b4c235d42316ef73c7748fed940ab44442d09027
+MISC metadata.xml 339 BLAKE2B aa954d512a8d86489f00bcaf9f59d4427e95e095b42ef7946456db0c9037fcda08a9940e22df160871fcf1d19d8c06852b707934a904fa680ed06726fcd5c735 SHA512 a8976b24c12b154f9cdcd8a6f31d10f35a039a51141eda7aaea0fa6e9f7f9d405745f4910c6f56d44fac6ecde6bd927dc8a1e10f995279816f1bc551667dedd5
diff --git a/net-print/cnijfilter2/cnijfilter2-5.20.ebuild b/net-print/cnijfilter2/cnijfilter2-5.20.ebuild
new file mode 100644
index 000000000000..a5ceae2028a2
--- /dev/null
+++ b/net-print/cnijfilter2/cnijfilter2-5.20.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+MY_P="${PN}-source-${PV}-1"
+
+DESCRIPTION="IJ Printer Driver"
+HOMEPAGE="https://www.canon.it/"
+SRC_URI="http://gdlp01.c-wss.com/gds/0/0100006900/01/${MY_P}.tar.gz"
+
+LICENSE="Canon-IJ"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="virtual/libusb:1
+ dev-libs/libxml2
+ net-print/cups"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+src_prepare() {
+ default
+ DIRS="cmdtocanonij2 cnijbe2 lgmon3 rastertocanonij tocanonij tocnpwg"
+ LIBDIR=com/libs_bin$(usex amd64 64 32)
+ for d in ${DIRS}; do
+ mv "${d}"/configure.{in,ac} || die
+ done
+ echo "AC_INIT([${PN}], [${PV}])" >> configure.ac
+ echo "AM_INIT_AUTOMAKE" >> configure.ac
+ echo "AC_CONFIG_SUBDIRS([${DIRS}])" >> configure.ac
+ echo "AC_CONFIG_FILES([Makefile])" >> configure.ac
+ echo "AC_OUTPUT()" >> configure.ac
+ echo "SUBDIRS= ${DIRS}" >> Makefile.am
+ sed -i \
+ -e "/^CFLAGS/d" \
+ */configure.ac || die
+ eautoreconf
+ cd ${LIBDIR}
+ rm libcn*2.so || die
+ ln -sf libcnbpcnclapicom2.so.5.0.0 libcnbpcnclapicom2.so || die
+ ln -sf libcnnet2.so.1.2.3 libcnnet2.so || die
+ cd -
+}
+
+src_configure() {
+ LDFLAGS="-L"${S}"/${LIBDIR}" econf --enable-progpath="${EPREFIX}/usr/bin"
+}
+
+src_install() {
+ default
+ insinto /usr/share/ppd/cupsfilters
+ doins ppd/*ppd
+ dolib.so ${LIBDIR}/*
+}
diff --git a/net-print/cnijfilter2/files/cnijfilter2-5.20-gentoo.patch b/net-print/cnijfilter2/files/cnijfilter2-5.20-gentoo.patch
new file mode 100644
index 000000000000..80c7361cb1a1
--- /dev/null
+++ b/net-print/cnijfilter2/files/cnijfilter2-5.20-gentoo.patch
@@ -0,0 +1,50 @@
+--- cnijfilter2-source-5.20-1/cmdtocanonij2/filter/Makefile.am.old 2018-01-14 18:14:20.645473030 +0100
++++ cnijfilter2-source-5.20-1/cmdtocanonij2/filter/Makefile.am 2018-01-14 18:14:36.078219959 +0100
+@@ -1,4 +1,4 @@
+-filterdir=$(libdir)/cups/filter
++filterdir=$(libexecdir)/cups/filter
+
+ filter_PROGRAMS= cmdtocanonij2
+
+--- cnijfilter2-source-5.20-1/cnijbe2/src/Makefile.am.old 2018-01-14 19:25:48.823470121 +0100
++++ cnijfilter2-source-5.20-1/cnijbe2/src/Makefile.am 2018-01-14 19:25:59.316275741 +0100
+@@ -1,6 +1,6 @@
+ ## Process this file with automake to produce Makefile.in
+
+-backend_bindir = /usr/lib/cups/backend
++backend_bindir = $(libexecdir)/cups/backend
+ backend_bin_PROGRAMS = cnijbe2
+ transform =
+
+--- cnijfilter2-source-5.20-1/rastertocanonij/src/Makefile.am.old 2018-01-14 21:31:33.053307218 +0100
++++ cnijfilter2-source-5.20-1/rastertocanonij/src/Makefile.am 2018-01-14 21:31:41.106166479 +0100
+@@ -1,4 +1,4 @@
+-filterdir=$(libdir)/cups/filter
++filterdir=$(libexecdir)/cups/filter
+
+ filter_PROGRAMS= rastertocanonij
+
+--- cnijfilter2-source-5.20-1/tocanonij/src/Makefile.am.old 2018-01-15 22:38:14.236460663 +0100
++++ cnijfilter2-source-5.20-1/tocanonij/src/Makefile.am 2018-01-15 22:38:39.184018933 +0100
+@@ -1,7 +1,8 @@
+ INCLUDES = \
+ -I$(top_srcdir)/include/cncl
+
+-bin_PROGRAMS= tocanonij
++filterdir=$(libexecdir)/cups/filter
++filter_PROGRAMS= tocanonij
+
+ tocanonij_SOURCES= \
+ main.c
+--- cnijfilter2-source-5.20-1/tocnpwg/src/Makefile.am.old 2018-01-15 22:42:43.759703863 +0100
++++ cnijfilter2-source-5.20-1/tocnpwg/src/Makefile.am 2018-01-15 22:43:10.442232986 +0100
+@@ -2,7 +2,8 @@
+ INCLUDES = \
+ @XML_2_CFLAGS@
+
+-bin_PROGRAMS= tocnpwg
++filterdir=$(libexecdir)/cups/filter
++filter_PROGRAMS= tocnpwg
+
+ tocnpwg_SOURCES= \
+ main.c mkpset.c
diff --git a/net-print/cnijfilter2/metadata.xml b/net-print/cnijfilter2/metadata.xml
new file mode 100644
index 000000000000..869d1f155629
--- /dev/null
+++ b/net-print/cnijfilter2/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tupone@gentoo.org</email>
+ <name>Tupone Alfredo</name>
+ </maintainer>
+ <longdescription lang="en">
+ Printer Support for Canon PIXMA Printers
+ </longdescription>
+</pkgmetadata>
diff --git a/net-print/cups-filters/Manifest b/net-print/cups-filters/Manifest
index 1b9ec3e2649b..609f0b5df98c 100644
--- a/net-print/cups-filters/Manifest
+++ b/net-print/cups-filters/Manifest
@@ -4,7 +4,7 @@ DIST cups-filters-1.17.9.tar.xz 1454068 BLAKE2B 7c4b1c1a017cbaaf5d413071195ce53e
DIST cups-filters-1.18.0.tar.xz 1457748 BLAKE2B 6db45707d3c0bdd369407023423a02f8909936daeccdecf1be6007d782888352c15c5590f845e074ca8da271ce1d7262c8b98a0ec8df6e383622654c06730d29 SHA512 260f4d4c635b4ca0222a9a90a6675d7ecb1cf8b4f4428431c263f50f9152537331d2c7d77c4fa0f899a12beecd6500f6ca146f4e2d087cc6525919aa0b922647
DIST cups-filters-1.19.0.tar.xz 1465524 BLAKE2B 044ab5906f73a9405de55df953c76f7efd09ac4f7800df538c8c3cfd1651de6ed4ea6e3de9378221fef69d983f070b6dcab68dfd2b822fe59aa7f804a8c27907 SHA512 4b580734f7bac78c9d48aad7d8bb9e47227134e594fba76b1c82632fd8dd3e885f3897f7efd1a4b56647b74741f452f4e36d0157591c7fd5d626001028903d30
EBUILD cups-filters-1.16.4.ebuild 3432 BLAKE2B 9733302bc404c6454ba652bd523f2a41ba0070eb605c8b4150056ed5ddbd6093bdd72871889fa030093c7426721e45580ef75671080655eb6ec2c89dcff2bf25 SHA512 4a69c596427cbca25b3549aeb2fa91733065f1fd7a30d236234633a9955998147614d53b2e7e8044c034f297b292a67d83ebdba603079223f4f8352b4d4c3049
-EBUILD cups-filters-1.17.9.ebuild 3503 BLAKE2B 5ca468480e4552cae9f8f6253dd3d5980d1b018c9e1e4400b2694e0cf309cded49b863b8ce5989379002fe6e6625a19b87adc49a2d7d4389a34dc41f6d619f11 SHA512 249fd3b993a27f76a175ccbdabe6c3269fb954c43521d95c695facec3b441205fb1b6c0d93e255fa4f5fe8909c23c03a96c8e480746b3e795463465d1cf6513e
+EBUILD cups-filters-1.17.9.ebuild 3501 BLAKE2B c15b3c960a4a03d09ef337fb24b87633878d492ec11d13c5dd700da6a8b35a8b159406527f61cff230e06f1c79f8675eed154ae3d172ac010e13eb1e17090e3d SHA512 a6b0c900758decf93932e75a557258cf7c03daeecf0198177a04a733946b1a3ab4a188890f2db5a138c9369f285ae5833923f2ee54710d659db77054ee816861
EBUILD cups-filters-1.18.0.ebuild 3504 BLAKE2B 5d8c026d3040863a9bbfe54dd4bcbd36ba20ff341dcc9348f21af574aa64162ee46536f9c868df3b0bf51caf55ee4ddf20e178741ab00bc1a24b5278fa26bfe0 SHA512 4eeff094b85dc861d817a58211fed3b812b9e8b7d73c2ffb2dd2245cfa53e325c0f8d7844b20580331f1d72c24f7d2e5bc2bb44e4385a83f7e2b466e30268a02
EBUILD cups-filters-1.19.0.ebuild 3504 BLAKE2B ceb5f203394fcb688acb1e80e520b14bcbe5a664f20725841d4fce9b70b31ea95746f737fbd3181979fe214836fd4c16c9bb9434999b1b8542ac750f806d20a4 SHA512 cbc2fed9c50d9773530fe806ed177220cd6daaabc1f1bfe0c360c75bc33a899a3c8893694798e5cac0413d84a67e3163c40f19852738b21b7d13bb2c770f589a
EBUILD cups-filters-9999.ebuild 3504 BLAKE2B 5d8c026d3040863a9bbfe54dd4bcbd36ba20ff341dcc9348f21af574aa64162ee46536f9c868df3b0bf51caf55ee4ddf20e178741ab00bc1a24b5278fa26bfe0 SHA512 4eeff094b85dc861d817a58211fed3b812b9e8b7d73c2ffb2dd2245cfa53e325c0f8d7844b20580331f1d72c24f7d2e5bc2bb44e4385a83f7e2b466e30268a02
diff --git a/net-print/cups-filters/cups-filters-1.17.9.ebuild b/net-print/cups-filters/cups-filters-1.17.9.ebuild
index a839fdb4414f..947b950d103d 100644
--- a/net-print/cups-filters/cups-filters-1.17.9.ebuild
+++ b/net-print/cups-filters/cups-filters-1.17.9.ebuild
@@ -12,7 +12,7 @@ if [[ "${PV}" == "9999" ]] ; then
EBZR_REPO_URI="http://bzr.linuxfoundation.org/openprinting/cups-filters"
else
SRC_URI="http://www.openprinting.org/download/${PN}/${P}.tar.xz"
- KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~m68k-mint"
+ KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 sparc x86 ~amd64-fbsd ~m68k-mint"
fi
DESCRIPTION="Cups filters"
HOMEPAGE="https://wiki.linuxfoundation.org/openprinting/cups-filters"
diff --git a/net-print/foomatic-db-ppds/Manifest b/net-print/foomatic-db-ppds/Manifest
index dda979bc02b6..1d81debd2f4f 100644
--- a/net-print/foomatic-db-ppds/Manifest
+++ b/net-print/foomatic-db-ppds/Manifest
@@ -1,10 +1,6 @@
AUX Makefile.in-4.0.20120117.patch 1161 BLAKE2B f935f674597d1edc4d70b2fc600e5a04dd55acbae7fa648089ded8f10f3d61390c62e24ba5d491b3a4ac2fb7c9636db3c4895842da798c5a870972d334b71b31 SHA512 75ab0f16ce0c187553fc7bdcdc9a23ae8fecd50942d3ba0282ec2d4001f141904e6f93c8a9b6496ab2b0205a31d46a082ea304e8dcbc25f5e38c86ff696d7935
-DIST foomatic-db-4.0-20140105.tar.gz 38845034 BLAKE2B d61f6f2eb6eeb913d8875c16538b2c0dce2b2962ba85c4856471cd84b0866d1450b1d3fec863faa22ae0766848562f81d4ab543192bcc6c2a5f8bdc3435ec18c SHA512 4d06d63fe79bcfb912875b8209d658e018f4486821e7bf9433cb181d68df58602a58e755202d8ce53e0a9b9d8b0f1b31a7847c4d1346164e88105b06a4003ee4
-DIST foomatic-db-4.0-20160504.tar.gz 45782654 BLAKE2B b03374cc60564963578c88c3c25324ad0b1a5eb0812fe3eeed673d236c9ccb9938dc6d30bd00c023e99ccbed1ae02823a155477938c16e638410d7b9420bb5c2 SHA512 816a857b9529c8f71ba524c261812b83e30c660bd6f99a150e45950d212a54c62a8aad9ea9f7485f270972d42f5f333bcee8da55eb5c837b542187f25322f47f
-DIST foomatic-db-4.0-20161101.tar.gz 48879184 BLAKE2B 96c0e32e9a31d86fd55cbbea5b08e874faabd961ebee4ff15c4967ba4ac89272fa5d71e1080bacc7bc28c2bd7404b0a6db944f0aa3b51dc9426ce18c439b13ed SHA512 64bd45889b74ea376d432696541b7d7c03978ea126e9e08302761208b8e7d54399cdd7e218101ebccebc97d2f800cbe9f63c844bb3d943d4662ea2463c21653d
DIST foomatic-db-4.0-20170331.tar.gz 53321292 BLAKE2B 375421205b80cc84d10629454cad053ea0022c8e230c0eab0797f3de79d42e6cc3769ad286095aa7a5bdde0f49d30fb3484e8cbefbae48a32840c0ca96885276 SHA512 33037b087eccfe08fb5b2c0220992f4ad4762c7206325f6bc8073903aafa27a260382cfa8edb4500f0feeea4d0489a3a345fe3017790484fdfb53aa577f691c0
-EBUILD foomatic-db-ppds-4.0.20140105.ebuild 869 BLAKE2B 8d96d2349824b149d31f89f350134f5829f0f8c25e9b2597b326c204fbef501f1fb3d6fc8e912bb67811a38c18f692a684a119b25b44bf77929130068377adce SHA512 ca5b9be9064a8b88f899866c6af881b9d0b64ed683b7f1c1bfc8982f362724231bebd3bcf795017d67b2a31f7cfc72493a75afe9b5f750f9be0a14e342852159
-EBUILD foomatic-db-ppds-4.0.20160504.ebuild 866 BLAKE2B 8be6489b9a3d55b242068ee174670d07afde24e2830bb8781635c175d508c7bcb236563fd47cb35aaa08b5b33ba3efa7e050e3d1167161ba6027651eb9da2327 SHA512 c598058bc3878a2cda44d6fd4f195d3b28ec16638f561587dd505925701b5790003d43cb770a82f2259d4b6714f96a334edc202b7fd15d1277bf6fe6925c114e
-EBUILD foomatic-db-ppds-4.0.20161101.ebuild 866 BLAKE2B 8be6489b9a3d55b242068ee174670d07afde24e2830bb8781635c175d508c7bcb236563fd47cb35aaa08b5b33ba3efa7e050e3d1167161ba6027651eb9da2327 SHA512 c598058bc3878a2cda44d6fd4f195d3b28ec16638f561587dd505925701b5790003d43cb770a82f2259d4b6714f96a334edc202b7fd15d1277bf6fe6925c114e
-EBUILD foomatic-db-ppds-4.0.20170331.ebuild 857 BLAKE2B 51e02fbea71948d2221ae7f5f6a4b0636499fc70eff53270531660c4479cae4cd4c63978c45ecc692f5f2b5bb95759ad43532af6c79d67ed082a035f59c2dfc1 SHA512 10ed93c630c9e241bd0083ea6815a2c980ce0535d865a5ef7ac9e8afae2d140ad2d1beaf47783a9d98bc429557ecc2fcdc77d947c6beb9930db87b546faaa2cc
+DIST foomatic-db-4.0-20180126.tar.gz 58697641 BLAKE2B ae063e5d82e70dcd4b7791d0ffc3914c6a7d218c9e1067f6fe99f029c7f4340399e7034da26119e4219096758d029c832797dc10e8076f49f0e24ca11188785c SHA512 84e9c70e797a5328317d0b2725ebb67aa630923516fd8f860740af58ee5337b6302669c822b6aba32fb10ad9670c5894b34356e3cfc0e1496bd051551f40026d
+EBUILD foomatic-db-ppds-4.0.20170331.ebuild 845 BLAKE2B 1e05baaa71842a77e33e2c1514dfcefb3a5f73722d52f2d2897dee75a721a6223ac2b75d9b631f10cf2255ef61e8cdc0542e4e4a5bd4429878d37e1d9e88fa93 SHA512 6d0491122d2de885047a92588ba11b6edc6abe95f265f6b62da655ce73bc22eae07b2e5ebc6e37b7cd2be5dc8df475336f51029100ff0124cfebda9529d2266d
+EBUILD foomatic-db-ppds-4.0.20180126.ebuild 863 BLAKE2B 704b3a2f8801d7ce86775323d3d5b93d590664dbba5a55b0b3e802c2f77fafd7d74a47ff5f8a3d03e16aa99a8f59ed4de59333373a0d92b32fa5406ec5b71dae SHA512 91759d2e20b22d17349519cb3ccba8fb140cf289e97da511b756e4c0aa4639a02fe8318a161724a57b1fdb43c7bb9244440623ff047078bd72f47bac5a21851f
MISC metadata.xml 259 BLAKE2B 4a7248bc5a529d1cf3b51f8bcfff668a9e525df3e62584369d4b5526c89e70235378420b164073946ea91cf182065d9c8d2d46c8750d5f77855239b77ce45bae SHA512 7b1cbb90c1ddcf63b8802cfa3a53611f6367801b492c7677ef038738a337002c4606bcf93c5186abf808e74bca1fa76266169245acdb3b5997651bcabfecfa5c
diff --git a/net-print/foomatic-db-ppds/foomatic-db-ppds-4.0.20140105.ebuild b/net-print/foomatic-db-ppds/foomatic-db-ppds-4.0.20140105.ebuild
deleted file mode 100644
index e3b9373bfdcf..000000000000
--- a/net-print/foomatic-db-ppds/foomatic-db-ppds-4.0.20140105.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils versionator
-
-MY_P=${PN/-ppds}-$(replace_version_separator 2 '-')
-
-DESCRIPTION="linuxprinting.org PPD files for postscript printers"
-HOMEPAGE="http://www.linuxprinting.org/foomatic.html"
-#SRC_URI="http://linuxprinting.org/download/foomatic/${MY_P}.tar.gz"
-SRC_URI="https://dev.gentoo.org/~dilfridge/distfiles/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE=""
-
-S="${WORKDIR}/${PN/-ppds}-$(get_version_component_range 3 ${PV})"
-
-src_prepare() {
- epatch "${FILESDIR}/Makefile.in-4.0.20120117.patch"
-}
-
-src_install() {
- default
- rm -v "${ED}"/usr/share/foomatic/xmlschema/{driver,option,printer,types}.xsd || die "Cannot remove duplicates"
-}
diff --git a/net-print/foomatic-db-ppds/foomatic-db-ppds-4.0.20161101.ebuild b/net-print/foomatic-db-ppds/foomatic-db-ppds-4.0.20161101.ebuild
deleted file mode 100644
index 99af50ea5954..000000000000
--- a/net-print/foomatic-db-ppds/foomatic-db-ppds-4.0.20161101.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils versionator
-
-MY_P=${PN/-ppds}-$(replace_version_separator 2 '-')
-
-DESCRIPTION="linuxprinting.org PPD files for postscript printers"
-HOMEPAGE="http://www.linuxprinting.org/foomatic.html"
-SRC_URI="http://linuxprinting.org/download/foomatic/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE=""
-
-S="${WORKDIR}/${PN/-ppds}-$(get_version_component_range 3 ${PV})"
-
-src_prepare() {
- epatch "${FILESDIR}/Makefile.in-4.0.20120117.patch"
- rm db/source/PPD/Kyocera/ReadMe.htm || die # bug #559008
-}
-
-src_install() {
- default
- rm -v "${ED}"/usr/share/foomatic/xmlschema/{driver,option,printer,types}.xsd || die "Cannot remove duplicates"
-}
diff --git a/net-print/foomatic-db-ppds/foomatic-db-ppds-4.0.20170331.ebuild b/net-print/foomatic-db-ppds/foomatic-db-ppds-4.0.20170331.ebuild
index 7cea5da00dae..077cc3318f07 100644
--- a/net-print/foomatic-db-ppds/foomatic-db-ppds-4.0.20170331.ebuild
+++ b/net-print/foomatic-db-ppds/foomatic-db-ppds-4.0.20170331.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -13,7 +13,7 @@ SRC_URI="http://linuxprinting.org/download/foomatic/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~sparc-fbsd ~x86-fbsd"
+KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd"
IUSE=""
S="${WORKDIR}/${PN/-ppds}-$(get_version_component_range 3 ${PV})"
diff --git a/net-print/foomatic-db-ppds/foomatic-db-ppds-4.0.20160504.ebuild b/net-print/foomatic-db-ppds/foomatic-db-ppds-4.0.20180126.ebuild
index 99af50ea5954..4acc8fdfb809 100644
--- a/net-print/foomatic-db-ppds/foomatic-db-ppds-4.0.20160504.ebuild
+++ b/net-print/foomatic-db-ppds/foomatic-db-ppds-4.0.20180126.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
inherit eutils versionator
@@ -13,14 +13,15 @@ SRC_URI="http://linuxprinting.org/download/foomatic/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
IUSE=""
S="${WORKDIR}/${PN/-ppds}-$(get_version_component_range 3 ${PV})"
src_prepare() {
- epatch "${FILESDIR}/Makefile.in-4.0.20120117.patch"
+ eapply "${FILESDIR}/Makefile.in-4.0.20120117.patch"
rm db/source/PPD/Kyocera/ReadMe.htm || die # bug #559008
+ default
}
src_install() {
diff --git a/net-print/foomatic-db/Manifest b/net-print/foomatic-db/Manifest
index 789ecc416005..c5f763fba04b 100644
--- a/net-print/foomatic-db/Manifest
+++ b/net-print/foomatic-db/Manifest
@@ -1,9 +1,5 @@
-DIST foomatic-db-4.0-20140105.tar.gz 38845034 BLAKE2B d61f6f2eb6eeb913d8875c16538b2c0dce2b2962ba85c4856471cd84b0866d1450b1d3fec863faa22ae0766848562f81d4ab543192bcc6c2a5f8bdc3435ec18c SHA512 4d06d63fe79bcfb912875b8209d658e018f4486821e7bf9433cb181d68df58602a58e755202d8ce53e0a9b9d8b0f1b31a7847c4d1346164e88105b06a4003ee4
-DIST foomatic-db-4.0-20160504.tar.xz 4074612 BLAKE2B aa7bbbc3798edbed0ed0ad84fb83566ebdda1c883eaa19b1d1b7c8db536c11e0899671953355bb56d10899003ca7abdb779ee7e5198432094efb94b32dc9944b SHA512 ade62d14773fc5c4c82ac5ebf791ab0e70b36d758493468307acde21730a146bdb198cfe7bc14041aa05ed5b29961ca2dde4ad29d3e555164020046a4f89e5eb
-DIST foomatic-db-4.0-20161101.tar.xz 4474300 BLAKE2B 2919f33d379777c61d5eebc8b5349bd44ec18ca4cd8698643d2172ed6513be707045eca1e3cdbe8855f30c94bfa2d6e75e649fbe0204ac411f0cbaf53279181c SHA512 8370632697846e1635d00c369125eebc83fd0363896ed3b29d684c8e6cacc4d8cc8c679e889f20e83458f07b254dcfab22b1faef2dcf3063fbe9d3f457ead623
DIST foomatic-db-4.0-20170331.tar.xz 5083832 BLAKE2B 3c22869cc50f9e68e04bc9edaf6227764ede1566bf93311f1098d0022174911697a63685488be2c753205e40284ec22c31a64e672fee3851eeec920730b5a344 SHA512 f265a476533a77c27f0eb6414a3b93c6b269effba7bb0d46c9d3965c0e7218c3b081ae5e3f01ebfe7afbec70379543dd2e553b97b338eca43c34c11a4ffb4dcc
-EBUILD foomatic-db-4.0.20140105.ebuild 1308 BLAKE2B 1c3e97532e60ccb48bd294a50bf51ee7b0181a14def76b899c715330dafe06ca52fa19f5719bbd5dbb347c68b88322f30e846cb66fbad86adb530f3fdb9103fd SHA512 fedbc2040876bf5e25b81a492b16c9361a287725262d2d5b9506405934a83662c0e2b87f90aa76a1e2eebb9dcbc16b798388ba51b02fba26c7d717440d27a328
-EBUILD foomatic-db-4.0.20160504.ebuild 1216 BLAKE2B c39a85d657c4abf7d86ae4dd4f06f74229e998efee1657ccf9808d330be5ae50745684e0f606b928775e4a4ee6a2c7ab9153b6d9201b7bbce0e8d53421d8e925 SHA512 08e880232898c05ac71884fff0e1e367a41974d13bc3e0ade29c89d71378de497273ed322fbf7fbfe9add425a46cc4e91e38279424a7134aa26621759fc14bf1
-EBUILD foomatic-db-4.0.20161101.ebuild 1216 BLAKE2B c39a85d657c4abf7d86ae4dd4f06f74229e998efee1657ccf9808d330be5ae50745684e0f606b928775e4a4ee6a2c7ab9153b6d9201b7bbce0e8d53421d8e925 SHA512 08e880232898c05ac71884fff0e1e367a41974d13bc3e0ade29c89d71378de497273ed322fbf7fbfe9add425a46cc4e91e38279424a7134aa26621759fc14bf1
+DIST foomatic-db-4.0-20180126.tar.xz 5418608 BLAKE2B e11dbfc7e4cf121ba8b456820438b0418981c414c6a798dee463430dd8ccf65b424e1d597bc21b32929e858d0282b12df81fb419793bd34172b0c414619d2762 SHA512 1879e2601ad88262c99201bff5353ac40516985de72dd894eeeae2589ae2b82dd4dbfc972cb3ff43f209efb92753d4ed0ce584d89cd242fedc011511c45d8a87
EBUILD foomatic-db-4.0.20170331.ebuild 1207 BLAKE2B 2aed57c70dd5ccdac9ed27f5af6bfd754ed950da1a075ea57c85651e870440b3538bb049c358c227f01f63857ee4feb29260a9f94451a031b15ce1e101cee4ea SHA512 5fe1da45af096d8419faa461369067e5b45bfecc311e788b05ee506e92cd88324e58cff9a619706ea69c5fdfe6837cdab1cc346eca74e4766a70346404d9d7b3
+EBUILD foomatic-db-4.0.20180126.ebuild 1225 BLAKE2B 39fec6d0fed1bbaf3f75d5015bc727589e8a60cd3f2b3d146cee1bb820ab0511cee115cf299929cfcf908ca99421fa5bd5fd3f9bee8d2bd7fefd0114dd60b6ae SHA512 7d20d8cbef85150a5ca7847467ddee3dbcd355af02c75991709f82e498c7d27703c0f24057e2df70fdc26195e7e5982c99221fbd4b415d22d63ca8ca657d5481
MISC metadata.xml 259 BLAKE2B 4a7248bc5a529d1cf3b51f8bcfff668a9e525df3e62584369d4b5526c89e70235378420b164073946ea91cf182065d9c8d2d46c8750d5f77855239b77ce45bae SHA512 7b1cbb90c1ddcf63b8802cfa3a53611f6367801b492c7677ef038738a337002c4606bcf93c5186abf808e74bca1fa76266169245acdb3b5997651bcabfecfa5c
diff --git a/net-print/foomatic-db/foomatic-db-4.0.20140105.ebuild b/net-print/foomatic-db/foomatic-db-4.0.20140105.ebuild
deleted file mode 100644
index 8c7581fcb014..000000000000
--- a/net-print/foomatic-db/foomatic-db-4.0.20140105.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit versionator
-
-DESCRIPTION="Printer information files for foomatic-db-engine to generate ppds"
-HOMEPAGE="http://www.linuxprinting.org/foomatic.html"
-#SRC_URI="http://www.openprinting.org/download/foomatic/${PN}-$(replace_version_separator 2 -).tar.gz"
-SRC_URI="https://dev.gentoo.org/~dilfridge/distfiles/${PN}-$(replace_version_separator 2 -).tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd"
-IUSE=""
-
-DEPEND=""
-RDEPEND="
- net-print/foomatic-db-engine
- !net-print/foo2zjs[hp2600n]"
-
-S="${WORKDIR}/${PN}-$(get_version_component_range 3 ${PV})"
-
-src_prepare() {
- # ppd files do not belong to this package
- rm -r db/source/PPD || die
-}
-
-src_configure() {
- econf \
- --disable-gzip-ppds \
- --disable-ppds-to-cups
-}
-
-src_install() {
- default
- rmdir "${ED}"/usr/share/foomatic/db/source/PPD || die
- # Avoid collision with foo2zjs, bug 185486
- rm "${ED}"/usr/share/foomatic/db/source/{driver/foo2{hp,lava,xqx,zjs}.xml,printer/{Generic-ZjStream_Printer,HP-{Color_LaserJet_{1500,1600,2600n},LaserJet_{10{00,05,18,20,22},M1005_MFP}},Minolta-{Color_PageWorks_Pro_L,magicolor_2{20,30,43}0_DL},Samsung-CLP-{3,6}00}.xml} || die
-}
diff --git a/net-print/foomatic-db/foomatic-db-4.0.20161101.ebuild b/net-print/foomatic-db/foomatic-db-4.0.20161101.ebuild
deleted file mode 100644
index eb237a0a62eb..000000000000
--- a/net-print/foomatic-db/foomatic-db-4.0.20161101.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit versionator
-
-DESCRIPTION="Printer information files for foomatic-db-engine to generate ppds"
-HOMEPAGE="http://www.linuxprinting.org/foomatic.html"
-SRC_URI="http://www.openprinting.org/download/foomatic/${PN}-$(replace_version_separator 2 -).tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE=""
-
-DEPEND=""
-RDEPEND="
- net-print/foomatic-db-engine
- !net-print/foo2zjs[hp2600n]"
-
-S="${WORKDIR}/${PN}-$(get_version_component_range 3 ${PV})"
-
-src_prepare() {
- # ppd files do not belong to this package
- rm -r db/source/PPD || die
-}
-
-src_configure() {
- econf \
- --disable-gzip-ppds \
- --disable-ppds-to-cups
-}
-
-src_install() {
- default
- rmdir "${ED}"/usr/share/foomatic/db/source/PPD || die
- # Avoid collision with foo2zjs, bug 185486
- rm "${ED}"/usr/share/foomatic/db/source/{driver/foo2{hp,lava,xqx,zjs}.xml,printer/{Generic-ZjStream_Printer,HP-{Color_LaserJet_{1500,1600,2600n},LaserJet_{10{00,05,18,20,22},M1005_MFP}},Minolta-{Color_PageWorks_Pro_L,magicolor_2{20,30,43}0_DL},Samsung-CLP-{3,6}00}.xml} || die
-}
diff --git a/net-print/foomatic-db/foomatic-db-4.0.20160504.ebuild b/net-print/foomatic-db/foomatic-db-4.0.20180126.ebuild
index eb237a0a62eb..1a475c50eb02 100644
--- a/net-print/foomatic-db/foomatic-db-4.0.20160504.ebuild
+++ b/net-print/foomatic-db/foomatic-db-4.0.20180126.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
inherit versionator
@@ -24,6 +24,7 @@ S="${WORKDIR}/${PN}-$(get_version_component_range 3 ${PV})"
src_prepare() {
# ppd files do not belong to this package
rm -r db/source/PPD || die
+ default
}
src_configure() {