summaryrefslogtreecommitdiff
path: root/net-print/poster/poster-20060221-r4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-print/poster/poster-20060221-r4.ebuild')
-rw-r--r--net-print/poster/poster-20060221-r4.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-print/poster/poster-20060221-r4.ebuild b/net-print/poster/poster-20060221-r4.ebuild
new file mode 100644
index 000000000000..b0aeabe617c5
--- /dev/null
+++ b/net-print/poster/poster-20060221-r4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Small utility for making a poster from an EPS file or a one-page PS document"
+HOMEPAGE="https://ctan.org/pkg/poster"
+SRC_URI="mirror://kde/printing/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix_gs_crash.patch"
+ "${FILESDIR}/${P}-fix_duplicate_DocumentMedia.patch"
+ "${FILESDIR}/${P}-fix_cutmarks.patch"
+)
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} ${PN}.c -lm -o ${PN} || die
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ dodoc README ChangeLog
+}