summaryrefslogtreecommitdiff
path: root/net-print/mtink/mtink-1.0.16-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-print/mtink/mtink-1.0.16-r2.ebuild')
-rw-r--r--net-print/mtink/mtink-1.0.16-r2.ebuild35
1 files changed, 23 insertions, 12 deletions
diff --git a/net-print/mtink/mtink-1.0.16-r2.ebuild b/net-print/mtink/mtink-1.0.16-r2.ebuild
index 79e369b73084..8f231fa1e74e 100644
--- a/net-print/mtink/mtink-1.0.16-r2.ebuild
+++ b/net-print/mtink/mtink-1.0.16-r2.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
+inherit toolchain-funcs
DESCRIPTION="mtink is a status monitor and inkjet cartridge changer for some Epson printers"
HOMEPAGE="http://xwtools.automatix.de/"
@@ -12,19 +14,31 @@ SLOT="0"
KEYWORDS="amd64 ~ppc ~sparc x86"
IUSE="cups doc X"
-DEPEND="X? ( x11-libs/libX11
+DEPEND="
+ virtual/libusb:0
+ cups? ( net-print/cups )
+ X? (
+ x11-libs/libX11
x11-libs/libXpm
x11-libs/libXt
- >=x11-libs/motif-2.3:0 )
+ x11-libs/motif:0
+ )
cups? ( net-print/cups )
virtual/libusb:0"
RDEPEND="${DEPEND}"
PATCHES=(
- "${FILESDIR}/${P}-overflow.patch"
- "${FILESDIR}/${P}-flags.patch"
+ "${FILESDIR}"/${P}-overflow.patch
+ "${FILESDIR}"/${P}-flags.patch
+ "${FILESDIR}"/${P}-motif.patch
+ "${FILESDIR}"/${P}-fno-common.patch
)
+src_prepare() {
+ default
+ sed -i -e "s/gcc/$(tc-getCC)/g" Makefile.ORG || die
+}
+
src_configure() {
if use X ; then
./Configure || die
@@ -48,9 +62,7 @@ src_compile() {
src_install() {
dobin ttink detect/askPrinter
- if use X; then
- dobin mtinkc mtink
- fi
+ use X && dobin mtinkc mtink
dosbin mtinkd
@@ -62,9 +74,8 @@ src_install() {
doexe etc/mtink-cups
fi
- dodoc README CHANGE.LOG
- use doc && \
- dohtml html/*.gif html/*.html
+ dodoc html/README CHANGE.LOG
+ use doc && dodoc -r html/*.{gif,html}
}
pkg_postinst() {