summaryrefslogtreecommitdiff
path: root/net-print/cups-pk-helper/cups-pk-helper-0.2.6-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-print/cups-pk-helper/cups-pk-helper-0.2.6-r1.ebuild')
-rw-r--r--net-print/cups-pk-helper/cups-pk-helper-0.2.6-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-print/cups-pk-helper/cups-pk-helper-0.2.6-r1.ebuild b/net-print/cups-pk-helper/cups-pk-helper-0.2.6-r1.ebuild
new file mode 100644
index 000000000000..39719a8af2cb
--- /dev/null
+++ b/net-print/cups-pk-helper/cups-pk-helper-0.2.6-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2
+
+DESCRIPTION="PolicyKit helper to configure cups with fine-grained privileges"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/cups-pk-helper"
+SRC_URI="https://www.freedesktop.org/software/${PN}/releases/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm arm64 ~ia64 ppc ppc64 ~riscv ~sparc x86"
+
+# Require {glib,gdbus-codegen}-2.30.0 due to GDBus changes between 2.29.92
+# and 2.30.0
+DEPEND="
+ >=dev-libs/glib-2.30.0:2
+ net-print/cups
+ >=sys-auth/polkit-0.97
+"
+RDEPEND="${DEPEND}
+ sys-apps/dbus
+"
+BDEPEND="
+ >=dev-util/gdbus-codegen-2.30.0
+ >=dev-util/intltool-0.40.6
+ virtual/pkgconfig
+ sys-devel/gettext
+"
+
+DOCS=( AUTHORS HACKING NEWS README )
+
+src_prepare() {
+ # Regenerate dbus-codegen files to fix build with glib-2.30.x; bug #410773
+ rm -v src/cph-iface-mechanism.{c,h} || die
+
+ gnome2_src_prepare
+}