summaryrefslogtreecommitdiff
path: root/net-print/cups-filters/cups-filters-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-print/cups-filters/cups-filters-9999.ebuild')
-rw-r--r--net-print/cups-filters/cups-filters-9999.ebuild22
1 files changed, 11 insertions, 11 deletions
diff --git a/net-print/cups-filters/cups-filters-9999.ebuild b/net-print/cups-filters/cups-filters-9999.ebuild
index 90abc670cca8..ddd2623dced4 100644
--- a/net-print/cups-filters/cups-filters-9999.ebuild
+++ b/net-print/cups-filters/cups-filters-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -19,7 +19,7 @@ HOMEPAGE="https://wiki.linuxfoundation.org/openprinting/cups-filters"
LICENSE="MIT GPL-2"
SLOT="0"
-IUSE="dbus +foomatic jpeg ldap pclm pdf perl png +postscript static-libs test tiff zeroconf"
+IUSE="dbus +foomatic jpeg ldap pclm pdf perl png +postscript test tiff zeroconf"
RESTRICT="!test? ( test )"
@@ -79,13 +79,13 @@ src_configure() {
--with-pdftops=pdftops
--with-rcdir=no
--without-php
+ --disable-static
$(use_enable dbus)
$(use_enable foomatic)
$(use_enable ldap)
$(use_enable pclm)
$(use_enable pdf mutool)
$(use_enable postscript ghostscript)
- $(use_enable static-libs static)
$(use_enable zeroconf avahi)
$(use_with jpeg)
$(use_with png)
@@ -98,21 +98,25 @@ src_compile() {
default
if use perl; then
- pushd "${S}/scripting/perl" > /dev/null
+ pushd "${S}/scripting/perl" > /dev/null || die
perl-module_src_configure
perl-module_src_compile
- popd > /dev/null
+ popd > /dev/null || die
fi
}
+src_test() {
+ emake check
+}
+
src_install() {
default
if use perl; then
- pushd "${S}/scripting/perl" > /dev/null
+ pushd "${S}/scripting/perl" > /dev/null || die
perl-module_src_install
perl_delete_localpod
- popd > /dev/null
+ popd > /dev/null || die
fi
if use postscript; then
@@ -134,10 +138,6 @@ src_install() {
systemd_dounit "${S}/utils/cups-browsed.service"
}
-src_test() {
- emake check
-}
-
pkg_postinst() {
if ! use foomatic ; then
ewarn "You are disabling the foomatic code in cups-filters. Please do that ONLY if absolutely."