summaryrefslogtreecommitdiff
path: root/net-print/cups-filters/cups-filters-1.28.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-print/cups-filters/cups-filters-1.28.3.ebuild')
-rw-r--r--net-print/cups-filters/cups-filters-1.28.3.ebuild24
1 files changed, 12 insertions, 12 deletions
diff --git a/net-print/cups-filters/cups-filters-1.28.3.ebuild b/net-print/cups-filters/cups-filters-1.28.3.ebuild
index d9d1f9e65e60..589687b5cf87 100644
--- a/net-print/cups-filters/cups-filters-1.28.3.ebuild
+++ b/net-print/cups-filters/cups-filters-1.28.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,14 +12,14 @@ if [[ "${PV}" == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/OpenPrinting/cups-filters.git"
else
SRC_URI="http://www.openprinting.org/download/${PN}/${P}.tar.xz"
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86"
+ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86"
fi
DESCRIPTION="Cups filters"
HOMEPAGE="https://wiki.linuxfoundation.org/openprinting/cups-filters"
LICENSE="MIT GPL-2"
SLOT="0"
-IUSE="dbus +foomatic jpeg ldap pclm pdf perl png +postscript static-libs test tiff zeroconf"
+IUSE="dbus +foomatic jpeg ldap pclm pdf perl png +postscript test tiff zeroconf"
RESTRICT="!test? ( test )"
@@ -81,13 +81,13 @@ src_configure() {
--with-pdftops=pdftops
--with-rcdir=no
--without-php
+ --disable-static
$(use_enable dbus)
$(use_enable foomatic)
$(use_enable ldap)
$(use_enable pclm)
$(use_enable pdf mutool)
$(use_enable postscript ghostscript)
- $(use_enable static-libs static)
$(use_enable zeroconf avahi)
$(use_with jpeg)
$(use_with png)
@@ -100,21 +100,25 @@ src_compile() {
default
if use perl; then
- pushd "${S}/scripting/perl" > /dev/null
+ pushd "${S}/scripting/perl" > /dev/null || die
perl-module_src_configure
perl-module_src_compile
- popd > /dev/null
+ popd > /dev/null || die
fi
}
+src_test() {
+ emake check
+}
+
src_install() {
default
if use perl; then
- pushd "${S}/scripting/perl" > /dev/null
+ pushd "${S}/scripting/perl" > /dev/null || die
perl-module_src_install
perl_delete_localpod
- popd > /dev/null
+ popd > /dev/null || die
fi
if use postscript; then
@@ -136,10 +140,6 @@ src_install() {
systemd_dounit "${S}/utils/cups-browsed.service"
}
-src_test() {
- emake check
-}
-
pkg_postinst() {
if ! use foomatic ; then
ewarn "You are disabling the foomatic code in cups-filters. Please do that ONLY if absolutely."