summaryrefslogtreecommitdiff
path: root/net-print/cndrvcups-common-lb/cndrvcups-common-lb-3.70.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-print/cndrvcups-common-lb/cndrvcups-common-lb-3.70.ebuild')
-rw-r--r--net-print/cndrvcups-common-lb/cndrvcups-common-lb-3.70.ebuild24
1 files changed, 13 insertions, 11 deletions
diff --git a/net-print/cndrvcups-common-lb/cndrvcups-common-lb-3.70.ebuild b/net-print/cndrvcups-common-lb/cndrvcups-common-lb-3.70.ebuild
index 23e5c3724b52..41880207f325 100644
--- a/net-print/cndrvcups-common-lb/cndrvcups-common-lb-3.70.ebuild
+++ b/net-print/cndrvcups-common-lb/cndrvcups-common-lb-3.70.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools
+
+inherit autotools toolchain-funcs
MY_PV="$(ver_rs 1- '')"
SOURCES_NAME="linux-UFRII-drv-v${MY_PV}-uken"
@@ -15,19 +16,18 @@ SRC_URI="http://gdlp01.c-wss.com/gds/8/0100007658/08/${SOURCES_NAME}-05.tar.gz"
LICENSE="Canon-UFR-II GPL-2 MIT"
SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
-IUSE=""
RDEPEND="
>=dev-libs/libxml2-2.6:2
>=gnome-base/libglade-2.4:2.0
>=net-print/cups-1.1.17
- >=x11-libs/gtk+-2.4:2
-"
+ >=x11-libs/gtk+-2.4:2"
DEPEND="${DEPEND}"
-BDEPEND=""
S="${WORKDIR}/${SOURCES_NAME}/Sources/${P/-lb-${PV}/-4.10}"
+PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
+
pkg_setup() {
# Don't raise a fuss over pre-built binaries
QA_PREBUILT="
@@ -39,11 +39,9 @@ pkg_setup() {
/usr/$(get_abi_LIBDIR x86)/libcaiousb.so.1.0.0
/usr/$(get_abi_LIBDIR x86)/libcaiowrap.so.1.0.0
/usr/$(get_abi_LIBDIR x86)/libcanon_slim.so.1.0.0
- /usr/$(get_libdir)/libcanonc3pl.so.1.0.0
- "
+ /usr/$(get_libdir)/libcanonc3pl.so.1.0.0"
QA_SONAME="
- /usr/$(get_abi_LIBDIR x86)/libcaiousb.so.1.0.0
- "
+ /usr/$(get_abi_LIBDIR x86)/libcaiousb.so.1.0.0"
}
src_unpack() {
@@ -66,6 +64,8 @@ src_prepare() {
"s:backenddir = \$(libdir)/cups/backend:backenddir = `cups-config --serverbin`/backend:" \
backend/Makefile.am || die
+ sed -i -e "s@CC=gcc@CC=$(tc-getCC)@" c3plmod_ipc/Makefile || die
+
export "LIBS=-lgtk-x11-2.0 -lgobject-2.0 -lglib-2.0 -lgmodule-2.0"
change_dir mv configure.in configure.ac
change_dir sed -i -e 's/configure.in/configure.ac/' configure.ac
@@ -77,7 +77,7 @@ src_configure() {
}
src_compile() {
- change_dir emake
+ change_dir emake AR="$(tc-getAR)"
# Cannot be moved to 'change_dir' as it doesn't need eautoreconf
cd "${S}/c3plmod_ipc" || die
@@ -116,4 +116,6 @@ src_install() {
if [[ "$(get_libdir)" != lib ]] && [[ ${SYMLINK_LIB} = yes ]]; then
dosym "../$(get_libdir)/libc3pl.so" /usr/lib/libc3pl.so
fi
+
+ find "${ED}" -name '*.la' -o -name '*.a' -delete || die
}