summaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/Manifest.gzbin9760 -> 9763 bytes
-rw-r--r--net-p2p/airdcpp-webclient/Manifest2
-rw-r--r--net-p2p/airdcpp-webclient/airdcpp-webclient-2.3.0.ebuild65
-rw-r--r--net-p2p/cpuminer-opt/Manifest6
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-3.8.7.1.ebuild46
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-3.8.7.2.ebuild46
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-3.8.7.ebuild46
7 files changed, 211 insertions, 0 deletions
diff --git a/net-p2p/Manifest.gz b/net-p2p/Manifest.gz
index 2f4dbcc5160f..aaf21bd085fa 100644
--- a/net-p2p/Manifest.gz
+++ b/net-p2p/Manifest.gz
Binary files differ
diff --git a/net-p2p/airdcpp-webclient/Manifest b/net-p2p/airdcpp-webclient/Manifest
index ea2f0b2e1bcd..10b82d8f32e9 100644
--- a/net-p2p/airdcpp-webclient/Manifest
+++ b/net-p2p/airdcpp-webclient/Manifest
@@ -1,5 +1,7 @@
AUX airdcppd.confd 198 BLAKE2B 7d3fbce6527a7f1971f544a37215fa73ed1f19bc5f6c4c3ef90c28b170b84ecd3a82da77b582b69ef442a9a455752192ba4b6b33aeb9a43587c0209fdf380342 SHA512 025ec93c208173771fe697574c9161b9af8d740eab0b1290c8d3857961dc3635339bdb9c18b97fdde6fa7dc8924f4453b9c609ca57e61f1cad9ff47683fb613e
AUX airdcppd.initd 584 BLAKE2B 6e19d6088b26153527fa51e3789c3968647af3f7a2b1fbe2b355587b14eef94b8800a78565ce3bd54f0474542496bfd9f80566c36fcf6f1e51f55c48aa0654ee SHA512 f6de7a576eaef662e73dd488acd956371891278a6fa6c912be864c630a22435541deaca9055c6d7912bf483de228db2cd0bd9c9666a1a436de55112561783721
DIST airdcpp-webclient-2.2.1.tar.gz 845507 BLAKE2B 5d97fe5d25957d870cc5480153acb746ac20bc398e637ccf25a98e42cc905fb445bbc47c211174552e0ee23d1affb0a9265d8499389373bf6622b14428300bd5 SHA512 97c5b32e590b2fc735fe4978c1a173272c55f84fe97212f7cd1e8bd4a279553c1d992573185781aeceafbbe6bb51303ddb2cd164c748fa798993a661f3abfb81
+DIST airdcpp-webclient-2.3.0.tar.gz 880508 BLAKE2B 426c0582ffad734cae2f66826aa04b2db791a110abc79629f4e3b71a69db354b56d213feae6d807f3b7a3f2906aac00fc50c49eaf3dc7d8e09783f59c99ef4e5 SHA512 b1f47c8f500aa684a8cabcff916b6a1e41230d949a35d57c80f13734f6f88f8c3a31d99f64cc1f6e316d26710da894670f130baf78fec5ecf3a70a70f0d7417a
EBUILD airdcpp-webclient-2.2.1.ebuild 1431 BLAKE2B 5a4ec19c01fd32862d96a415cfabd10576b4ae435a33d8788ba2a8ec1dc02e0e30f517a76c36d2392840ae239d7aa3ff9571b7625208c13e2d81c5741469284f SHA512 40fd30c487e3ac0eb2cc80ed3fc40bdda23adb9be229499a47b4abb12e2cff73fd95ab1cc2e920ae8f867d6f3b55cbd441ecee3396bd465b0dbfc0678ad1e902
+EBUILD airdcpp-webclient-2.3.0.ebuild 1440 BLAKE2B 1a2486c19ac9b0814b03811232d648553febaf1277f3b8d88dccf57f3af6078f34b5ed73f6ab14a9b32f822fdbb8ae9a583a8a09ebafbb9271b6641d5929e348 SHA512 1726caffeea7019c6b3ae244c29d787749871c309bafb83974d947c960f7137c51923ad9ef0feed8124055e326291bc2c00aeec938f7e3a6702e7a824475e8c2
MISC metadata.xml 928 BLAKE2B e00d0b7df5302e9129c18fa7250dc30fe34e339cd99e41751d64546d41b0ed328e442825f372acec7207e97f67655c3c05ce99cfda096a7895097210b2d57b1f SHA512 ceccd70826faff18052a1cfe3cdcef1a253ed1227565fa94e865fba8c0a5b8a03535844a3b78d98f6bc26e8a9f29202f0bf1e19fa833d4356ace1e6b26e3936e
diff --git a/net-p2p/airdcpp-webclient/airdcpp-webclient-2.3.0.ebuild b/net-p2p/airdcpp-webclient/airdcpp-webclient-2.3.0.ebuild
new file mode 100644
index 000000000000..9c72310e8ce0
--- /dev/null
+++ b/net-p2p/airdcpp-webclient/airdcpp-webclient-2.3.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy{,3} )
+
+inherit cmake-utils python-any-r1 user
+
+DESCRIPTION="Cross-platform Direct Connect client"
+HOMEPAGE="https://airdcpp-web.github.io/"
+SRC_URI="https://github.com/airdcpp-web/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="nat-pmp +tbb +webui"
+
+RDEPEND="
+ app-arch/bzip2
+ dev-cpp/websocketpp
+ dev-libs/boost:=
+ dev-libs/leveldb:=
+ dev-libs/libmaxminddb:=
+ dev-libs/openssl:0=[-bindist]
+ net-libs/miniupnpc:=
+ sys-libs/zlib:=
+ virtual/libiconv
+ nat-pmp? ( net-libs/libnatpmp:= )
+ tbb? ( dev-cpp/tbb:= )
+"
+DEPEND="
+ virtual/pkgconfig
+ ${PYTHON_DEPS}
+ ${RDEPEND}
+"
+PDEPEND="webui? ( www-apps/airdcpp-webui )"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ enewgroup airdcppd
+ enewuser airdcppd -1 -1 /var/lib/airdcppd airdcppd
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DINSTALL_WEB_UI=OFF
+ -DENABLE_NATPMP=$(usex nat-pmp)
+ -DENABLE_TBB=$(usex tbb)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ newconfd "${FILESDIR}/airdcppd.confd" airdcppd
+ newinitd "${FILESDIR}/airdcppd.initd" airdcppd
+ keepdir /var/lib/airdcppd
+ fowners airdcppd:airdcppd /var/lib/airdcppd
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "Run 'airdcppd --configure' to set up ports and authentication"
+ fi
+}
diff --git a/net-p2p/cpuminer-opt/Manifest b/net-p2p/cpuminer-opt/Manifest
index 2ce3fdda4b07..ff6618c4d370 100644
--- a/net-p2p/cpuminer-opt/Manifest
+++ b/net-p2p/cpuminer-opt/Manifest
@@ -3,9 +3,15 @@ DIST cpuminer-opt-3.8.4.1.tar.gz 1678548 BLAKE2B 86ff1dce5abf735982f1272f6a97a18
DIST cpuminer-opt-3.8.5.tar.gz 1701640 BLAKE2B b42d52da56e141bac42b4e5159325f8344434ecfee6e740fbd3c10cc64b448c6b849b029ea703e0f63e6720625fedcfd84e22dd34fc4a4ce37a88e120337ac1e SHA512 27047b8ee4c2a84f40f62ee6a0a4b24245096ade061d55c3c5374aa12e548aeb6d2dc665799ac81edaabcce63a21af11cef8df6ad050fb8cc7094170ec7a8384
DIST cpuminer-opt-3.8.6.1.tar.gz 1701432 BLAKE2B daef8f5f4d5734e80fba1f21dbf3954ccb521dd102dc50427f934b6dbb66d74db85cc2f778da47723783fb2ccca81c6e318da414bc1aa968f4e9966faf88ccea SHA512 a88a0f9b0eb62b5ab74e97616c9c90220847fef232987409ec1ac6d47e1b85f0de186cbccdb317db001dec2f67cd6ea7d5c738abc6bbb42fbadbca53492441db
DIST cpuminer-opt-3.8.6.tar.gz 1701535 BLAKE2B ed51168879e6ca6ada67f13b7325b36c8e58dd3d6d71c55993e84ff9363864fd503f70849fd29366607e57b23f1493539e0e17d1043295266ed4505fbd032cb7 SHA512 57ab3ff3f0a298a4c24d0d8cf4f145627435bbdc4577952995a8babbd7838ae36e56a0d1e2b4c8900af6beecae95af29fef58b74b9afb5268307b67043ef93c4
+DIST cpuminer-opt-3.8.7.1.tar.gz 1707776 BLAKE2B 134c25fab106db6fad601010f8f91a82e42bc03b94e633ffd3db3ef3d4eb05f2561e1249c06f3505a03abbb95976ebfcbcbad225166bc2208a123df15859036a SHA512 74cd569718cf8402cb25a4be4e9d94a897a697e02c7c9f6422313c3a3026f3d12a8eea9669b3a253fdfb471311bf49f8209f35efacb84fd3151e4ac8acda2ed7
+DIST cpuminer-opt-3.8.7.2.tar.gz 1707968 BLAKE2B 2358286014b631fea94f49de5ccb61477c0b388c650a87734ee684781ddc0f0cbdbb539affce6c12da8a4ca91a132f8ca9a4ba923c971d0ddca8e712276899ec SHA512 857a91a1061d9d4921af94743faee03031e8f2e92ba2e1d885dbd1060b19d6b93d28e9f54d10e59930eb0c8ebdb19db9888aca9ce0a05e7fbbb659d3ae3e25b5
+DIST cpuminer-opt-3.8.7.tar.gz 1707993 BLAKE2B c1a3156c02a3adf80b75fd6766c3bb7d20755813f90b2669ff6d462990ef2b80a97218b0a30fb559c8c2b3902bdc194e01f463351778f6fbd2a8a08c44da3e81 SHA512 c2aee02586712591d609748e5dbf90d5e28050fa4611915e216a6fef79fdb7ea2e0c31b844457fd505f2cc6892268dbcaebe3ed6b00f2efe9734c8d19ba8096a
EBUILD cpuminer-opt-3.8.4.1.ebuild 1002 BLAKE2B 33f93d5f53ddd1f52e0dca9e3afbc7c61e54c74618ad6e8d65b106c95240f3e108ae1f4b8aa47c3994309791caaac7623099a9cc6e6bf3b3b949db84a73d20ed SHA512 fdd3205d085d5f45b65becdf5157cbd9817e9aba9f8436e78bab45baaa77287a6e9a563fd959d7559d6794747ec24204ee566db22dda3f18e75b5ec8db51d0bf
EBUILD cpuminer-opt-3.8.5.ebuild 1002 BLAKE2B 33f93d5f53ddd1f52e0dca9e3afbc7c61e54c74618ad6e8d65b106c95240f3e108ae1f4b8aa47c3994309791caaac7623099a9cc6e6bf3b3b949db84a73d20ed SHA512 fdd3205d085d5f45b65becdf5157cbd9817e9aba9f8436e78bab45baaa77287a6e9a563fd959d7559d6794747ec24204ee566db22dda3f18e75b5ec8db51d0bf
EBUILD cpuminer-opt-3.8.6.1.ebuild 1002 BLAKE2B 33f93d5f53ddd1f52e0dca9e3afbc7c61e54c74618ad6e8d65b106c95240f3e108ae1f4b8aa47c3994309791caaac7623099a9cc6e6bf3b3b949db84a73d20ed SHA512 fdd3205d085d5f45b65becdf5157cbd9817e9aba9f8436e78bab45baaa77287a6e9a563fd959d7559d6794747ec24204ee566db22dda3f18e75b5ec8db51d0bf
EBUILD cpuminer-opt-3.8.6.ebuild 1002 BLAKE2B 33f93d5f53ddd1f52e0dca9e3afbc7c61e54c74618ad6e8d65b106c95240f3e108ae1f4b8aa47c3994309791caaac7623099a9cc6e6bf3b3b949db84a73d20ed SHA512 fdd3205d085d5f45b65becdf5157cbd9817e9aba9f8436e78bab45baaa77287a6e9a563fd959d7559d6794747ec24204ee566db22dda3f18e75b5ec8db51d0bf
+EBUILD cpuminer-opt-3.8.7.1.ebuild 1002 BLAKE2B 33f93d5f53ddd1f52e0dca9e3afbc7c61e54c74618ad6e8d65b106c95240f3e108ae1f4b8aa47c3994309791caaac7623099a9cc6e6bf3b3b949db84a73d20ed SHA512 fdd3205d085d5f45b65becdf5157cbd9817e9aba9f8436e78bab45baaa77287a6e9a563fd959d7559d6794747ec24204ee566db22dda3f18e75b5ec8db51d0bf
+EBUILD cpuminer-opt-3.8.7.2.ebuild 1002 BLAKE2B 33f93d5f53ddd1f52e0dca9e3afbc7c61e54c74618ad6e8d65b106c95240f3e108ae1f4b8aa47c3994309791caaac7623099a9cc6e6bf3b3b949db84a73d20ed SHA512 fdd3205d085d5f45b65becdf5157cbd9817e9aba9f8436e78bab45baaa77287a6e9a563fd959d7559d6794747ec24204ee566db22dda3f18e75b5ec8db51d0bf
+EBUILD cpuminer-opt-3.8.7.ebuild 1002 BLAKE2B 33f93d5f53ddd1f52e0dca9e3afbc7c61e54c74618ad6e8d65b106c95240f3e108ae1f4b8aa47c3994309791caaac7623099a9cc6e6bf3b3b949db84a73d20ed SHA512 fdd3205d085d5f45b65becdf5157cbd9817e9aba9f8436e78bab45baaa77287a6e9a563fd959d7559d6794747ec24204ee566db22dda3f18e75b5ec8db51d0bf
EBUILD cpuminer-opt-9999.ebuild 1002 BLAKE2B 33f93d5f53ddd1f52e0dca9e3afbc7c61e54c74618ad6e8d65b106c95240f3e108ae1f4b8aa47c3994309791caaac7623099a9cc6e6bf3b3b949db84a73d20ed SHA512 fdd3205d085d5f45b65becdf5157cbd9817e9aba9f8436e78bab45baaa77287a6e9a563fd959d7559d6794747ec24204ee566db22dda3f18e75b5ec8db51d0bf
MISC metadata.xml 333 BLAKE2B f7851fe0d55d729c75e3934fa32ab578c57d3dfc4a1634cc8dcca655f0d4ab1a6bb56d0b9c347dedb6cedf3d5a5a7a1bb9662856733970b1cc8db288c26be4a2 SHA512 770d39605bb1afa7d7643b4fc8f295e449f90175ae0d31c8a5023bfc9ba233c9e80ebf1dfbf81c4b86af8dc1d66bc336a4464748f162119b35fcb695cd54e656
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-3.8.7.1.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-3.8.7.1.ebuild
new file mode 100644
index 000000000000..a1f4a660f6b9
--- /dev/null
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-3.8.7.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Optimized multi algo CPU miner"
+HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
+IUSE="cpu_flags_x86_sse2 curl libressl"
+LICENSE="GPL-2"
+SLOT="0"
+REQUIRED_USE="cpu_flags_x86_sse2"
+DEPEND="
+ dev-libs/gmp:0
+ dev-libs/jansson
+ curl? ( >=net-misc/curl-7.15[ssl] )
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/JayDDee/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ econf --with-crypto $(use_with curl)
+}
+
+src_install() {
+ default
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ insinto "/etc/${PN}"
+ doins cpuminer-conf.json
+}
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-3.8.7.2.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-3.8.7.2.ebuild
new file mode 100644
index 000000000000..a1f4a660f6b9
--- /dev/null
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-3.8.7.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Optimized multi algo CPU miner"
+HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
+IUSE="cpu_flags_x86_sse2 curl libressl"
+LICENSE="GPL-2"
+SLOT="0"
+REQUIRED_USE="cpu_flags_x86_sse2"
+DEPEND="
+ dev-libs/gmp:0
+ dev-libs/jansson
+ curl? ( >=net-misc/curl-7.15[ssl] )
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/JayDDee/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ econf --with-crypto $(use_with curl)
+}
+
+src_install() {
+ default
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ insinto "/etc/${PN}"
+ doins cpuminer-conf.json
+}
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-3.8.7.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-3.8.7.ebuild
new file mode 100644
index 000000000000..a1f4a660f6b9
--- /dev/null
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-3.8.7.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Optimized multi algo CPU miner"
+HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
+IUSE="cpu_flags_x86_sse2 curl libressl"
+LICENSE="GPL-2"
+SLOT="0"
+REQUIRED_USE="cpu_flags_x86_sse2"
+DEPEND="
+ dev-libs/gmp:0
+ dev-libs/jansson
+ curl? ( >=net-misc/curl-7.15[ssl] )
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/JayDDee/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ econf --with-crypto $(use_with curl)
+}
+
+src_install() {
+ default
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ insinto "/etc/${PN}"
+ doins cpuminer-conf.json
+}