summaryrefslogtreecommitdiff
path: root/net-p2p/ncdc/ncdc-1.19.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/ncdc/ncdc-1.19.1.ebuild')
-rw-r--r--net-p2p/ncdc/ncdc-1.19.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-p2p/ncdc/ncdc-1.19.1.ebuild b/net-p2p/ncdc/ncdc-1.19.1.ebuild
new file mode 100644
index 000000000000..7810c157e08a
--- /dev/null
+++ b/net-p2p/ncdc/ncdc-1.19.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools eutils toolchain-funcs
+
+DESCRIPTION="ncurses directconnect client"
+HOMEPAGE="http://dev.yorhel.nl/ncdc"
+SRC_URI="http://dev.yorhel.nl/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+IUSE="geoip"
+
+RDEPEND="app-arch/bzip2
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ net-libs/gnutls
+ sys-libs/ncurses:0[unicode]
+ sys-libs/zlib
+ geoip? ( dev-libs/geoip )"
+DEPEND="${RDEPEND}
+ dev-util/makeheaders
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch_user && eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with geoip)
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}