summaryrefslogtreecommitdiff
path: root/net-p2p/mktorrent/mktorrent-1.1_p20180502.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/mktorrent/mktorrent-1.1_p20180502.ebuild')
-rw-r--r--net-p2p/mktorrent/mktorrent-1.1_p20180502.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-p2p/mktorrent/mktorrent-1.1_p20180502.ebuild b/net-p2p/mktorrent/mktorrent-1.1_p20180502.ebuild
new file mode 100644
index 000000000000..6e9c5fe03dae
--- /dev/null
+++ b/net-p2p/mktorrent/mktorrent-1.1_p20180502.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="Simple command line utility to create BitTorrent metainfo files"
+HOMEPAGE="https://github.com/Rudde/mktorrent"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Rudde/mktorrent.git"
+else
+ COMMIT_ID="96090fb175f3cef17ae2499e98c2868363106927"
+ SRC_URI="https://github.com/Rudde/${PN}/archive/${COMMIT_ID}.tar.gz -> ${PN}-${COMMIT_ID}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+ S="${WORKDIR}/${PN}-${COMMIT_ID}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="threads +ssl debug"
+
+RDEPEND="ssl? ( dev-libs/openssl:0= )"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ tc-export CC
+
+ local myemakeargs=(
+ USE_LONG_OPTIONS=1
+ USE_LARGE_FILES=1
+ DEBUG=$(usex debug)
+ USE_OPENSSL=$(usex ssl)
+ USE_PTHREADS=$(usex threads)
+ )
+ emake "${myemakeargs[@]}"
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README
+}