summaryrefslogtreecommitdiff
path: root/net-news/alligator/alligator-24.02.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-news/alligator/alligator-24.02.2.ebuild')
-rw-r--r--net-news/alligator/alligator-24.02.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-news/alligator/alligator-24.02.2.ebuild b/net-news/alligator/alligator-24.02.2.ebuild
new file mode 100644
index 000000000000..52c3873c160b
--- /dev/null
+++ b/net-news/alligator/alligator-24.02.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="forceoptional"
+KFMIN=6.0.0
+QTMIN=6.6.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="Convergent RSS/Atom feed reader for Plasma"
+HOMEPAGE="https://apps.kde.org/alligator/"
+
+LICENSE="|| ( GPL-2 GPL-3 ) CC0-1.0 CC-BY-SA-4.0 GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-libs/kirigami-addons:6
+ >=dev-qt/qtbase-${QTMIN}:6[gui,network,sql,widgets]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kirigami-${KFMIN}:6
+ >=kde-frameworks/syndication-${KFMIN}:6
+"
+RDEPEND="${DEPEND}"