summaryrefslogtreecommitdiff
path: root/net-misc
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/Manifest.gzbin54072 -> 54083 bytes
-rw-r--r--net-misc/curl/Manifest2
-rw-r--r--net-misc/curl/curl-9999.ebuild26
3 files changed, 24 insertions, 4 deletions
diff --git a/net-misc/Manifest.gz b/net-misc/Manifest.gz
index 7d9ac9861dc1..7c49df0ba83d 100644
--- a/net-misc/Manifest.gz
+++ b/net-misc/Manifest.gz
Binary files differ
diff --git a/net-misc/curl/Manifest b/net-misc/curl/Manifest
index d10a01c402ca..eea44d83cc4d 100644
--- a/net-misc/curl/Manifest
+++ b/net-misc/curl/Manifest
@@ -7,5 +7,5 @@ DIST curl-8.1.2.tar.xz 2612652 BLAKE2B 66d0828912bb9971dac99025aa8b5c1c2fac1f8b5
DIST curl-8.1.2.tar.xz.asc 488 BLAKE2B 304dbdb51aa113c0b70b2662e29b1be3294b04f5f00264ce60703756363999cd567dcd0301e27b294d1d53f16ecc016ba429fcbea240949b372750f7e6e7375a SHA512 d120299a2d59259aeb19ae0fa3a3e181e25b6927677187037c61a0901879956177ce8dda10764073a47848f81dcbbcb94e0b6008742994042b6b8fd194e169c3
EBUILD curl-8.0.1.ebuild 8702 BLAKE2B 24aee27a611d96a824f461384089730f6bc51500dc50d3a2dfc287e6cf76b31f6c072de757c2ff0686158c934f3be69732560c905691bf159da26b31bc005141 SHA512 b33fe3010a94e0db79b8aa1f5367a7ad9b6caaa84a89119bff24ee889cb046c4ce0d84b2e67f08cba31ac9f632ea337a851091437f4b5c89a2ecf942d958681b
EBUILD curl-8.1.2.ebuild 9470 BLAKE2B 4e1909e47fec9452d354098a88ac6290419196055adbbed32cea123fb71fa63e09169e4adeca0dd726809351e2169b6b6ae2c3d37b2c6e08a85e36f000eb34e4 SHA512 11c07852bb13722a4880442802191e087d2321c4fb7408b7883d044f321f9a53be9b3abd6c6c43dbd3b19933d7bdcf9ae7b4e735c0fad73e3cb84d9477cf278e
-EBUILD curl-9999.ebuild 9582 BLAKE2B 83c875a61eeff83025373abff516170abf85a400fdbf9e0e64f8a61eb4f8a69a200537944f106d5d8c632d40aa7128cbd2de7173b292ecea10fb04628366a13d SHA512 15da1eb2e9c0d08d445d3e22a49bdb3fbec9b6de0278809e8e43af382b1f1fde12a8936d0fd77feaec91d9b2298b8f21dee6704792850ed4a28a844d01c01075
+EBUILD curl-9999.ebuild 10114 BLAKE2B 14de0a5075fa558c57a73bf87c57e834c32bed47c45aa2f5551e7742448202e282fadb3fc8f7b1910db60450ec26d07755e41168ecda856a63b47ea9a7de03d6 SHA512 50b15a42248cad6d0a1777525ec11eefa82187928eefca4c1e770f9d615a61632c4ee15dd2900ab4ec506c254f7e2b6f6eb9240d6f6071b2f2ff8d28f8055730
MISC metadata.xml 2203 BLAKE2B 939a2ec06ec2155b88d510abdfaa00eafcd5a7e5f6f7983e456ccfc7cf4179d58adbcc7f282a11bb74d217640c93896fb5038206f7c76ea2c2e2543fe0db378e SHA512 c81d7159c0851dab0ae099c7129d965d3d3bd5cc7f7f3240052a4afab0eaa1e15efbf79265bbad5f2d257cc14b5d30daacd3aa5c3099c2ac264560e23ec797f1
diff --git a/net-misc/curl/curl-9999.ebuild b/net-misc/curl/curl-9999.ebuild
index 770410045476..0414671d123d 100644
--- a/net-misc/curl/curl-9999.ebuild
+++ b/net-misc/curl/curl-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=8
VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/danielstenberg.asc
-inherit autotools multilib-minimal multiprocessing prefix verify-sig
+inherit autotools multilib-minimal multiprocessing prefix toolchain-funcs verify-sig
DESCRIPTION="A Client that groks URLs"
HOMEPAGE="https://curl.se/"
@@ -137,7 +137,7 @@ multilib_src_configure() {
local myconf=()
myconf+=( --without-ca-fallback --with-ca-bundle="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt )
- if use ssl ; then
+ if use ssl; then
myconf+=( --without-gnutls --without-mbedtls --without-nss --without-rustls )
if use gnutls; then
@@ -177,6 +177,7 @@ multilib_src_configure() {
myconf+=( --with-default-ssl-backend=rustls )
else
eerror "We can't be here because of REQUIRED_USE."
+ die "Please file a bug, hit impossible condition w/ USE=ssl handling."
fi
else
@@ -241,7 +242,7 @@ multilib_src_configure() {
--without-amissl
--without-bearssl
$(use_with brotli)
- --without-fish-functions-dir
+ --with-fish-functions-dir="${EPREFIX}"/usr/share/fish/vendor_completions.d
$(use_with http2 nghttp2)
--without-hyper
$(use_with idn libidn2)
@@ -263,6 +264,7 @@ multilib_src_configure() {
--without-wolfssl
--with-zlib
$(use_with zstd)
+ --with-zsh-functions-dir="${EPREFIX}"/usr/share/zsh/site-functions
)
if use test && multilib_is_native_abi && ( use http2 || use nghttp3 ); then
@@ -305,6 +307,15 @@ multilib_src_configure() {
echo "Requires.private: ${priv[*]}" >> libcurl.pc || die
}
+multilib_src_compile() {
+ default
+
+ if multilib_is_native_abi; then
+ # Shell completions
+ ! tc-is-cross-compiler && emake -C scripts
+ fi
+}
+
# There is also a pytest harness that tests for bugs in some very specific
# situations; we can rely on upstream for this rather than adding additional test deps.
multilib_src_test() {
@@ -324,6 +335,15 @@ multilib_src_test() {
multilib_is_native_abi && emake test TFLAGS="-n -v -a -k -am -p -j$((7*$(makeopts_jobs))) !241 !1083"
}
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+
+ if multilib_is_native_abi; then
+ # Shell completions
+ ! tc-is-cross-compiler && emake -C scripts DESTDIR="${D}" install
+ fi
+}
+
multilib_src_install_all() {
einstalldocs
find "${ED}" -type f -name '*.la' -delete || die