summaryrefslogtreecommitdiff
path: root/net-misc
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/Manifest.gzbin55239 -> 55403 bytes
-rw-r--r--net-misc/autoupnp/Manifest5
-rw-r--r--net-misc/autoupnp/autoupnp-0.5.0.ebuild33
-rw-r--r--net-misc/autoupnp/autoupnp-9999.ebuild37
-rw-r--r--net-misc/autoupnp/metadata.xml8
-rw-r--r--net-misc/r8152/Manifest4
-rw-r--r--net-misc/r8152/files/r8152-2.16.3-kernel-5.19-fix.patch43
-rw-r--r--net-misc/r8152/metadata.xml17
-rw-r--r--net-misc/r8152/r8152-2.16.3.ebuild49
9 files changed, 151 insertions, 45 deletions
diff --git a/net-misc/Manifest.gz b/net-misc/Manifest.gz
index 3e163653d624..516fb7236424 100644
--- a/net-misc/Manifest.gz
+++ b/net-misc/Manifest.gz
Binary files differ
diff --git a/net-misc/autoupnp/Manifest b/net-misc/autoupnp/Manifest
index 9844d563f22e..708ce46ee1a1 100644
--- a/net-misc/autoupnp/Manifest
+++ b/net-misc/autoupnp/Manifest
@@ -1,4 +1,5 @@
DIST autoupnp-0.4.7.tar.bz2 264916 BLAKE2B 3542c577a32f5ba3a8ea60c6f2ebb3d5cea76fa440d281e6895c246252d3ba70720aaafa4d843f06a23f1b022942cddb2a0b37b41eff91919db55fbbd87f28b5 SHA512 2c6bb3421fecbffea2a63ea1e930b7c789459d4626a0f281abe0e9bb62e5efc772475d4bf0c9f13fe2e9e13417940c6eb17408e6aae28bc24a4fc2e16d4dc8de
+DIST autoupnp-0.5.0.tar.gz 7402 BLAKE2B b6de76a45e6811e57cfb15bf41d3305ad4e8ed9b1459270426724b016d33a9a398bae5bca4d3d87360d712614fcad0fa5d8571db88ce632afd43220539ba992d SHA512 0118b20fdb225673348c3ba469bfde6c37e79fba42e7dbf7bca6a0c25dd9f853b0ee73860c5dbb8165e97125cb71b2794d4e88ece0a1155c85f4c83390131dbc
EBUILD autoupnp-0.4.7.ebuild 613 BLAKE2B c27ef2e0ceca01d708ca3613289f57f00adcabc20a34105c1a157db81dc982594d00142ea55dd8efc108ce7b8b3bc45950c923bfe5dcdbf990ac213bb9b61ca1 SHA512 a10502a183a05be67b128714c3a0e0acb5773c7b9e776093857575b5197812f1569a31ccc6ff45142798b4a4f66435c9d5a086b7e49e25dd9de6f54042f54e91
-EBUILD autoupnp-9999.ebuild 638 BLAKE2B c0d9468b76db496100c6f2897c716361af2604cd11b70c12d5d4676f97f478bbdee86f4b9d7347323a1585b2c27f84988fe2d489804df47b14db4a421565cf7a SHA512 e306e4285009481c31399d5217aa9549cfafdebd9952fa73802b399b560bc3688b02575d904f759e3c377c8abcd866f46b71dde0a6bb294b74526b04ddd3611f
-MISC metadata.xml 506 BLAKE2B c4f57634d98b30ba532903b86576bf08f4a24c86b0b00c02976753e2c70447f69802fe750c9892557bcbdbb14ab79b6f26bd45a037fbde799215b4734a9985a0 SHA512 f0dacc0b507514389e473f83e6d3f9e6198be0dd077838b57100efabec97c8647e6ef8c000c3ac9e6606cace0a4601e9939ef0d9e2fe61366eaebce6e24059af
+EBUILD autoupnp-0.5.0.ebuild 575 BLAKE2B fa4085e87095e89f62de9c7521540aaedeb421cdf3f79b40b63665fbe10dbe900d8332677da39c244c48e8f6c0428efa810ac000275e9a471534808cbca86be2 SHA512 e524f8bf4c81f5534d555c3dc6a77ca33a7ab0252af3b603fd38321d0033a0a67e8515a71696ac0b75016c36c6ae813b50cbc7c064b37a7adf30bf6b1999fe51
+MISC metadata.xml 392 BLAKE2B d4e689854968e0f26c88b8fa7f615df0d996711233e46bb0bdf1b265b31fa13a614b05a2e03b6b9df101b536dfea70f067a97661bba05bf7624e933a3ee7637d SHA512 42b53800c487b2e53644467ad0f754112d9116179d000dece34c824d1ab2a992046e1048139d88bc2202b5974e14ace9896af9500f05473ea9ba61dce42fb880
diff --git a/net-misc/autoupnp/autoupnp-0.5.0.ebuild b/net-misc/autoupnp/autoupnp-0.5.0.ebuild
new file mode 100644
index 000000000000..9f5acac5c152
--- /dev/null
+++ b/net-misc/autoupnp/autoupnp-0.5.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Automatic open port forwarder using UPnP"
+HOMEPAGE="https://github.com/projg2/autoupnp/"
+SRC_URI="
+ https://github.com/projg2/autoupnp/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+
+DEPEND="
+ net-libs/miniupnpc:0=
+ libnotify? ( x11-libs/libtinynotify:0= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature libnotify)
+ )
+ meson_src_configure
+}
diff --git a/net-misc/autoupnp/autoupnp-9999.ebuild b/net-misc/autoupnp/autoupnp-9999.ebuild
deleted file mode 100644
index f7ea428391ea..000000000000
--- a/net-misc/autoupnp/autoupnp-9999.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools git-r3
-
-DESCRIPTION="Automatic open port forwarder using UPnP"
-HOMEPAGE="https://github.com/mgorny/autoupnp/"
-EGIT_REPO_URI="https://github.com/mgorny/${PN}.git"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS=""
-IUSE="libnotify"
-
-RDEPEND="net-libs/miniupnpc:0=
- libnotify? ( x11-libs/libtinynotify:0= )"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local myconf=(
- $(use_with libnotify)
- )
-
- econf "${myconf[@]}"
-}
-
-src_install() {
- default
- find "${D}" -name '*.la' -delete || die
-}
diff --git a/net-misc/autoupnp/metadata.xml b/net-misc/autoupnp/metadata.xml
index 2b97f05c8032..ff2e8e5125ef 100644
--- a/net-misc/autoupnp/metadata.xml
+++ b/net-misc/autoupnp/metadata.xml
@@ -6,11 +6,7 @@
<name>Michał Górny</name>
</maintainer>
<upstream>
- <maintainer status="active">
- <email>mgorny@gentoo.org</email>
- <name>Michał Górny</name>
- </maintainer>
- <bugs-to>https://github.com/mgorny/autoupnp/issues/</bugs-to>
- <remote-id type="github">mgorny/autoupnp</remote-id>
+ <bugs-to>https://github.com/projg2/autoupnp/issues/</bugs-to>
+ <remote-id type="github">projg2/autoupnp</remote-id>
</upstream>
</pkgmetadata>
diff --git a/net-misc/r8152/Manifest b/net-misc/r8152/Manifest
new file mode 100644
index 000000000000..cbcaa5b83b2d
--- /dev/null
+++ b/net-misc/r8152/Manifest
@@ -0,0 +1,4 @@
+AUX r8152-2.16.3-kernel-5.19-fix.patch 1599 BLAKE2B e1300601e2dcd98729481a6d146ffcc0b55e6163c405608ed783bc56acca65654317804c1da780203d96945b49d815b6efd740a752335d4c0aa562f2ba84bbf3 SHA512 6cdb4ee02c6727d87d94fbd4058b7bbd18e3bb4542c2489d4080217ef323faddbf5b998a83dd42b8e1a1e4c1eb6f65762616382fc5fd8519db07d6dd01f83b4a
+DIST r8152-2.16.3.tar.bz2 73331 BLAKE2B 9e22ee6d9d0197def782f77bfd0c88a2d8827d4f8cc0bbb1a6583ab67533cd07ba79a16cd9350272ed18c733fe809ea1ff70596627abdc65d452bdf817628bc8 SHA512 c37bf5199d3a857c9a7a12f3aa4ecfe9c04b49413aea862a053ebee24c137cd35769e5d5cc7e2bb7dd3bf9057f51ffada0b4e0c53cb3d417e05c8e3fc830705c
+EBUILD r8152-2.16.3.ebuild 1186 BLAKE2B a2677a3275123439393ee103a35e5a9a7ebff7e7377d58ea0d0bced6fd83b7af0c71ae227ce23f7825e54927f769a8e0dda09ba41e48371a7d54b88f42b10738 SHA512 c0cf0f803e16fb7709e2efac79effd3a82eadcfdb80135164eaa0b63364e5ee73e347e0d733ffa90d3977852bb6fefa19f8fff70ecda41b8f1a8e295e8802428
+MISC metadata.xml 660 BLAKE2B 1f7bd7d75e5fc3b88b140f88b82390b09cbffed8770b73b4584f7d9114fd1b97a84f745881d424f30c1a738c332bb04bab3d651bd9734f0170164eb8158ef098 SHA512 c0258ae24671a18801a9a499869267b2c3d2d0350e1fbbf91db6fe2358326bb27551623ef93c9c9a9bebde3c08520463eae00a05802053a0f5b7ade1b0f5ea4d
diff --git a/net-misc/r8152/files/r8152-2.16.3-kernel-5.19-fix.patch b/net-misc/r8152/files/r8152-2.16.3-kernel-5.19-fix.patch
new file mode 100644
index 000000000000..076d78f46062
--- /dev/null
+++ b/net-misc/r8152/files/r8152-2.16.3-kernel-5.19-fix.patch
@@ -0,0 +1,43 @@
+From: https://github.com/wget/realtek-r8152-linux/commit/6ffb3760c34a904467d70830ac9c10211e8f5d3a
+From: Hyacinthe Cartiaux <hyacinthe.cartiaux@free.fr>
+Date: Wed, 14 Sep 2022 15:13:31 +0200
+Subject: [PATCH] Fix for linux 5.19 without breaking older kernel
+ compatibility
+
+--- a/r8152.c
++++ b/r8152.c
+@@ -20458,9 +20458,13 @@ static ssize_t sg_en_store(struct device *dev, struct device_attribute *attr,
+ return -EINVAL;
+ }
+
+-#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,26)
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(5,19,0)
++/* LINUX_VERSION_CODE >= KERNEL_VERSION(5,19,0) */
++ netif_set_tso_max_size(netdev, tso_size);
++#elif LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,26)
++/* LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,26) */
+ netif_set_gso_max_size(netdev, tso_size);
+-#endif /* LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,26) */
++#endif
+
+ return count;
+ }
+@@ -20620,12 +20624,16 @@ static int rtl8152_probe(struct usb_interface *intf,
+ rtl_get_mapt_ver(tp);
+
+ netdev->ethtool_ops = &ops;
+-#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,26)
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(5,19,0)
++/* LINUX_VERSION_CODE >= KERNEL_VERSION(5,19,0) */
++ netif_set_tso_max_size(netdev, RTL_LIMITED_TSO_SIZE);
++#elif LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,26)
++/* LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,26) */
+ if (!tp->sg_use)
+ netif_set_gso_max_size(netdev, RTL_LIMITED_TSO_SIZE);
+ #else
+ netdev->features &= ~(NETIF_F_TSO | NETIF_F_TSO6);
+-#endif /* LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,26) */
++#endif
+
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(4,10,0)
+ /* MTU range: 68 - 1500 or 9194 */
diff --git a/net-misc/r8152/metadata.xml b/net-misc/r8152/metadata.xml
new file mode 100644
index 000000000000..b840941c9ce9
--- /dev/null
+++ b/net-misc/r8152/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>jay@jvf.cc</email>
+ <name>Jay Faulkner</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>Official Realtek r8152 linux driver. The following cards are currently supported:
+RTL8156 RTL8156B(S)(G) RTL8153 RTL8153B RTL8154 RTL8154B RTL8152B</longdescription>
+ <use>
+ <flag name="center-tap-short">Enable support for center tap short</flag>
+ </use>
+</pkgmetadata>
diff --git a/net-misc/r8152/r8152-2.16.3.ebuild b/net-misc/r8152/r8152-2.16.3.ebuild
new file mode 100644
index 000000000000..bb0eb2cef113
--- /dev/null
+++ b/net-misc/r8152/r8152-2.16.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit udev linux-info linux-mod
+
+DESCRIPTION="r8152 driver for Realtek USB FE / GBE / 2.5G Gaming Ethernet Family Controller"
+HOMEPAGE="https://www.realtek.com/en/component/zoo/category/network-interface-controllers-10-100-1000m-gigabit-ethernet-usb-3-0-software"
+
+SRC_URI="http://rtitwww.realtek.com/rtdrivers/cn/nic1/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="virtual/udev"
+DEPEND="${RDEPEND}"
+
+MODULE_NAMES="r8152(net/usb:${S})"
+BUILD_TARGETS="modules"
+IUSE="+center-tap-short"
+
+# https://github.com/wget/realtek-r8152-linux/ keeps reasonably up to date
+# with kernel support patches. It appears to be used by the AUR maintainer.
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.16.3-kernel-5.19-fix.patch
+)
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="KERNELDIR=${KV_DIR}"
+ BUILD_PARAMS+=" CONFIG_CTAP_SHORT=$(usex center-tap-short on off)"
+}
+
+src_install() {
+ linux-mod_src_install
+ einstalldocs
+ udev_dorules 50-usb-realtek-net.rules
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+ udev_reload
+}
+
+pkg_postrm() {
+ linux-mod_pkg_postrm
+ udev_reload
+}