summaryrefslogtreecommitdiff
path: root/net-misc/zerotier/zerotier-1.14.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/zerotier/zerotier-1.14.0.ebuild')
-rw-r--r--net-misc/zerotier/zerotier-1.14.0.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/net-misc/zerotier/zerotier-1.14.0.ebuild b/net-misc/zerotier/zerotier-1.14.0.ebuild
index 8a00c6b94532..9b3f00cf92ca 100644
--- a/net-misc/zerotier/zerotier-1.14.0.ebuild
+++ b/net-misc/zerotier/zerotier-1.14.0.ebuild
@@ -275,8 +275,8 @@ CRATES="
thiserror@1.0.58
thread_local@1.1.8
time-core@0.1.2
- time-macros@0.2.17
- time@0.3.34
+ time-macros@0.2.18
+ time@0.3.36
tinyvec@1.6.0
tinyvec_macros@0.1.1
tokio-io-timeout@1.2.0
@@ -399,6 +399,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.14.0-respect-ldflags.patch
"${FILESDIR}"/${PN}-1.10.1-add-armv7a-support.patch
"${FILESDIR}"/${PN}-1.12.2-noexecstack.patch
+ "${FILESDIR}"/${PN}-1.14.0-update-time.patch
)
DOCS=( README.md AUTHORS.md )
@@ -413,9 +414,11 @@ src_prepare() {
#1. Dont call cargo, we'll run it with cargo eclass functions
#2. Remove man page compression and install, we'll handle it with ebuild functions
+ #3. Gentoo generates target specific build dirs now bug #937782
sed -i \
-e '/ifeq ($(ZT_SSO_SUPPORTED)/,/endif/ { /cargo build/d }' \
-e '/install:/,/^$/ { /man[0-9]/d }' \
+ -e "s|rustybits/target/$(usex debug debug release)|rustybits/$(cargo_target_dir)|" \
make-linux.mk || die
}